How To Enable SMS Texting (The Green People) from Mac (Instructional Guide)

Discussion in 'iOS 8' started by Inframan, Oct 20, 2014.

  1. Inframan, Oct 20, 2014
    Last edited by a moderator: Oct 20, 2014

    Inframan macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #1
    STEP 1 - Turn Off iMessage on your iPhone and reboot your phone.




    STEP 2 - Sign out of iMessage on your Mac and restart your Mac.


    STEP 3 - Sign back into iMessage from Your Mac - Refer to the image above, Sign in where you signed out


    STEP 4 - Turn iMessage back on in your iPhone and select "Text Message Forwarding"


    [​IMG]
    adult picture hosting


    STEP 5 - Select the Mac you want to use SMS with, make sure you are in-front of that Mac when you are doing this.



    STEP 6 - Once you selected which Mac you want to use SMS with you will receive a code on your Mac to Enter into your iPhone. Enter the code you are provided



    STEP 7 - You should now be able to Send SMS texts from your Mac to all the Green People of the world! I hope this helps and Enjoy!


    [​IMG]
    imgurl
     
  2. Ledgem macrumors 65816

    Ledgem

    Joined:
    Jan 18, 2008
    Location:
    Hawaii, USA
    #2
    The signing out seems to be unnecessary. As mentioned on some other threads, you just need to have both devices set to also use the same email address for iMessage - if you use multiple email addresses, it doesn't seem to require your AppleID email address, just any email address registered for use with iMessage. That should allow the number verification to appear. There are conflicting reports as to whether you need to have both devices continue to use the email address for iMessage, or if you can disable it and go back to only using your phone number.
     
  3. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #3
    In some case yes, signing out is not needed but for me it was necessary. So for the sake of being "full proof" I recommend signing out and back in to avoid any further headaches.
     
  4. stickyfingers85 macrumors regular

    Joined:
    Aug 31, 2010
  5. malevolant macrumors 6502

    Joined:
    Jun 23, 2010
    Location:
    Boston, MA
  6. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #6
    haha yes :) Been vaping since 2006 - haven't had a cancer stick since then!
     
  7. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #7
    All I had to do was go into Messages on my mac and start a message to a phone number I knew didn't support iMessage. It went red and I was then prompted to confirm I wanted to route SMS message through my phone.

    I confirmed I did, was prompted to enter a confirmation number on my phone and that was it.

    I think your guide is very useful for those times it doesn't "just work" but would recommend people try the easy way first ;)
     
  8. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #8
    Happy to hear its working for you :) Been looking forward to this feature for quite sometime now.
     
  9. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #9
    Me too, I had to sign out and back in to get it to work!
     
  10. MacFly69 macrumors regular

    Joined:
    Dec 14, 2008
    #10
    Thank you! This helped a ton.
     
  11. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #11
    You're very welcome! :)
     
  12. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #12
    I had to restart the iPhone a couple of times before it would work.

    On the plus side, SMS relay is working on my 2010 iMac when all along I thought it would because it doesn't have BT LE!
     
  13. brsboarder macrumors 6502a

    Joined:
    Feb 16, 2004
    #13
    I don't have a text message forwarding choice on my iphone 6 running 8.1

    Any thoughts?
     
  14. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #14
    Did you follow the steps the OP outlined above?
     
  15. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #15
    I have it on my 4S, which was not one of the supported devices (as far as I knew). Apple made my day with Continuity phone calls and SMS.

    A.
     
  16. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #16
    Try turning on your Blue Tooth on your iPhone and also your Mac...I think thats how it communicates with the phone to send you your verification code, also try wifi...This is only for the initial set up to get the verification code, afterwards it will use cellular data to send the SMS messages.

    Also make sure you are running the latest version of Yosemite.
     
  17. apptel macrumors newbie

    Joined:
    Jun 22, 2012
    #17
    Any toughts on why you must use an e-mail adress? I tried with just my cell number but its a no go as far as I can tell.

    Even if I set it up with my e-mail and cell number on both my phone and my mac and then remove my email from both settings, as soon as I un-tick the e-mail adress it stops working.
     
  18. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #18
    Bluetooth is used for Handoff, but not for calls and SMS (I have Bluetooth off on all my devices for battery-life reasons).

    I did find I needed to check the box for the phone number in Accounts, rather than just the Apple ID. It may be it needed the phone number, or it could be that the devices need to be consistent - I do not know which.

    A.
     
  19. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #19
    If i remember correctly from when iMessage came out, the phone number was just used to mask the email address. I believe that somehow Apple redirects the iMessages from email to phone number. Because initially iMessage could only be used via email and wifi only, I believe this is how they are achieving rapid messaging. I could be wrong though :D

    ----------

    Correct... Double read my post again, bluetooth might be what Apple is using to establish communication between the iPhone and Mac ONLY to send the verification code to enable the Text Forwarding. The Calls and SMS will be used via cellular data from the phone. I could be wrong but this my best guess. It seems to almost "Pair" the two devices.
     
  20. apptel macrumors newbie

    Joined:
    Jun 22, 2012
    #20
    I see, still at bit annoying. Now who ever wants to message me will have to choose between my e-mail and my cell number as most people have both in their contacts.

    Kind of a stupid question, but will messages from the same contact sort itself in the same thread regardless which address they use? I really don't want to have separate conversations clogging up the messages app...
     
  21. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #21
    Well, double read my post. Bluetooth is off on all my devices. Always. It is not necessary for any part of this process.

    A.
     
  22. Inframan thread starter macrumors 6502

    Inframan

    Joined:
    Jan 18, 2013
    Location:
    Los Angeles, California
    #22
    It will be in same conversation as long as that specific email address is inside the same contact info.
     
  23. houssein31 macrumors regular

    Joined:
    Jul 16, 2013
    #23
    I did exactly what you showed and i can successfully receive SMS BUT when I reply to that person that sent me and SMS (and he has iMessage but can't use it offline) it sends it to them as iMessage.. (and there is a little red exclamation point showing me "message can't be sent")

    The person Im using to test them as an iPhone with iMessage turned on, BUT turned off there wifi and 3g....

    WHAT DO I DO????
    (sorry for the crappy explanation...hope you understand me)
     
  24. Alimar macrumors 6502a

    Alimar

    Joined:
    Sep 17, 2014
    Location:
    New York State
    #24
    I figured it out earlier... when in doubt, restart EVERYTHING! Works like a charm.
     
  25. GaresTaylan macrumors 6502a

    Joined:
    Nov 11, 2009
    #25
    Can't get this to work on my iPad. I followed steps, enabled on both and turn it on on the phone but my iPad never gets the code.
     

Share This Page