How To Get The Watch On WiFi

Discussion in 'Apple Watch' started by bothfly737, Apr 30, 2015.

  1. bothfly737 macrumors member

    Joined:
    Sep 25, 2014
    #1
    So I have a Airport Extreme, and I'm pretty sure my Apple Watch is NOT connecting to WiFi in my house.
    Anyone with a Airport Extreme that has got the watch to connect want to share the steps to get this to work.
    My watch looses connection to my phone when I'm out of BT range, so I have a lot of WiFi coverage at my house and would like to get the watch on the network.
    Thanks
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    There are no steps or procedures to this. The Watch is supposed to use known Wifi hotspots on it's own. I'm assuming your iphone is also connected to your Airport Extreme?
     
  3. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #3
    Yes, I've got the iPhone 6 Plus connected and like I said I'm pretty sure the Watch is not connected
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    From what I remember you should be able to use iMessage and get incoming notifications but not make phone calls. What is and isn't working for you?
     
  5. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #5
    The phone calls are not working when I'm out of range.
    I think it might have to do with my Dual Band AE.
    The Watch does not use 5GHZ, so I bet my iPhone is connecting to the network in 5GHZ and the watch is not. Since there is no way to turn off the 5GHZ on the AE I could rename the 5GHZ band and then force the iPhone to connect to the 2.4GHZ band and see if the Watch jumps on then.
     
  6. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #6
    The watch only connects to 802.11b/g networks, so make sure your phone knows the name/password for your b/g access point. Better yet, use the Airport configuration software to give your b/g network and n (or n/ac) networks the same name.

    Some people have had success removing the wifi network from the phone ("forget" option) and re-adding it.

    The watch will only hop on the network when a BT connection is unavailable from your phone, so don't look for the watch's MAC address to always be connected (at least this is what I've noticed with my own experimentation).
     
  7. colonelbutt macrumors regular

    colonelbutt

    Joined:
    Nov 14, 2007
    Location:
    London
    #7
    how does the watch connect to wifi with passwords ?
    do you enter the data ?
    I thought it just takes it from the iphone (i.e. the iphone programs the wifi on the watch)
     
  8. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #8
    SLOVED!!
    So I enabled my 5GHZ Network with the exact same name as the 2.4GHZ.
    Forgot the network on the iPhone and re added it and that worked.
    I just went way outside in the backyard where I know I have WiFi but more than 100 feet from where my iPhone was and tested a call and it rang on the watch!!
     
  9. vinitmenon macrumors regular

    vinitmenon

    Joined:
    Jun 24, 2013
    Location:
    Canada
    #9
    my phone is connected to 5ghz, disabled bluetooth on phone, but watch works on wifi..
     
  10. a.y.n macrumors regular

    a.y.n

    Joined:
    Jul 7, 2009
    Location:
    San Francisco
    #10
    can you try again after turning off bluetooth on the phone?
     
  11. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #11
    Just turned OFF BT on my iPhone and called it.
    The Watch RANG!!
    So BT OFF
    Watch worked !!
     
  12. Lennyvalentin macrumors 6502a

    Lennyvalentin

    Joined:
    Apr 25, 2011
    #12
    You should have different names for your 2.4GHz and 5GHz networks. Otherwise you can't tell them apart at a glance, and the only way you'll know which is which is if your 2.4GHz network gives you cruddy performance (for example due to neighbors using wifi, or microwave oven interference and so on.) :p
     
  13. a.y.n macrumors regular

    a.y.n

    Joined:
    Jul 7, 2009
    Location:
    San Francisco
    #13
    Weird, I have the same SSID for 2.4 and 5GHz, but the watch doesn't get on wifi at all. I also don't see it on the list of connected devices in Airport Util.

    Do I need to have bluetooth headphones connected to the watch for it to ring?
     
  14. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #14
    I agree, I could name the 5GHz different then force the iPhone on to the 2.4 and that way I know it there.
    What I'm not sure about is if I have both named the same, I assume the iPhone will jump to either the 5 or 2.4 band depending which has a better signal and since the watch can only use the 2.4. I wonder if the watch will drop off wifi when the iPhone get on the 5ghz band.
     
  15. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #15
    Do you have both 2.4 and 5GHz with the same name?
     
  16. Lennyvalentin macrumors 6502a

    Lennyvalentin

    Joined:
    Apr 25, 2011
    #16
    Nah, it doesn't seem to have any specific rules at all from my anecdotal experiences. When I had both 2.4 and 5 bands stored in my keyring, my iThings and Macbook seemed to pick and choose more or less randomly whenever I came home and they reconnected, even though I'd previously manually set them to specifically use the 5GHz network, even maybe preferring 2.4, even though at my place it gives much, much worse performance due to a ton of surrounding networks.

    On my 200Mbit/s cable connection, I'd be lucky to get more than say 15Mbit/s on 2.4; 5GHz band manages 150, 160Mbit/s between my time capsule and 2011 13" Macbook Pro (both support triple stream 802.11n wifi over 5GHz.)

    So to fix this I deleted the 2.4GHz network, and after that all my stuff always picks 5GHz band. Of course, the watch won't be able to use this (once I actually manage to buy a watch that is), but my place is tiny so bluetooth will suffice, and I typically takes off my watch when I get home anyway.

    Well, only experience can teach us that! Do an experiment and report back on what happens! :D
     
  17. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #17
    The AE will not allow you to delete the 2.4, you can rename the 5GHz and then tell your phone to connect to the 2.4 only

    ----------

    I think your Watch won't show up on the WiFi list unless you force it to get on WiFi by either turning off BT on your iPhone or taking the watch out of BT range. If you checked your client list while your watch is near your phone then the watch should be on BT and not WiFi.
    Right now my watch is right next to my phone so it doesn't show up on the wifi list at the moment.

    ----------

    Quoted the wrong guy.

    I think your Watch won't show up on the WiFi list unless you force it to get on WiFi by either turning off BT on your iPhone or taking the watch out of BT range. If you checked your client list while your watch is near your phone then the watch should be on BT and not WiFi.
    Right now my watch is right next to my phone so it doesn't show up on the wifi list at the moment.
     
  18. Lennyvalentin macrumors 6502a

    Lennyvalentin

    Joined:
    Apr 25, 2011
    #18
    You can delete the network from the keyring (like I said) just fine, then your devices can't connect to it anymore (since they don't know about it).

    You can't delete it from the time capsule, which is kind of weird, but I have other devices which can only use 2.4, so it's not something I want to do anyway, heh. :)
     
  19. a.y.n macrumors regular

    a.y.n

    Joined:
    Jul 7, 2009
    Location:
    San Francisco
    #19
    Ya, I turned off BT, ⌚️ doesn't ring when it received calls, and I don't see it on the list of devices on wifi at the AEBS.
     
  20. fischersd macrumors 68040

    fischersd

    Joined:
    Oct 23, 2014
    Location:
    Kitchener, Ontario, Canada
    #20
    A number of people have found that they need to delete and re-add their wifi networks on the iPhone for the watch to pick them up.

    Bug...I'm sure it'll be fixed in an upcoming release.
     
  21. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #21
    And both of your 2.4 and 5ghz are the same name,
     
  22. Dmal99 macrumors 6502

    Joined:
    Sep 29, 2012
    #22
    OP instructions worked for me like a charm. When you turn off the BT on your phone you have to wait a minute or so for the watch to reconnect to WiFi. It works though, and I took a call!
     
  23. bothfly737 thread starter macrumors member

    Joined:
    Sep 25, 2014
    #23
    Here is more info.
    So it seems that when the watch is connected to the phone via BT it takes a while for it to get on WiFi when out of BT range.
    For example I walked outside and tried to make a call from the watch to the house phone I was holding. The call failed.
    So I went back to the iPhone and turned OFF BT. Tested a call to the watch and again it rang, so I knew it was now on WiFi.
    Then walked outside again and called the house, this time it went right through.
    Did a Text message to myself and it went out and came right back to the watch.
    Sooo
    I think if you get this working and your going to be home in your WiFi network then I would turn OFF BT while your in WiFi that way your watch will stay on WiFi and not keep switching back to BT.
    You will just need to remember to turn BT back on when you leave.
    But this seems to work great and extend the range of the watch.
     
  24. priscilla55 macrumors regular

    priscilla55

    Joined:
    Oct 2, 2013
    Location:
    Falkirk, Scotland
    #24
    The wifi thing is definitely working for me. I turned BT off on my watch this morning to test something, got distracted and forgot to turn it back on. Just noticed 9 hours later, but my watch continued working as normal. I've been all over the house while my phone stayed in one room all day.

    I see my wifi address on my watch under settings > general > about
     
  25. a.y.n macrumors regular

    a.y.n

    Joined:
    Jul 7, 2009
    Location:
    San Francisco
    #25
    Weird, I just turned off BT again, and now the ⌚️ is definitely on the wifi, I see it in Airport Util and everything. Wasn't working before, maybe it does take a few minutes for it to connect after losing BT.
     

Share This Page