Other How to listen to music on earphones without Voice Control interfering

Discussion in 'iPhone' started by icymountain, Mar 23, 2017.

  1. icymountain macrumors regular

    Joined:
    Dec 12, 2006
    #1
    I have an iPhone 6s, that I like a lot.

    Except that I cannot use it to listen to music (which I could do 8 years ago with iPhone 3G): when I plug my earphones, and start playing music, Voice Control seems to trigger randomly, often after just a few seconds of playing. So it of course makes it totally impossible to listen to anything.

    What could I do to really kill off this "feature" ?
    I have seen all sorts of methods that require turning on and off Siri and passwords, but none got me anywhere. Plus I *really* do not want Siri or Voice Control at all. I do not care for these, the screen interface is fine with me, and voice interface is a No Go (I do not need to inform the people seated next to me in the metro about what I do or ask my device to do, I cannot get why the smart engineers in Cupertino did not figure this out yet and put an easy off switch to all these).
     
  2. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
  3. Shirasaki macrumors 604

    Shirasaki

    Joined:
    May 16, 2015
    #3
    Your situation is weird actually. I played the music on my iPhone 6s Plus over a year and never encounter such issue.

    Or perhaps you are using a headphone with mic?
    --- Post Merged, Mar 24, 2017 ---
    But voice control cannot be shut off completely.
     
  4. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #4
    Is possible that the headphones have a short or other problem that is constantly attempting to do voice control?
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #5
    Have different headphones been tried? What about cleaning out the headphone jack?
     
  6. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #6
    Thanks a lot for your answers !

    I have indeed de-activated Siri, but that does not turn off Voice Control completely.
    I have tried two sets of earphones, but both have a microphone. So that could be the problem indeed. I may search for yet another set without a mic (though it is not too easy right now, as I am travelling).
     
  7. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #7
    I believe there's a way to disable Voice Control in accessibility settings in iOS 10 at least.
     
  8. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #8
    I think you are referring to "Voice Over".
    My issue is with "Voice Control" that never seems to completely turn off...
     
  9. bradbomb macrumors 6502

    bradbomb

    Joined:
    Jan 7, 2002
    Location:
    Los Angeles, CA
    #9
    It really sounds like something is either messed up with the headphone jack or the pairs of headphones you have. If you have tried multiple headphones, its likely the jack. Remember, headphones with a mic also have a button to answer calls, skip tracks, and on a long hold, activate voice control. The short in either the headphones or the jack is causing it to think there is constantly a long press on the button. Are the headphones you are using from the iPhone 3G or the brand new pair that came with the 6S?
     
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #10
    No, Voice Control: https://support.apple.com/en-us/HT207301
     
  11. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #11
    Ok, thanks, I had not seen that (and the search did not point me to that option). I switched it, and will see and report...
    --- Post Merged, Mar 24, 2017 ---
    I am using third party headphones, that are quite recent. There is a JVC one and a Sony one. I am actually thinking it is likely to be an issue with the Jack (unless the option pointed in the post above fixes my issue). I will see and report!
     
  12. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #12
    So far, it seems to work better than it ever did, so I am hypothesizing that this is the solution ! Many thanks again. I will post if the issue still comes back (and then I would look into the Jack thing).
     
  13. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #13
    Well, it sounds like it might be the workaround, given that it shouldn't be required to turn all that off to avoid it all (as it shouldn't be turning on by itself randomly when you are using headphones).
     
  14. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #14
    Agreed!
    In my search, I also found some webpage showing that some third party jacks have problems with iPhone 6 / iPhone 6s jacks and can use a small rubber band to make them fit slightly differently and avoid some issues. That may actually be the root cause. I cannot find the link right now.
     
  15. icymountain thread starter macrumors regular

    Joined:
    Dec 12, 2006
    #15
    I can now say it is not the solution.

    It is a jack problem. I found that if I do not push the earphone connector all the way into the jack plug the issue does not happen (I have to leave, say about 1mm play). Of course this is not a robust solution. Some websites mention some kinds of "jack plug spacer". Annoying, and ridiculous.

    I cannot test with the earphones supplied with the iPhone right now, as I am travelling far from home.
     
  16. BluKoolAid macrumors newbie

    BluKoolAid

    Joined:
    Dec 11, 2017
    Location:
    Seattle
    #16
    --- Post Merged, Dec 11, 2017 ---
    I am having the exact same problem! It sucks being on an eliptical runner and have the voice control constantly and randomly activate!
     
  17. IonaFC Suspended

    IonaFC

    Joined:
    Feb 9, 2018
    #17
  18. Julien macrumors G4

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #18
    Doubt they waited nearly a year for this answer.
     
  19. Guxandra macrumors newbie

    Joined:
    Mar 2, 2018
    #19
    Hey everyone,

    I also have a 6s and came across this issue recently. I changed what needed to be changed in the settings, but VoiceOver still messes things up. I have the original Apple earphones that came in the box — which works just as fine with my iPod and iPad.

    Could it still be a jack problem as the earphones are soon 2 years old? I formerly suspected that one of the iOS updates might have tricked me... but I don’t know.

    Any ideas? :/
     
  20. posguy99 macrumors 6502a

    Joined:
    Nov 3, 2004
    #20
    Sure. Replace the headphones, like the thread tells you to.
     
  21. 808s, Mar 4, 2018
    Last edited: Mar 4, 2018

    808s macrumors newbie

    Joined:
    Mar 4, 2018
    #21
    I had the same issue with my 5, both with my car's aux cable and my earpods. I had dropped the phone a few times and had the screen replaced when it started happening, so I figured that was the problem.

    However, I just got a nearly new 7 and the same issue is happening with both the headphones and aux cord, even with the lightning to headphone jack. the phone did not come with headphones, but the earpods I am using were brand new in august and not used much with my 5 due to the aforementioned issue. used em sometimes with my ipod classic, but still not much use. I've tried other ways to get voice control to pop up, and none of them work. it only happens when something is plugged in while music is playing, and without any noticeable trigger. It will also fast forward or rewind through entire songs, pause and play repeatedly, and the whole time it's plugged in the controls on the earpods give no response whatsoever.

    I'm probably going to try buying a pair of the lightning headphones and see what happens, but it really does not seem like the headphones could be the issue.
     
  22. justthisonce, Mar 12, 2018
    Last edited: Mar 12, 2018

    justthisonce macrumors newbie

    Joined:
    Mar 12, 2018
    #22
    I’ve joined up today just to reply to this thread.

    I think it’s a bug with the latest update, honestly, I have two Itouch ( 5 & 6 gen) both with apple mic headphones and up until the latest update I never knew there was this seperate music voice control, separate to Siri (which is always off on my devices), but since the update both devices are experiencing this music voice control random trigger.

    Just like described in the quote above the VC takes on a mind of it’s own and sometimes it fast plays a song, shuffles songs, rewinds and late at night it’s creepy AF to have this suddenly do this. I only have apple mic ear buds but I’ve tried swapping my two with other family members headphones (even brand new ones out of the pack) and the same result happens, I don’t even need to be holding down anything, once I sneezed and it triggered it another time I dropped it onto my pillow and it set it off. I’ve spent a few days scouring the web in hopes to find a way to disable this and nothing, even help desk left me with no help. Feb-mar 2018 seems to be the only timeframe where ppl are complaining/asking about this music voice over, this post was one of the later 2017 ones that described the issue perfectly, most it’s just a Siri issue but this is definitely separate to that.

    It’s nuts

    Edit: https://support.apple.com/en-us/HT207301 doesn’t help as those options are now missing under my accessibility > home button, my only options is click speed nothing else... weird.
     
  23. Ppal, Apr 18, 2018
    Last edited: Apr 19, 2018

    Ppal macrumors newbie

    Ppal

    Joined:
    Apr 18, 2018
    #23
    I have the same issue.
    I have an iphone 7 updated wit last IOS.
    I have bluetooth speaker JBL flip4.
    I disabled siri and Voice Control.
    But Voice Control menu still arises.
    When i am listenning music with both in my mountain bike, VOICE CONTROL appears sometimes.
    I think its because of strong trepidations or movements.
    But i want to disable that to happen again and again.
    The issue is with VOICE CONTROL not the speaker! How can i disable that automated function?

    PS: edited to avoid confusion
     
  24. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #24
    What exactly do you mean by "Voice Over" and by "shows up" (given that the thread is mostly about Voice Control)?
     
  25. Ppal, Apr 18, 2018
    Last edited: Apr 18, 2018

    Ppal macrumors newbie

    Ppal

    Joined:
    Apr 18, 2018
    #25
    I mean VOICE CONTROL menu that pops up.
    where i refer VOICE OVER is VOICE CONTROL instead.

    i already disabled VOICE CONTROL but it keeps emerging.
    i think probably its because some kind of connecting issue or something.. but i don't want this kind of response or auto function by my phone, trying to overcome the bump.
     

Share This Page