How to make keyboard go away in SMS App?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ubestbsteppin, Nov 12, 2010.

  1. ubestbsteppin macrumors regular

    Joined:
    May 23, 2008
    #1
    I've never known how/if there is a way to make the keyboard go away or hide while in the SMS app. I know it doesn't pop up until you tap the input box, but is there a way to make it go away after it's already popped up? It's even worse when in landscape mode because reading a long text becomes difficult with the keyboard open.
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    ive been looking for this also, the only way i can make it hide is by hitting messages, which brings you back to the main SMS screen then go back into that contact
     
  3. ubestbsteppin thread starter macrumors regular

    Joined:
    May 23, 2008
    #3
    Yeah. Even though that fix seems simple enough I wish there was a way to do it without backing out of the message. Maybe just tapping the empty space in the message or something could hide the keyboard.
     
  4. Mliii macrumors 65816

    Mliii

    Joined:
    Jan 28, 2006
    Location:
    Southern California
    #4
    That would be a very simple way to do it. And I'd like to have a variation in a different application.When editing a note in the Notes App, I find that it's difficult to GET the keyboard to show up unless the cursor is at the end of the note.
     
  5. OC513 macrumors 6502

    Joined:
    Jul 19, 2007
    Location:
    NYC
    #5
    the best workaround I have figured out is to hit the edit button in the upper right hand corner.....this will make the keyboard disappear....when done just hit cancel. Works great.
     
  6. ubestbsteppin thread starter macrumors regular

    Joined:
    May 23, 2008
    #6
    That one's not working for me on iPhone 4 with 4.1. That would be easier though.
     
  7. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #7
    Glad to know it is not just me who hates that. Like said earlier, I just hit messages and then go back in. It is annoying to say the least.
     
  8. rorschach macrumors 68020

    rorschach

    Joined:
    Jul 27, 2003
    #8
    Hit the camera icon to the left of the message field, then "Choose Existing" then cancel.
     
  9. derf36 macrumors newbie

    Joined:
    Aug 1, 2010
    #9
    that's a great solution, just tried it and its my new move, thanks
     
  10. ubestbsteppin thread starter macrumors regular

    Joined:
    May 23, 2008
    #10
    Are you using an iPhone 4 with 4.1?
     
  11. benhollberg macrumors 68020

    benhollberg

    Joined:
    Mar 8, 2010
    #11
    I hate that now is iOS 4.x if there is an unread message and you open up the SMS app it automatically pulls up the keyboard.
     
  12. Grimes macrumors regular

    Joined:
    Jun 11, 2010
    #12
    This is the only way that works on my ip4 (4.1). I tried the simple "edit" and "cancel" trick, but that didn't work...
     
  13. SAD*FACED*CLOWN macrumors 65816

    SAD*FACED*CLOWN

    Joined:
    Apr 5, 2010
    Location:
    Houston, TX
    #13
    no...this does not work...sorry
     
  14. derf36 macrumors newbie

    Joined:
    Aug 1, 2010
    #14
    yep, iphone 4 with 4.1, no jailbreak.
     
  15. SnowDX macrumors 6502

    Joined:
    Jun 30, 2010
    Location:
    The Great White North
    #15
    I am on 4.1 and clicking Edit does remove the keyboard. (cancel brings it back)
     
  16. Mliii macrumors 65816

    Mliii

    Joined:
    Jan 28, 2006
    Location:
    Southern California
    #16
    This does not work for me.
    And the Camera Button trick works but has too many steps. But so far, it's the best option I can find.
     
  17. OutSpoken macrumors 6502a

    Joined:
    Jun 9, 2009
    Location:
    UK
    #17
    I think its annoying too.

    But I just tried the edit trick on my iP4 4.1(JB) and it worked!
     
  18. shandyman Suspended

    Joined:
    Apr 24, 2010
    Location:
    Dublin, Ireland
    #18
    actually i love it, since i wanna reply to it if i do that....
     
  19. ubestbsteppin thread starter macrumors regular

    Joined:
    May 23, 2008
    #19
    Oh I see what you're saying now. I thought you meant hitting edit and then cancel will cause the keyboard to go away. But you mean that when you tap edit the keyboard goes away, you're free to read the message without the keyboard in the way, then when you're done just tap cancel (bringing the keyboard back). In that sense, it does work but doesn't totally get rid of the keyboard. Still annoying that I can't just make the keyboard go away without a workaround.
     
  20. LSUtigers03 macrumors 68020

    LSUtigers03

    Joined:
    Apr 9, 2008
    #20
    Are you hitting edit then immediately hitting cancel? You can simply hit edit and read what you want then hit cancel. Also if you hit messages then go back to the conversation the keyboard will be gone.
     
  21. Grimes macrumors regular

    Joined:
    Jun 11, 2010
    #21
    I see what you mean. I did try to hit messages and then go back into the conversation, but the keyboard was still there.

    So I have 2 workarounds here that do work, but that is a crude solution. There should be a way to toggle the keyboard on/off.
     
  22. OC513 macrumors 6502

    Joined:
    Jul 19, 2007
    Location:
    NYC
    #22
    exactly.....its a workaround for now.
     
  23. Labamboos macrumors newbie

    Joined:
    Mar 23, 2010
    #23
    Man was I relieved to find that I am not the only one frustrated by this initially innocuous bug...I really hope that :apple: pull their finger out and fix it. Thanks for the solutions...really like the edit one :)
     
  24. Infraggable Kru, Jan 4, 2011
    Last edited: Jan 4, 2011

    Infraggable Kru macrumors regular

    Joined:
    Dec 23, 2010
    #24
    seriously, a bunch of whiny kids

    I can't seriously believe this annoys you people

    what else are you guys going to complain about, the shutter on the camera app?
     
  25. uiop. macrumors 68020

    uiop.

    Joined:
    Jul 22, 2008
    Location:
    Grand Rapids, MI
    #25
    The keyboard will go away so long as there's nothing that's in the typing space above the keyboard. Even if there's just a blank space, it won't go away when you click messages and go back to the conversation. You have to click backspace and make sure there is nothing typed out, then click messages and go back to the conversation.

    I don't know why this is so difficult...
     

Share This Page