How to Stop Birthday Notifications?!?!?!?

Discussion in 'OS X El Capitan (10.11)' started by kappaknight, Jan 7, 2016.

  1. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #1
    I'm currently running on the latest OSX beta, but I think this problem exists in all versions.

    Every time I log into my computer, my calendar pops up notification about various Brithdays, etc. even though those Calendars have been turned off in iCal. Now, even after dismissing it, they pop right back within 5 minutes as an alert on the screen.

    How the hell do I get rid of these? I'd like to keep the Notifications for meetings and stuff on the screen, but the birthday notifications are completely useless to me; more maddening because unlike other calendars, they won't go away if hushed.

    Anyone have a solution?
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Have you tried to turn off birthday and holiday calendars from your other devices such as iPhone? I think this might work. Unfortunately I am not using Mac OS X 10.11.3 beta now so I am not sure if this will work.
     
  3. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #3
    Working correctly for me re: not getting alerts for birthdays.

    A couple things to try. First, turn on "Show Birthday Calendar" and then go to "Alerts" in Preferences and change the Birthday alert to None. Exit Calendar. Relaunch. Then click off "Show Birthday Calendar". That might unstick whatever might be off in the Calendar preferences/settings file.

    Second, might be a corrupt preferences file, so, delete that/those. Sorry don't have which one(s) are there from memory. Should be able to get a good idea by doing following from a Terminal window:

    Code:
    cd ~/Library
    find . -type f -name '*Cal*'
    Also: possibly coming from some other source? Eg. A Google/Outlook/other calendar that is pushing birthday events to Calendar?
     
  4. kappaknight thread starter macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #4
    Birthday calendars have been turned off everywhere that I've seen.
     
  5. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #5
    Are you running Mac OS X El Capitan 10.11.4 beta 1 now? If not, you can try to update to this version or 10.11.3 to see if issue persist.
     
  6. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark

Share This Page