How to undo changes made by BOOTICE to enable AHCI mode in windows 10

Discussion in 'Windows, Linux & Others on the Mac' started by Ole1111, Aug 28, 2015.

  1. Ole1111 macrumors newbie

    Joined:
    Aug 27, 2015
    #1
    I am running windows 10 on macbook pro early 2011.
    I used BOOTICE as described in the link below to enable AHCI mode for SSD drive.
    Tutorial: Enable SATA AHCI Mode in Windows 7,8,8.1 10 | MacRumors Forums


    My problem now is the computer cannot wake up from sleep.
    How can I undo the changes made by BOOTICE and go back to IDE mode and resolve the problem causing the computer not to be able to wake up ?

    The registry file AHCI.Detection.Reset.reg has made the following changes

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride]
    "0"=dword:00000000
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorAV\StartOverride]
    "0"=dword:00000000
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStorV\StartOverride]
    "0"=dword:00000000

    Thank you.
     
  2. macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #2
    You need to restore the old MBR which you patched using BOOTICE. You can do this when you did make a backup of the MBR before the patch.
     
  3. Ole1111 thread starter macrumors newbie

    Joined:
    Aug 27, 2015
    #3
    Well unfortunately I did not make backup.
     
  4. macenied, Aug 28, 2015
    Last edited: Aug 28, 2015

    macenied macrumors 6502a

    macenied

    Joined:
    Aug 20, 2014
    #4
    Well, then:

    • Image backup Windows
    • Delete Windows partition
    • Create new Windows partition
    • Install Windows
    • Restore the Image backup WITHOUT the MBR

    There are many solutions out there for the Windows Image backup. Make sure that you create a emergency boot media for the backup and test it, you need it for the restore. I use Macrium Reflect free ( a complete backup solution for Windows which can do the image thingy as well ;) ).

    There may be other solutions for fixing the MBR, this is the one I am aware about.
     
  5. Michael_80 macrumors newbie

    Michael_80

    Joined:
    Nov 23, 2015
    #5
    This is my first post here and it is going to be a long post so please accept my apologies.

    I have successfully enabled ACHI on my old MacPro 1.1 using Windows 10 64 bit. However I see little to no benefit using this tweak and want to revert back. I also did not make a backup of the MBR (it did not cross my mind and also I saw user macenied very wisely suggesting the backup of the MBR after the steps of the tutorial when I had already completed the process). So...
    I tried the method described in this thread ( http://forums.macrumors.com/threads/tutorial-enable-sata-ahci-mode-in-windows-7-8-8-1-10.1908034/ ) suggested by sanke1:
    "
    #13
    To go back to IDE mode,

    1. Uninstall SATA AHCI controller device from device manager.
    2. Boot into Windows setup preinstallation environment using bootable DVD or USB.
    3. Choose Repair option at the start.
    4. You have to start Commandline from one of those Advanced Troubleshooting options and type this: bootrec /fixmbr
    5. Exit commandline and reboot."


    I also executed other commands such as
    • bootrec /RebuildBcd
    • bootrec /fixMbr
    • bootrec /fixboot
    • Exit
    ...and the result is that whilst I now have in the device manager the old "layout" of devices, ie Standard IDE Controllers, the MacPro cannot go to sleep any more.
    I also tried another thing (which is not mentioned in any suggestion): I opened BOOTICEx64.exe and went to install the MBR using the last option (Windows NT 6.x MBR). Now, instead of unknown MBR it states Windows NT 6x MBR.
    I also enabled minimal boot to windows to redetect the devices - no dice.

    Having taken all the above steps, I would like to know If the above method macenied suggest is indeed working. I am asking this because I have done everything related to MBR (replaced it, repaired it etc) and I still have the sleep problem so I am missing something here - I am afraid that doing the above method will not fix my problem (since I have already done everything related to MBR).
    Maybe there is a registry setting and/or a patch that needs to be reverted in order to be able to go back from ACHI to IDE.
    Please, if someone has tested it and reverted back from ACHI to IDE and his mac can go to and resume from sleep, post here the exact steps taken.
    Thank you all and sorry for the long post.
     
  6. sanke1 macrumors 65816

    sanke1

    Joined:
    Nov 9, 2010
    #8
    You may have to re-install Windows. I was able to perfectly go back to IDE mode on my iMac 2011 with sleep mode.


    Back up your Windows files. Boot into OSX and perform system files and permission check. Then do a fresh install of Windows again.

    I think sleep mode is waste of power. I shut down my iMac when not in use. Hence for me, SATA AHCI mode is totally worth the trade off.
     
  7. Michael_80 macrumors newbie

    Michael_80

    Joined:
    Nov 23, 2015
    #9
    Thank you very much for responding --> you are the only one :)
    I cannot install windows now with all my programms - I will leave it as it is.
    However, it is worth noting that, at least on my mac pro 1.1, converted to 2.1 (8 core 3Ghz, 7970, 32Gb Ram) with an 850 Evo and Rapid Mode enabled I cannot see any difference in performance.
    Also, I always had not only the IDE devices but one ACHI device in the Device Manager before the tweak. Now I have two ACHI devices.
    This makes me believe that, before the tweak, there is a virtual achi device-driver thing here (bios emulation through uefi ?), even though it shows up as IDE (that is why it is also showing an ACHI device). That is the reason I wanted to go back - to have sleep again since performance is the same.
    Never mind..
     
  8. sanke1, Dec 2, 2015
    Last edited: Dec 3, 2015

    sanke1 macrumors 65816

    sanke1

    Joined:
    Nov 9, 2010
    #10
    ^^ That might be if your Mac Pro is having SATA 2. If it is SATA 3, it must make significant difference.
    @Michael_80

    SSDs need SATA 3 on AHCI to show full speed. (If you have a quality SSD and not some cheap one purchased from bargain sale)

    SATA 2 = 3 Gigabit/s (250-275 MBps max transfer speed)
    SATA 3 = 6 Gigabit/s (500-550 MBps max transfer speed)
     

Share This Page