HP Color Laserjet 2600n Issue On MacBook Pro

Discussion in 'MacBook Pro' started by bella92108, Mar 9, 2006.

  1. bella92108 macrumors 68000

    Mar 1, 2006
    I'm not sure if anyone else has been able to come up with a workaround, but I got the MacBook Pro and tried to install my HP Color Laserjet 2600n on it and when trying to print the status is just blank.

    I called HP support and we re-installed and no luck. He put me on hold and came back and said the driver isn't available yet for the intel computers, which to me is somewhat shocking given that it's HP!

    Does anyone know of a workaround to get it to print? I have the printer on the LAN so maybe there's another option? Works fine from the PC (bleh, I got it to be able to print from the MAC)....

  2. screensaver400 macrumors 6502a

    Jan 28, 2005
    “HP is ready. We are proud to announce that full Universal driver support for hundreds of HP peripherals is built into Mac OS X version 10.4.4 Tiger for Intel-based Macs.”

    Considering the 2600n is currently being sold, you'd think drivers for it would be included in the "hundreds of HP peripherals" category.

  3. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    You'd think... but NOT....

    Unless the apple site knows something that HP tier III doesn't, lol. They specifically said that most of their drivers are NOT Intel compat in the case of the imacs and macbook pros... lovely ehhh?

    Still lookin for a workaround peeps... This site is full of geniuses, can't someone come up with SOMETHING, I can't use this printer until you do!
  4. slick316 macrumors 6502

    Sep 28, 2005
    I don't know if this helps or not, but I have that HP 2600n color laser printer and I am using it with an Intel iMac. I have the 2.0 8 June 2005 drivers (same ones I use with my G4 PB). I have the 2600n connected to my wireless Linksys router, and I use my Intel iMac to print wirelessly. The printer is quickly recognized and prints everytime.
    Maybe there is some issue with it when printing via USB or something.
  5. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    I have mine plugged into my linksys router too. HP has even recognized that the current drivers don't work on the macbook pro... so how is it that you've defied HP? I don't believe it
  6. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    Furthermore, I think it's funny when the HP and the Apple pages specifically do not list this model as being supported at this time. Explain that please. I'm guessing you have the 2550 or 2500
  7. taylorpohlman macrumors member

    Mar 1, 2006
    See my post on the thread on Rosetta and printing, but you might try the workaround of forcing your universal binaries to use Rosetta. For example, if you try to print from Safari in native intel mode with a driver that is only ppc, there can be some issues (really shows up with a lot of HP's all in one software). For me, if I force Safari to come up under Rosetta (executing the PPC code version) then the PPC drivers work ok when you try to print. One symptom of the problem is that when you get the print dialog and try to select some of the options (like paper type or layout) you may notice an entry on the list (like "HP all in one") where normally the Print Driver Information entry might be, with the characters struck through. Try quiting the app, going to the finder, selecting the app and then "get info" and checking the "start using Rosetta" box. When you restart the app, the print driver should appear ok (correct function name, no line through). This is especially a problem if you use printer sharing and your print server is a PPC mac. You won't notice this with Word, Excel, etc of course, because they run only under Rosetta. Hope this helps, may not work with all drivers, and running native apps under Rosetta is a pain, I know.
  8. MisterMe macrumors G4


    Jul 17, 2002
    After looking at your printer's specs on HP's website, I am mystified why you are having so many problems. Contrary to your post, the HP Color LaserJet 2600n is supported by HP for MacOS X. It is a Bonjour-compatible PostScript (clone) printer with an Ethernet port. The HP's installer installs a PPD file on Mac, which tells the OS which features are available. It should "just work" using Apple's PostScript driver. There is nothing that is specific to which processor is in your Mac. I am no longer a fan of HP printers, but I am at a loss what more HP could have done with the HP CLJ 2600n.
  9. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    It sure is nice to have these forums, as I'd be lost without them... I just became a MAC from the PC world two years ago so while I've learned a ton, I still have a lot to go.

    What's happening is it installs fine, but then when I go to print something from say... Safari, it opens the Print Status window, says the job name (name of the document) but then under status it just says "-" as in nothing, just a dash. HP's explanation of this is that since the driver isn't Intel Compat, the driver just isn't initializing... but to me (at least from my experience) sounds like a bunch of hoolabahoo....

    Would it work to use the 2550 or 2500 driver built in? I'm just unsure as to next-steps. It sounds like there's a lot of confidence that it should work, so I kinda don't want to sit idle while HP Develops their driver if all that's going to happen is I install their crap and the status is still "-" because of some OTHER issue...

    Help :)
  10. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    Did you look at the apple site? If you look at the supported Intel Mac list of HP drivers, the 2600n is NOT on it, so please, enlighten me with where you see that it is.
  11. AlmostThere macrumors 6502a

    The 2600n does NOT understand postscript.

    There is an open source driver but I don't know how well, if at all, this works under OS X.

    If the OP wants to give it a go the download link is http://foo2hp.rkkda.com/
  12. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    It baffles me to get such contradictory information on here. However, it makes more sense that the printer is NOT postscript, since all of the other printers that HP has on the list seem to be and ... what... oh yeah the 2600n is NOT on the list and shows that there is NO intel-mac support for them yet.

    Unless someone can give me evidence otherwise, I'm going to consider this case-closed until HP releases their Intel version of the driver for the 2600n. I've read in numerous places, as well as claims from HP that nobody has been able to make this thing work on the Intel macs, wish it wasn't true, but what can I do? Regret that I got a MacBook Pro? As slow as Acrobat and Photoshop run, along with the bugginess in a lot of these universal apps that are being rushed to market I'm starting to get agitated... lol... altho webpages load so quick :)

  13. adk macrumors 68000


    Nov 11, 2005
    Stuck in the middle with you
    HP printer drivers are horrible on PPC, good luck getting one to work on an intel.
  14. taylorpohlman macrumors member

    Mar 1, 2006
    Bella92108 - did you try the workaround using Rosetta that I posted above? When you say your driver shows just a dash, it makes me think that you've got that PPC driver with intel native app problem - what application are you trying to print from? Are you forcing that app to run using Rosetta and still having the problem, or not? Please check posts with suggestions, and comment on whether or not they work - that's what we're here for...

  15. FBDiver macrumors newbie

    Mar 11, 2006
    Pacific NW, USA
    I had one of these (2600) onsite for pre-release testing from HP, and I had similar problems even on intel based PC's. They confirmed my sighting as a bug, and I think they released a firmware update, but I haven't kept up on it as we ended up moving the printer into an office and connecting directly to a PC. HP did get it working for me before I moved the printer, but again this was before the printer was acutally shipping.

    Basically when I installed this printer on the print server (server 2003) I couldn't print a test page, it would say it was sent but nothing printed. Yet if you sent a Word document that was on the local drive it printed fine, if you printed a Word document ( or anything else ) that was on a network drive it did the same thing as the Test Page, nothing ever printed, no errors, nothing.

    Not sure I actually answered any questions, but maybe this gives you another data point in resolving this issue.

    Good luck!
  16. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    Well the underlaying issue is in order to print I don't want to launch my apps in rosetta, lol. I'm not sure if it works that way or not... it doesn't make sense that I would have to do that. Well, it makes technical sense, but not common sense, lol. I didn't get a MacBook pro for this to happen. Regardless, I'm not entirely convinced it is in fact a driver issue, because what happens is in the print center when a document goes to it, it says DOCUMENT NAME and the correct document displays (ie andrew.doc or whatever)... and then STATUS and under the status where it would normally say PRINTING or PENDING it just has a - dash.... I've tried from internet explorer and textpad... I have uninstalled and reinstalled the driver, updated the firmware on the printer, and tried both printing to the USB side of it AND the NETWORK side, neither work... same result on both.

    I tried troubleshooting this way too (I may sound like an idiot on the mac side because I just got into it two years ago, but I've been on PC for ages)... and what's odd is that when I set up the printer on the PC and share it on the network, then do windows printing services from the mac, that happens, I print and it shows the job in the print que on the PC but then nothing ever hit the printer, it just went into the que on the PC and said "PRINTING" yet it never printed, so I'm guessing the Mac is sending bad data to the PC... oye....
  17. Teggy macrumors newbie

    Apr 20, 2006
    I have an Intel Mini. It would not recognize the 2600n drivers until I updated the firmware that is on the HP site. After doing so (you'll need to temporarily connect via USB) it found the driver right away and I was able to switch to using the printer over the network.
  18. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    I'm very curious as to how you did this. HP has said it's not possible, as well as everyone that's posted to this forum has said it's not posisble on an Intel system as well. I upgraded the firmware then reinstalled the HP software (the current version I downloaded from the website) so I'm trying to understand that if you have the HP COLOR LASERJET 2600N, how in the world it works for you, yet HP claims it won't, Apple claims it won't, and countless people who have tried to get it to work have said it does NOT work, even after the firmware update. The incompatability issue is in their driver, NOT the FIRMWARE on the printer.

    Please give more details....

  19. Teggy macrumors newbie

    Apr 20, 2006
    Don't know what to tell you...I definitely have the HP Color Laser Jet 2600n (I'm reading the model number right off the front), and it didn't work when I first installed the drivers (the printer utility wouldn't even find the drivers), but once I updated the firmware Bonjour found it perfectly.

    There is one thing I am curious about. I intially installed the drivers that were on the site, but then installed the drivers from the CD over them. The dialog button said "upgrade". I don't know if that is just a generic thing os x does when it finds any version of the existing software. It would seem strange that the CD drivers would be newer than the ones online.
  20. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    I'm still having issues with this, since you say Bonjour is printing it, why would that be? On a network printer like this Bonjour wouldn't find it, and the HP app doesn't find a network printer for mac, it has to be manually configured... are you talking about booting in windows and using it through there on your intel mac?

    The drivers on the web are NEWER than the ones on the CD.... so that solution wouldn't make any sense. I'd like to see that printer actually print something from a mac... because if the manufacturer claims it not possible and countless websites where people have tried and failed.... I just don't see that as a valid claim.

  21. Teggy macrumors newbie

    Apr 20, 2006
    The printer is plugged into one of my wireless access points and I am able to access it (including the internal web pages) via my intel Mini.

    I'm not sure what you mean about Bonjour not being able to find it. Even the HP instructions say simply let the computer find the printer via Rendezvous (obviously printed pre-Tiger).

    When I first plugged in the printer to the network, the Printer Setup Utility found the printer via Bonjour and even specified it by name. The only thing it was unable to do was find the driver. Once I updated the firmware, it found the printer and the driver without any intervention.
  22. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    OK so I followed you to the point of seeing it as a Bonjour printer, but then it doesn't find the driver, the pull down menu says select driver and there's no 2600n option (obviously)... it didn't pull the driver FROM the printer, and updating the firmware ONLY updates the printer, not the computer, so there's something you'd done that isn't matching here... did u install the CD software prior to this? Those drivers had to have come from one of the installers.
  23. Teggy macrumors newbie

    Apr 20, 2006
    Yes, prior to updating the firmware I installed the drivers from the CD. Perhaps the old drivers are the key?
  24. Nutsy macrumors newbie

    Apr 21, 2006
    I bought a 2600n a few months back and it worked no problem on my PPC Macs.

    I just bought another 2600n two weeks ago, and also bought a MacBook Pro. Prints flawlessly.

    I think your problem is that you installed the software that came with the printer.

    I never did that on my MacBook Pro and it works just fine.

    Try deleting anything to do with HP 2600n on your machine, restart, and then try printing.

    BTW, I am printing via ethernet, via router.

  25. LonelyNinja macrumors newbie

    Jul 20, 2006
    Working Printer HowTo


    I got the printer working on a 13" MacBook running Mac OS X 10.4. Here's how...

    Linksys BEFW11S4 WAP & Router
    MacBook (13") 2.0 GHz
    Mac OS X 10.4
    HP Color LaserJet 2600n, printing via Ethernet

    1. In System Preferences->Print & Fax, remove previous attempts at installing the printer.
    2. Go to http://h20000.www2.hp.com/bizsuppor...iesId=446153&swLang=8&taskId=135&swEnvOID=219
    and get teh HP color LaserJet 2600n OS X Universal Binary Full Software Solution.
    Go to hp.com
    Click Software and Driver Download
    Click Printing and Multifunction
    Click Printers
    Click HP Color LaserJet Printers
    Click HP Color LaserJet 2000 Printer series
    Click HP Color LaserJet 2600n Printer
    Click Mac OS X (NOT Mac OS X 10.<whatever>)
    Follow the instructions above.

    3. After you download it, install it.
    4. Load System Preferences -> Print & Fax and add a printer. It should (theoretically) detect the printer via Bonjour. If not, add it. The driver will detect automatically.

    If it doesn't detect automatically, you may have to manipulate it to get it installed somehow, but I didn't face this problem so I couldn't say how to correct it.

Share This Page