I CANNOT DO A RESTORE - The device isn't eligible for the requested build

Discussion in 'iPhone Tips, Help and Troubleshooting' started by roflcopter101, Jul 18, 2010.

  1. roflcopter101 macrumors newbie

    Joined:
    Jul 18, 2010
    #1
    Hey guys i got my iphone 3gs and it was working fine on FW 3.1.3 and now i stupidly upgraded 4.0.1 ( or whatever itunes is upgrading too) and now i cant restore back to any firmware version. It always gives me the same message. “The Iphone could not be restored. The device isn't eligible for the requested build”. Please help me fix this
     
  2. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
  3. draz macrumors 6502a

    Joined:
    Jun 20, 2010
    #3
    You can go higher... but you can't go lower.

    Well you can... but not as easy as you thought :p
     
  4. roflcopter101 thread starter macrumors newbie

    Joined:
    Jul 18, 2010
    #4
    how do i fix it. I cant do anything with it now because its not unlocked. Its not jailbroken
     
  5. draz macrumors 6502a

    Joined:
    Jun 20, 2010
    #5
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    With the 3GS and now i4 models you cannot restore to anything but the latest firmware version thats out.
    Very bad move.
    Never update a JB or unlocked iphone again to official firmware thru itunes cause it will always lock up. The unlock is not permanent, its only thru software.
    If you have SHSH's saved on file locally or on cydia for 3.1.3 you can restore to that. If not you just gotta wait for a new JB and unlock to be released.
    Lesson learned I hope.
     
  7. Dr Kevorkian94 macrumors 68020

    Joined:
    Jun 9, 2009
    Location:
    SI, NY
    #7
    epic fail i feel sorry, but like many said that was a very bad move
     
  8. mrat93 macrumors 65816

    mrat93

    Joined:
    Dec 30, 2006
    #8
    If you have the old bootrom, you might have a chance at unlocking it. I'm not too sure though. I know for a fact that yu can't jailbreak or unlock the newer bootrom models.
     
  9. roflcopter101 thread starter macrumors newbie

    Joined:
    Jul 18, 2010
  10. splashnader macrumors 6502a

    splashnader

    Joined:
    Jul 1, 2008
    Location:
    Via Satellite
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    Wrong facts.
    Bootrom doesnt mean it can be JB.
    Currently there is no JB tools available to JB any iphone 3GS model on official 4.0 or 4.0.1
     
  12. roflcopter101 thread starter macrumors newbie

    Joined:
    Jul 18, 2010
    #12
    so is my iphone totally inoperable until the new JB comes out?
     
  13. compg318 macrumors regular

    Joined:
    Dec 1, 2008
    #13
    Not entirely true. If he has a backed up shsh on Cydia which he more than likely does if he was jailbroken prior, he can downgrade back, Jailbreak with blackra1n or anything else but Spirit. And restore to a modified ipsw created with Pwnage Tool.
     
  14. Sinfire macrumors regular

    Joined:
    Apr 23, 2010
    #14
    Doesn't the phone have to be Jailbroken before it can be downgraded, or even connected to cydia ?
     
  15. Sinfire macrumors regular

    Joined:
    Apr 23, 2010
    #15
    The phone still works. Just get a plan from AT&T and download apps from the App store. Otherwise, it can still work as an iPod, and you can connect to wireless networks for your data needs.
     
  16. roflcopter101 thread starter macrumors newbie

    Joined:
    Jul 18, 2010
    #16
    i have tmobile, no att sim card
     
  17. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #17
    What I said is entirely true. There is nothing now to JB any 3GS model on official 4.0 or 4.0.1
    Exactly if he has SHSH's. He cannot JB on 4.0 but only downgrade to 3.1.3 and then JB and unlock IF.
    And its not always a definate thing everyone that was JB has SHSH's backed up on cydias server.
    What was mentioned above was that if you got the old bootrom you're ok. And that clearly is not the case.
     
  18. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #18
    then use your shsh, which it prob do have, to downgrade to 3.1.2 then custom fw back to 4.0
     
  19. roflcopter101 thread starter macrumors newbie

    Joined:
    Jul 18, 2010
    #19
    how do i do that. how do i use shsh?
     
  20. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #20
    windows or mac?
     
  21. roflcopter101 thread starter macrumors newbie

    Joined:
    Jul 18, 2010
    #21
    mac. i never jailbroke it though, didnt have cydia
     
  22. goobot macrumors 603

    goobot

    Joined:
    Jun 26, 2009
    Location:
    long island NY
    #22
    so how did you unlock?
     
  23. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #23
    You got alot of research and reading to do.
    Do you remember when you opened up cydia if on the top of the page if it displayed something like this?: "This device has SHSHs on file for iPhone OS 3.1.2, 3.1.3 etc...
    [​IMG]

    What you will need to do is edit your hosts file to redirect to cydias server to get your shshs in order for itunes to let you downgrade your iphone 3GS.
    Then download either an official 3.1.2 or 3.1.3 ipsw file and try to hold down shift-restore or option-restore and select one of those firmware files.
    If it lets you restore then you can use previous JB tools to JB it and then install ultrasnow thru cydia to unlock it.
    But just by your questions I dont know if you're up for this long and complicated many step process.
     
  24. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #24
    WTF?
    Dude, get it together.
    We cant help you if you cant help yourself with some straight answers with what you're trying to do and what you had before and how.
    Were you JB and unlocked or no?
    Did you have installed cydia or just rock maybe? Did you click make my life easier when you first opened up cydia assuming you had cydia installed?

     
  25. splashnader macrumors 6502a

    splashnader

    Joined:
    Jul 1, 2008
    Location:
    Via Satellite
    #25
    All throughout this thread you have at times made it sound as if your iphone, prior to the upgrade was not jailbroken. Everyone else, apparently, except for me was under the impression that your phone was jailbroken. But now again you are saying your phone was never JB. It's almost impossible to figure out what you did.

    If your phone was prior JB you should have known not to upgrade to latest FW.
     

Share This Page