I cant upgrade my firmware on itouch

Discussion in 'iPod touch' started by AlexavieI2, Oct 30, 2010.

  1. AlexavieI2 macrumors newbie

    Joined:
    Oct 30, 2010
    #1
    Hey ppl im new in these thread. I have an ipod touch 1st gen and it has the firmware 2.2.1 i want to upgrade to 3.1.2 or 3.1.3 or anything else because I want to download apps etc etc. i have tried to update the ipod but itunes says this: The ipod "AlexavieI2" could not be updated because the firmware file is not compatible.

    And when i click on check for update it says: This version of the iPod software (2.2.1) is the current version.

    Help me please!!!:(
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
  3. AlexavieI2 thread starter macrumors newbie

    Joined:
    Oct 30, 2010
  4. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #4
    No, 2.2.1 is as high as a 1st gen will go. But 2.2.1 is compatible with the app store, so you can still have apps on it.
     
  5. AlexavieI2 thread starter macrumors newbie

    Joined:
    Oct 30, 2010
    #5
    but few ones. I can't have like facebook i can't have games......... for 90% percent of the apps I need 3.0 or up. Thats what app store tells me when I try to install something.
     
  6. BigDukeSix macrumors 6502a

    BigDukeSix

    Joined:
    Sep 22, 2010
    Location:
    34.6700N 118.1590W
    #6
    And that is exactly how Apple and all the other companies keep their sales up. If you want the latest apps, software, or what ever, you eventually have to buy a new piece of hardware that will run 'em.
     
  7. macking104 macrumors 6502

    macking104

    Joined:
    Jan 14, 2003
    Location:
    California, USA
    #7
    iPod Touch 1st gen update to 3.1.3

    To upgrade to 3.1.3 you need to:
    1) update iTunes on your computer
    2) update op system here: http://support.apple.com/kb/HT2052
    It says purchase so I think they still charge.
     
  8. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #8
    No, the first gen can go to 3.1.3. That is what I have on mine.
     
  9. apaulct macrumors newbie

    Joined:
    Jun 25, 2009
    #9
    iOS 3.x was a $10 upgrade from 1.x or 2.x when it was released. Guess Apple is still charging the $10. We are running 3.1.3 on our 1G and 4.1 on our 4G touch.
     

Share This Page