I changed the account name on my Admin account and now I can't log in

Discussion in 'Mac Basics and Help' started by mango2016, Sep 11, 2018.

  1. mango2016 macrumors newbie

    Joined:
    Sep 11, 2018
    #1
    Macbook Pro 2017 running on macOS High Sierra.

    Okay, so I can log into my computer fine (so far) but if I were to try to make changes, like in System Preferences and it asked for my Admin Username and Password, both slots show up empty and if I put in my username and password as they are, it won't accept it. I am still on my admin account by the way.

    Yes, I was one of those idiots that ignored the warning when I went to Advanced Options that I might not be able to log in if I changed that info. I had just really wanted a new username in the corner of my Macbook *sigh*

    How can I fix my mistake?
     
  2. chscag macrumors 68030

    chscag

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
  3. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #3
    I would consider setting up a new admin account, via command line. Once you have a new fully functioning admin account, you can more easily fix or replace your previous account to get back to your data.

    Here is a good write up for resetting the preference that you get on a new Mac to setup a new account.

    Do steps 1 to 6 and you will have a new account.

    Once that is done, you can work on fixing your previous account. Remember this will build a new, fresh account, and not touch your old account.
     
  4. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    Changing the name of your user account is something you should NEVER attempt to do unless you have the knowledge as to WHAT to do and how to accomplish it.

    Change the password? Yes, that's fine.
    But the account name?
    You could end up in a bag of hurt.

    I'd try the link hobo suggested above.
    If that just confuses you, come back, and perhaps we can make other suggestions...
     
  5. mango2016 thread starter macrumors newbie

    Joined:
    Sep 11, 2018
    #5
    Okay, so I haven't tried any of the links yet since I haven't had time, but earlier today I connected my laptop to my university's wifi and was prompted to enter my username and password. It was normal -- my username was there, I entered my password and it went through.

    But it still doesn't work when I do anything else, why did it work with the wifi situation? I will still go ahead and try that link, though.
     
  6. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #6
    Accounts are much more messy than they appear at first glance.

    Even more so if you are connecting to an enterprise network with a directory server...sounds like that is not the case. If you have a directory server, the credentials would get passed to it for logging in and perhaps other services (wifi, email, etc.).

    Just logging in does not mean you have access to many other services, not to mention have correct permissions.

    There are ways to fix, but for me the easiest is have a working, fully functional admin account.
     

Share This Page