"I" is no longer capitalized when typing with auto-capitalization off. Any fix for this?

Holmes31

macrumors member
Original poster
Jun 6, 2011
32
1
"I" was always capitalized in the middle of a sentence but now in iOS 10, it's not. Anyone else notice this?
 

Andrew.s

macrumors 6502
Jul 14, 2007
262
83
Inland Empire
Are you noticing this in a specific app? I just tried it out in Messages and it's auto capitalizing it for me. It's also working in Safari on this forum. You can tick Auto Cap off and back on? Or make sure it wasn't turned off?

EDIT: I literally just re-read your thread title. I've always had it on so not aware of how it worked on previous iOS versions so I can't speak to that but I'd assume that's your reason there. Apologies.
 
Last edited:

Holmes31

macrumors member
Original poster
Jun 6, 2011
32
1
it's like this in all apps. maybe it has to do with my keyboard dictionary specifically. i'd like to avoid resetting it though if i can.


^you can see the issue with the "I's" in this post
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
49,870
18,366
There are definitely some oddities when it comes to the keyboard in iOS 10. I've ran into this as well as into the keyboard not changing back to "ABC" after using some punctuation.
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,888
1,360
New Zealand
This may have been overlooked when fixing a different bug: In 9, if you typed, for example, Shift-A, then Backspace, then B, it would display "B" instead of "b". In other words, the Shift keypress would still apply even though you hadn't pressed it the second time. That's been fixed in 10, but possibly flowed through to the issue that you're seeing now.
 

Andropov

macrumors 6502
May 3, 2012
257
98
Spain
Settings -> General -> Keyboard -> Text Replacement -> Add

Phrase: I
Shortcut: i

Kind of a workaround, but that should fix it.

EDIT: Doesn't work, shortcuts need to be 2 characters or more
 

addamas

macrumors 6502
Apr 20, 2016
269
100
Is there any way to erase personal dictionary in Apple Keyboard? This should help in this problem.
 

anslo

macrumors newbie
Jan 17, 2017
1
0
"I" was always capitalized in the middle of a sentence but now in iOS 10, it's not. Anyone else notice this?
I've run into the same problem.... it's hateful.. has anyone figured this out? so tired of capitalizing my own pronouns lol
 

GreyOS

macrumors 68040
Apr 12, 2012
3,308
1,640
For countless others this was probably a bug - it was auto-capitalising with auto-capitalise off - so they fixed it. I'm afraid there is no setting for "auto-capitalise some things but not others"
 

ashindnile

macrumors 6502
Jul 16, 2015
385
156
There's a fix. But it isn't immediate.
You need to type i and in suggestions always pick I. Then delete and do it again. Once you've done this a couple times, every time you type in lower case, it automatically replaces with upper.
If you can't find I in suggestions, type in i, space then get back delete and type I. Do this a couple times as well. Essentially, get the keyboard to 'learn' this.
 

robbi

macrumors newbie
Feb 8, 2019
1
0
There's a fix. But it isn't immediate.
You need to type i and in suggestions always pick I. Then delete and do it again. Once you've done this a couple times, every time you type in lower case, it automatically replaces with upper.
If you can't find I in suggestions, type in i, space then get back delete and type I. Do this a couple times as well. Essentially, get the keyboard to 'learn' this.
[doublepost=1549646734][/doublepost]The capital I doesn’t come up as a suggestion. So frustrating!
 

Saato

macrumors newbie
Jun 10, 2019
2
0
[doublepost=1549646734][/doublepost]
The capital I doesn’t come up as a suggestion. So frustrating!
I’ve found that I will capitalise in certain apps, mainly Microsoft apps, eg Word, but not in apps like Apple Pages/Notes/Safari.

I just dont use the Apple apps anymore as a result. It’s really annoying with web based stuff though. E.g. you need to go through your entire post and change all your “i” to “I”. I have no idea why this is so hard to code at the OS level? Seems pretty straight forward. I don’t know how people can live with this on a daily basis.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.