"I" is no longer capitalized when typing with auto-capitalization off. Any fix for this?

Discussion in 'iOS 10' started by Holmes31, Sep 11, 2016.

  1. Holmes31 macrumors member

    Joined:
    Jun 6, 2011
    #1
    "I" was always capitalized in the middle of a sentence but now in iOS 10, it's not. Anyone else notice this?
     
  2. Andrew.s, Sep 11, 2016
    Last edited: Sep 11, 2016

    Andrew.s macrumors 6502

    Andrew.s

    Joined:
    Jul 14, 2007
    Location:
    Inland Empire
    #2
    Are you noticing this in a specific app? I just tried it out in Messages and it's auto capitalizing it for me. It's also working in Safari on this forum. You can tick Auto Cap off and back on? Or make sure it wasn't turned off?

    EDIT: I literally just re-read your thread title. I've always had it on so not aware of how it worked on previous iOS versions so I can't speak to that but I'd assume that's your reason there. Apologies.
     
  3. Holmes31 thread starter macrumors member

    Joined:
    Jun 6, 2011
    #3
    it's like this in all apps. maybe it has to do with my keyboard dictionary specifically. i'd like to avoid resetting it though if i can.


    ^you can see the issue with the "I's" in this post
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    There are definitely some oddities when it comes to the keyboard in iOS 10. I've ran into this as well as into the keyboard not changing back to "ABC" after using some punctuation.
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    This may have been overlooked when fixing a different bug: In 9, if you typed, for example, Shift-A, then Backspace, then B, it would display "B" instead of "b". In other words, the Shift keypress would still apply even though you hadn't pressed it the second time. That's been fixed in 10, but possibly flowed through to the issue that you're seeing now.
     
  6. Andropov macrumors regular

    Andropov

    Joined:
    May 3, 2012
    Location:
    Spain
    #6
    Settings -> General -> Keyboard -> Text Replacement -> Add

    Phrase: I
    Shortcut: i

    Kind of a workaround, but that should fix it.

    EDIT: Doesn't work, shortcuts need to be 2 characters or more
     
  7. Holmes31 thread starter macrumors member

    Joined:
    Jun 6, 2011
    #7
    Shortcuts need to be at least two letters unfortunately
     
  8. Andropov macrumors regular

    Andropov

    Joined:
    May 3, 2012
    Location:
    Spain
    #8
    True, didn't know that. Sorry then, no workaround.
     
  9. addamas macrumors 6502

    addamas

    Joined:
    Apr 20, 2016
    #9
    Is there any way to erase personal dictionary in Apple Keyboard? This should help in this problem.
     
  10. anslo macrumors newbie

    anslo

    Joined:
    Jan 17, 2017
    #10
    I've run into the same problem.... it's hateful.. has anyone figured this out? so tired of capitalizing my own pronouns lol
     
  11. GreyOS macrumors 68040

    GreyOS

    Joined:
    Apr 12, 2012
    #11
    For countless others this was probably a bug - it was auto-capitalising with auto-capitalise off - so they fixed it. I'm afraid there is no setting for "auto-capitalise some things but not others"
     
  12. ashindnile macrumors 6502

    Joined:
    Jul 16, 2015
    #13
    There's a fix. But it isn't immediate.
    You need to type i and in suggestions always pick I. Then delete and do it again. Once you've done this a couple times, every time you type in lower case, it automatically replaces with upper.
    If you can't find I in suggestions, type in i, space then get back delete and type I. Do this a couple times as well. Essentially, get the keyboard to 'learn' this.
     
  13. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland

Share This Page