Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

NostalgiaGuyOfficial

macrumors newbie
Original poster
Dec 14, 2019
4
0
USA Phoenix Arizona
I keep getting errors when trying to install macos mojave on an mac pro 4,1
im using dosdudes mojave patcher to put mac os mojave on my usb for installation
but whenever i start the patcher and make the installation usb in the verbose view it keeps getting an error called
/dev/disk4 GUID_partition_scheme
/dev/disk4s1 EFI
/dev/disk4s2 Apple_HFS /private/tmp/installesd
Validating target...done
Validating source...done
Retrieving scan information...done
Validating sizes...done
Restoring ....10....20....30....40....50....60....70....80....90....100
Remounting target volume...done
cp: /Users/aldendepooter/Desktop/macOS Mojave Patcher.app/Contents/Resources/prelinkedkernel: could not copy extended attributes to /Volumes/Untitled/System/Library/PrelinkedKernels/prelinkedkernel: Operation not permitted
"disk4" unmounted.
"disk4" ejected.
Any help would be appreciated
 

Velin

macrumors 68000
Jul 23, 2008
1,600
1,063
Hearst Castle
I keep getting errors when trying to install macos mojave on an mac pro 4,1
im using dosdudes mojave patcher to put mac os mojave on my usb for installation
but whenever i start the patcher and make the installation usb in the verbose view it keeps getting an error called

Post is unclear. Are you getting errors making the Mojave bootable USB? Or errors installing Mojave on the 4.1 Mac Pro? Your post says both.

Also note, if the Mac Pro 4.1 currently has High Sierra, you may want to flash the firmware if your box has a GT120, you'll need that EFI update. Though this is irrelevant to your immediate problem if you're stuck at the bootable USB stage.
 
  • Like
Reactions: Sweetfeld28
Comment

NostalgiaGuyOfficial

macrumors newbie
Original poster
Dec 14, 2019
4
0
USA Phoenix Arizona
well im not running mac os high sierra but el capitain.
and yes when making the usb i get an error but after that i can boot off the usb but then when i try to install mac os mojave
in the installation it keeps saying that the packages arent eligible for install
the maximum support for my mac pro is el capitain and i would like to get mojave on it
i tried several mac os mojave install apps but all of them got the same error when making the usb and installing.
BTW Thanks For Replying
 
Comment

Sweetfeld28

macrumors 65816
Feb 10, 2003
1,474
21
Buckeye Country, O-H
Search Youtube for how to Flash the 4,1 firmware to a 5,1. Then after covering to a 5,1; you should be able to go to the app store and upgrade it from there. This will then let you install Mohave, as Mohave is the last OS my 5,1 MP is able to run.
 
Comment

Velin

macrumors 68000
Jul 23, 2008
1,600
1,063
Hearst Castle
Yep. I pointed that out, first thing s/he needs to do is that firmware flash, especially if running a GT120. As for the bootable flash drive, if you're getting an error when making it, I don't see how it's going to work for an OS install.
 
Comment

MacUser2525

Suspended
Mar 17, 2007
2,097
369
Canada
The other posters left out you need a Metal capable GPU in the machine as well as the updating of the firmware to a 5,1 machines to do that install. I put an AMD rx560 in my 4,1 > 5,1 when I tested the process. The High Sierra full installer is required as it contains the firmware to upgrade the machine, once that is done then you can if you have supported GPU start the mojave installer which will further upgrade the firmware again allowing an install of it on the machine. I do not think I have left anything out.

Edit: and there is the thread I was thinking about when writing this that appeared on the next page.

https://forums.macrumors.com/thread...-bootrom-upgrade-instructions-thread.2142418/
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.