I want mojave on my Macbook 4,1 (early 2008)

brandonsierra

macrumors newbie
Jun 10, 2017
3
1
0
I want to find a way to get macOS Mojave on my Early 2008 MacBook 4,1 Polycarbonate. I've heard from Adam (Sparked Tech) that he got it working on his 4,1. so how can i. I hope there is a way soon for the Macs that have OS X 10.7.5 as their highest OS.
 

Riwam

macrumors 6502a
Jan 7, 2014
989
203
0
Basel, Switzerland
With great effort I managed to update my MacBook 4.1 to Yosemite and even my Yosemite is not very reliable and needs frequently to be rebuilt with Disk Warrior.
I cannot imagine Mojave working nicely with such old hardware. :rolleyes:
 

hrvatko

macrumors newbie
Aug 3, 2019
4
3
0
I want to find a way to get macOS Mojave on my Early 2008 MacBook 4,1 Polycarbonate. I've heard from Adam (Sparked Tech) that he got it working on his 4,1. so how can i. I hope there is a way soon for the Macs that have OS X 10.7.5 as their highest OS.
It works on that hardware, with small issues:
MINOR:
scrambled search bar icon in Finder
graphic lags in Chrome (or system-wide)
iSight is unrecognized
right click (double tap) unrecognized on trackpad
longer boot time (in regards to Lion)
XCode not working (kernel panic when downloading additional updates in order to run it)

MAJOR:
crash after shutdown/sleep (probably my fault with wrong patching)

It is not so fast, but quite enough for moderately web-browsing and little things. Indeed, safer solution than legacy OS Lion.
Check out my posts here:
Mojave on Unsupported Macs Thread

and wait for julianfairfax to respond and explain how to boot 10.14.6 with legacy-prelinkedkernel to avoid issues I got.
 
Last edited: