iCloud Photo Library not working on GM

Discussion in 'macOS Sierra (10.12)' started by stringerhye, Sep 19, 2016.

  1. stringerhye macrumors 6502

    stringerhye

    Joined:
    Jul 5, 2010
    Location:
    Brooklyn, NY
    #1
    So I noticed my Photos weren't updating from my iPhone to my MacBook Pro and when I went to the iCloud preferences under System Preferences I noticed that Photos is unchecked. I tried to turn it on, but it hangs at "Checking Library" and refuses to turn on. I tried logging out of iCloud and back in and even tried making a new Account, but nothing seems to work.

    Has anyone run into this or have a fix?
     
  2. element140 macrumors newbie

    Joined:
    Jan 7, 2014
    #2
    I had this issue too and also with iCloud drive. Nothing I did fixed the issue. I did a fresh install of the public beta GM and not even that fixed it so in the end went back to El Capitan and everything is now working as it should
     
  3. jayboy macrumors newbie

    jayboy

    Joined:
    Feb 22, 2011
    #3
    I have a similar issue. All my iCloud setting were fine, but my uploads in photo library won't start. The preferences says 'uploading 25788 items' but no movement since updating to Sierra. It's a bugger because I have been trying to upload my 180gb photo library over the past few weeks at about 5gb a night and I am about half way through.

    I have spent a while on the phone with Apple support and tried a few things like logging out of iCloud, switching off all iCloud services, force quitting all photos related services through the program manager, but I still sits there doing nothing.

    I'll get back onto Apple support and let you know if they find a solution.

    Cheers

    J
     

Share This Page