iCloud photo library uploading for 24 hours

Discussion in 'iOS 8' started by Brammy, Oct 21, 2014.

  1. Brammy macrumors 65816

    Joined:
    Sep 17, 2008
    #1
    So, I have a measly 104 photos in my iPhone 6 Plus's photo library. I enabled it yesterday, and for the past day it's been stuck at uploading all of them. The web page is also stuck on "preparing your library"


    I've rebooted the phone, turned iCloud Photo Library off and on again, but it's still not budging.

    Anyone have any ideas?
     
  2. iolinux333 macrumors 68000

    Joined:
    Feb 9, 2014
    #2
    I started out same thing last night, figured it was broken. Over the night though, plugged in and wifi on it seemed to upload about 200. Maybe their servers are backed up right now I don't know really but it seems like it should all be done and settled in the next day or two.
     
  3. Brammy thread starter macrumors 65816

    Joined:
    Sep 17, 2008
  4. greytmom macrumors 68040

    greytmom

    Joined:
    Jun 23, 2010
    #4
    Mine has uploaded about 4000 photos since Monday. Also, just checked my photos in iCloud.com and all seems to be well. Not sure what's going on with yours.

    Are you on wifi?
     
  5. Brammy, Oct 22, 2014
    Last edited: Oct 22, 2014

    Brammy thread starter macrumors 65816

    Joined:
    Sep 17, 2008
    #5
    Yeah. And plugged in.

    EDIT: something is messed up with my iCloud account, I think. I took 1 photo on my iPad and it's still uploading too
     
  6. beratblakaj macrumors member

    Joined:
    Oct 19, 2014
    #6
    Bammy have you tried leaving the photo app open. By that I mean having that in the foreground and not doing that. I would give that a try. I and other have had success with this.
     
  7. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #7
    Guys,

    This is regarding the authentication of the your iCloud account. Just go to icloud section under settings and click on your name/email on the top. It will go through with the authentication.

    I have two step verification enabled and looks like u guys have too.

    Let me know if it helps. Mostly it should.
     
  8. Brammy thread starter macrumors 65816

    Joined:
    Sep 17, 2008
    #8
    I'm not using 2-factor (although, thanks for reminding me, I should be). I did notice both my iPad and iPhone wanted me to enter the password in iCloud settings though.

    Didn't make a difference though. My iPad is still sitting there trying to upload 1 photo.
     
  9. uptownnyc macrumors 6502

    Joined:
    Mar 28, 2011
    #9
    Any fix for this? I'm stuck with "Preparing your library…" on the web.
     
  10. blownco macrumors regular

    blownco

    Joined:
    May 24, 2008
    Location:
    CA
    #10
    ive been using it since i got my 6+ and haven't had any issues. It could be your internet connections also being slow to upload pics.
     
  11. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #11
    Same here until 2 days ago. I had an issue for a few days in the beginning when the service was announced but fine since then....until Monday. I increased my storage to the 200GB plan and dropped a pile of videos on the phone through an app. It uploaded roughly half then stopped. No updates of any kind since then. I broke it but I'm certain it will work again. Just have to keep trying. Ha.
     
  12. uptownnyc macrumors 6502

    Joined:
    Mar 28, 2011
    #12
    Everything is uploaded from my device. It's when I login to iCloud and click into the Photos beta that I've seen "Preparing your Library" for days.
     
  13. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #13
    Are you on a home/personal wifi or a corporate/school wifi?
     
  14. blownco macrumors regular

    blownco

    Joined:
    May 24, 2008
    Location:
    CA
    #14
    that's weird i have the same plan 200gb and everything works as it should.

    edit i just went to the photo section on icloud and its doing the same thing you guys are saying so im guessing its on apples end will see.
     
  15. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #15
    All fine here now. I turned IPL off, then I turned it back on. I set autolock to never and left the photos app open. It took most of the day but it finished.

    Then for fun I decided today to rebuild my phone as a new device to solve some other issues. All went well and IPL has been working great. I took the time after the rebuild to really look at my photos and trimmed about 800 from the pile. I have been taking photos for years, roughly getting rid of the obvious bad shots but never really going back and ditching the shots that were similar or just not what I expected.

    Anyhow, try leaving the photo app open and it might upload everything.

    As for the website, I received the preparing library message until everything on my device was completed.
     
  16. blownco macrumors regular

    blownco

    Joined:
    May 24, 2008
    Location:
    CA
    #16
    yea as an update i can see my photos and videos on icloud so all is working fine here.
     
  17. heycal macrumors 6502a

    Joined:
    Jul 25, 2013
    #17
    Same problem. Stuck on 'preparing your library', and I have few photos. Never had any problem accessing my photos previously.
     
  18. docprego macrumors 65816

    Joined:
    Jun 12, 2007
    Location:
    Henderson, NV
    #18
    Same problem here. New as of today. Figured it was related to today event and there would be some mention of an iCloud upgrade but there wasn't.
     
  19. sualpine macrumors 6502

    sualpine

    Joined:
    May 13, 2013
    #19
    I only have 2 test photos and it has been preparing for 4 days. I am going to stick with Google cloud services. Even in beta, it should be better than this. I am scared as hell to trust them with my life's photos like this.
     
  20. bripab007 macrumors 6502

    Joined:
    Oct 12, 2009
    #20
    Just chiming in with my experience with a ~30GB local iPhoto library. I installed the public 10.10.3 OS X beta that came with the latest Photos app. I upgraded my 20GB iCloud Drive plan to the 200GB one, launched Photos app, asked me if I wanted to turn on iCloud Photo Library, turned it on, turned it on for my devices, and it proceeded to upload all my imported iPhoto library images over the course of the next three days. It did take a while for all the photos/thumbnails to show up on the iOS devices, and the iCloud Photos page on the website seemed to have a couple issues at first, but since then, it's been working great. New photos and edits taken show up pretty darn quickly across all devices.
     
  21. trifster macrumors newbie

    Joined:
    Mar 12, 2015
    #21
    Photos on iCloud.com stuck perparing library

    Same issue here. I talked to Apple and they want me to sign out of iCloud on all my devices and web then try to log in again. Came here looking for anyone with my same issue. Looks like i found a few.

    Trifster

    ----------

    This is actually a regression as the Photos app on iCloud.com worked great in the developer preview. I have a 150GB library and its working great via MacBook 10.10.3, iPad Air and iPhone 6. I may just disable iCloud Photo Library on all devices and let my collection re-upload from the laptop Library.
     
  22. Brammy thread starter macrumors 65816

    Joined:
    Sep 17, 2008
    #22
    Mine is still stuck. I'm going to have to wait until 10.3 and 8.3 are out and see if that fixes it.
     
  23. iapplelove macrumors 68040

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
    #23
    Didn't fix for me. I had to turn off photo stream on my devices until apple can get a fix. My photo library is kinda large but still??

    And the Mac photo app just says updating nothing has changed in 2 days
     
  24. skydivertak macrumors newbie

    Joined:
    May 16, 2007
    #24
    Anyone have a solution yet?

    I have been stuck since April 4th. 8.3 did not fix the problem, and I've tried turning Photo Library on and off. Seems to be working fine on my wife's 5S.

    Network does not seem to matter, I've been on several.

    The Flickr App is uploading photos with no issues, as does OneDrive.
     
  25. Brammy thread starter macrumors 65816

    Joined:
    Sep 17, 2008
    #25
    8.3 and 10.3 didn't do crap here, either.
     

Share This Page