Resolved iMac fails boot time RAM integrity check after updates restart

Discussion in 'iMac' started by eldudorinio, Feb 5, 2017.

Tags:
  1. eldudorinio macrumors member

    eldudorinio

    Joined:
    Jan 16, 2010
    #1
    Hi to all,

    I have a Mid-2010 iMac (21.5inch, 3.06GHz Core i3) with 16GB of RAM (recently upgraded, 2 x Hypertec 8GB kit (4GBx2) - HYS31325684GBOE) and a 1TB Crucial MX300 SSD drive (also recently upgraded), running OS X El Capitan.

    Since the purchase there were no issues with the iMac. However, after the memory upgrade, I got the three successive tones, then a five-second pause, repeating (RAM doesn't pass a data integrity check) a few times. This happened after either a forced shut down, or after a kernel panic once. Whenever that happened, I had to unplug the iMac, remove the memory access door, remove the memory and put it back in place. This was the only way to stop the startup tones.

    Of course, this made me suspect that the memory may be faulty. I run the AHT with no issues.

    Today, after a few updates, I had to restart the iMac to complete the updates. While restarting, when the iMac was about to boot again, I got the three successive tones again. So essentially, not only the iMac did not boot, but also the updates were not completed successfully.
    I tried removing and re-installing the memory, but now the iMac does not boot into Mac OS. I can hear the fans starting, but I get no boot sounds and nothing on the screen (no apple logo, no nothing).

    I tried:
    1. Unplugging for 30 seconds and trying again
    2. Holding down the Option key when booting
    No luck.

    Does anyone have a clue on how I can troubleshoot this?

    Thank you.
     
  2. nambuccaheadsau, Feb 5, 2017
    Last edited: Feb 5, 2017

    nambuccaheadsau macrumors 6502a

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #2
    Sure sounds like you got the wrong memory for the iMac. Just don't fit it and contact the supplier.

    Macs are very fussy about the prcise modules installed, and suggest dealing with OWC (macsales.com) and Crucial only. Both are Mac specialists.

    This is the memory band specs for your iMac:-


    https://eshop.macsales.com/item/Other World Computing/1333DDR3S08S/


    Do a SMC reset and a reset of the PRAM, and if both fail boot from your original system install DVD. Next option is to go into Recovery Mode ans see if Disk First Aid will help.
     
  3. eldudorinio thread starter macrumors member

    eldudorinio

    Joined:
    Jan 16, 2010
    #3
    Hey nambuccaheadsau,

    Thank you for you response and my apologies for getting back to you so late.

    I am sending the memory back and getting memory from Crucial.

    As far as the iMac, I have replaced the memory with the original DIMMs that came with the iMac. As soon as I did that the iMac started normally and finished the updates. Had no issues whatsoever since then (about a week).

    Thank you.
     

Share This Page