iMac G5 rolling back from Leopard to 10.3

bmcgonag

macrumors 65816
Original poster
Mar 20, 2007
1,077
0
Texas
I have a client who has given me his iMac G5. He needs to roll back from Leopard to 10.3. He has the original disks that shipped with the iMac (10.3), and a set of 10.3 that he bought as well. I have tried Disc 1 from both sets, and the Apple logo comes up when I boot to the disc, but then it just freezes. It runs Leopard, and boots from the HDD fine.

I have 3 macs (all Intel), is there any other solution to rolling this back for him?

Thanks,

Brian
 

300D

macrumors 65816
May 2, 2009
1,284
0
Tulsa
Only the original iMac G5 can use 10.3, the later two require 10.4 minimum.

There is no reason to downgrade, Leopard is best for G5 models.
 

bmcgonag

macrumors 65816
Original poster
Mar 20, 2007
1,077
0
Texas
He has some need for the OS9 compatibility for his business software still. Apparently Leopard doesn't offer this.
 

300D

macrumors 65816
May 2, 2009
1,284
0
Tulsa
Agreed, tell him to upgrade his 10 year old software. There isn't anything OSX apps can't do that OS9 could.