iMac hard drive replacement

Discussion in 'iMac' started by brentsg, Feb 4, 2016.

  1. brentsg macrumors 68040

    Joined:
    Oct 15, 2008
    #1
    My sister's 10,1 iMac hard drive died and I offered to replace it. The swap went just fine, and I put a Samsung 850 EVO 1TB in there and put it back together. The drive was previously lightly used so I'm not concerned about that. All firmware and such was up to date.

    AHT shows things are fine, but I can't get El Capitan to install from a USB stick. It counts down until it ways 1 second remaining but never restarts. I'll grab a pic of the error log on this next try, but it was some nonsense about fonts or something.. I think just general file issues.

    Am I looking at something weird like a bad SATA cable or bad logic board? I'd think AHT would find the logic issue.. and I'll be testing the drive I removed shortly. Just looking for ideas.

    Thanks.

    Edit: I did a PRAM and SMC reset before this current (in progress) attempt.
     
  2. ElCani macrumors member

    Joined:
    Jun 15, 2012
    #2
  3. brentsg thread starter macrumors 68040

    Joined:
    Oct 15, 2008
    #3
    This is going to drive me to drink. The errors indicate that files just aren't getting copied. So I tried the following:
    -Install to an external Firewire drive
    -Use a different USB stick
    -Use a different USB stick created on a different Mac than my MP

    All of these result in the exact same failure. I guess I'm taking the stupid thing apart again.
     
  4. brentsg thread starter macrumors 68040

    Joined:
    Oct 15, 2008
    #4
    Update: I absolutely cannot install El Capitan directly. I just installed Snow Leopard directly, so now to figure out how to upgrade most efficiently from there.
     
  5. hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #5
    Since you didn't specifically mention it ... I will ask the obvious: Did you format the SSD for OS X prior to using it in the iMac? You said it was lightly used, but that may have been in a PC environment.
     
  6. brentsg thread starter macrumors 68040

    Joined:
    Oct 15, 2008
    #6
    Yeah each try I formatted it properly for OSX. I was able to get this upgraded, but it wasn't any sort of physical issue with the computer. It was some defect with the USB installer as it pertains to this device. I tried 2 different sticks, and I created the installer with 2 different machines (Mac Pro, MacBook) and it failed in the same way.

    I wound up installing Snow Leopard and upgrading thru Software Update and the Mac App Store from there. I am not sure what's up with the USB stick method, as I've done that successfully many times with my own Macs.
     
  7. Dopeyman macrumors 6502a

    Joined:
    Sep 5, 2005
    Location:
    Los Angeles!
    #7
    Try this.....

    - Install captain on an external drive
    - Boot from that drive
    - Format the SSD
    - Download the installer from the App Store and install

    Maybe your flash drive is missing a few files?
     

Share This Page