iMac mid 2011 21,5" - black screen no chime

Discussion in 'iMac' started by jklas, Aug 5, 2019.

  1. jklas, Aug 5, 2019
    Last edited: Aug 6, 2019

    jklas macrumors member

    Joined:
    Jun 20, 2018
    #1
    Hello everyone,

    I searched quiete a lot of Forum-Threads to figure out a solution...with no result yet, thats why I want to ask you guys for some help.

    First of all, I got a iMac mid 2011 21,5" with 16 GB RAM, but no HDD into it anymore (by the former owner removed).

    So actually I started the device and it gives me no chime sound. Second of all the display is totally black even with flashlight I cannot figure anything out (or It was too difficult to see. :D ) Anyway, I heard that this stuff could be easy to be fixed as far as I read.
    Some people write that it can be only the LCD-Cable. Some people say that it can be the logic board or the thermal-sensor. Last but not least it can be the graphic-card-issue.

    So my first question is about how to indicate the issue.
    There is a so called "LED-Indicators" way to find out which part is "broken".
    I couldnt find any good tutorial or step-by-step manual to know how and to see the LED-indicators can be used to see which is the broken part?!
    Does anyone of you have some links or can describe me please how to see those LED-Indicators? I already took the Display-Glascover off the Device. I did nothing else yet.

    I guess I need to place a HDD into the device and then try to restart it again.
    I got a Test-OS on a USB-Stick.
    Also I tried to put the device with a mini-displayport-adapter to HDMI on my TV. It didn't show me any screen at my TV.

    If anyone of you can give me some advices how to proceed with that iMac and how can I fix it, I would appreciate this.
    I will upload a Video of the Device after I will be back from University.

    Thanks in advance.

    Best Regards,

    jklas
     
  2. Willo34 macrumors regular

    Willo34

    Joined:
    Feb 5, 2015
    Location:
    Netherlands
    #2
    I guess you know, the 21,5 inch M2011 has known GPU issues.....
     
  3. jklas thread starter macrumors member

    Joined:
    Jun 20, 2018
    #3
    Hey Willo34,

    yes actually I do. But the point is, that there are many things that exist as a fix. So it can be the Logic board or the GPU or even just the cable. What I try to find out at the moment is which of those parts is the broken part.

    And then maybe I could try to fix it. Since I dont want to buy a new/used GPU randomly, and maybe that part works... .

    So actually the device starts but makes no chime and only a black screen. It does make only a beep noise if the device has no RAM into it.
    So yeah I acutally tried to put the iMac on a TV with Mini-displayport-to-HDMI cable, but it didnt showed me anything... . I gonna try it later once more... .

    So yeah as I mentioned before..I want to know with those LED-indicators which part is going crazy... .

    Cause as you can see. Here are a lot of different solutions:



    at youtube. Some say it just the LCD-cable. Some the GPU. Some the Logic Board and so on... .
     
  4. mikehalloran macrumors 68000

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #4
    First. Replace the NV RAM battery with a new CR2032. You'll loosen the screen and it will be on the bottom right. Screen does not have to come off.

    Second. See if you still have a problem. Most users don't.
     
  5. jklas thread starter macrumors member

    Joined:
    Jun 20, 2018
    #5
    Okay thank you. I also saw after removing the display the batterie was not insert properly (the plastic piece holding was broken). So I guess I need to put a new one into it. Maybe I can let it be held by some tape or any other suggestions?

    Thank you for your answer and help! :)
     
  6. mikehalloran macrumors 68000

    Joined:
    Oct 14, 2018
    Location:
    The Sillie Con Valley
    #6
    Yes, it's easy to break these. I use a piece of tape then a wad of something to hold it in place — usually a small piece of foam rubber will do the trick. There's a spring under the battery that pushes it up so I don't trust tape to hold it for the 7+ years these things last.
     
  7. jklas thread starter macrumors member

    Joined:
    Jun 20, 2018
    #7
    Thank you for your advice mikehalloran.

    I bought a new CR2032 Battery, this one fitted kinda perfect into it. But I did not put any tape or so on/over it to hold it.

    Unfortually the device starts and it shows me 1 LED on. (guess the third or second one, for the Power-Plug) Then after pressing the button the LED left to the one that was from the begining on is gettin lighted green aswell.
    After this no LED starts on again. Screen is black again. I put all RAM out exept one. Tried that one aswell.
    Nothing happend the LED is still black.

    The fan goes crazy loud sometimes and sometimes not.
    The device just didnt started from one day to the other?!

    How should I proceed mikehalloran?

    thank you in advance for your patience and help! :)
     
  8. jklas thread starter macrumors member

    Joined:
    Jun 20, 2018
    #8
    Hey, so I found out that the first and the second LED are on. All others aren’t.
    Second of all, I changed the batterie, but at the moment just with tape. Hope that it lasts.

    I took out the logic board to see if something was wrong...there was nothing. A cleaned all the fans.

    But yeah the display is off and the LED for communicating between the logic board and GPU (3rd) and 4th with LCD Display are off.
    So what would you recommend?

    Best regards
     

Share This Page

7 August 5, 2019