iMessage not using phone number?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by babybuuutch, Feb 5, 2013.

  1. babybuuutch macrumors member

    Joined:
    Jan 16, 2012
    #1
    I updated to the new IOS6 and jailbroke my phone earlier today and now my iMessage will only work if I use my email to send/receive them. The option to use my phone number is just grayed out and not available to click. Also my phone isn’t letting me send picture messages just through regular text. Can anyone help out?
     
  2. babybuuutch thread starter macrumors member

    Joined:
    Jan 16, 2012
    #2
    I don’t really know how I fixed it except I went into send/receive and signed in and out of my apple ID and it seemed to fix the problem. Though I’m still having issues with the picture messaging.
     
  3. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #3
    Go to Settings > Messages > Send and Receive

    Tell me what's there
     
  4. dantyrr macrumors newbie

    Joined:
    Feb 9, 2013
    #4
    I have the same problem, but I don't even have the option to look at send/receive in: settings > messages > ....
    The only options I have are to turn iMessage (on/off), and to change teh SMS/MMS message options:
    MMS Messaging (on/off)
    Group messaging (on/off)
    Show Subject Field (on/off)
    Character count (on/off).

    I used evasi0n for ios 6, and have springtomize 2, winterboard, sbSettings.
     
  5. musicman008 macrumors newbie

    Joined:
    Nov 18, 2012
    #5
    Try to go to Settings->Phone and the field where it says My Number should show your mobile number.
     

Share This Page