iMessage previously working on iPhone 4S, now it's not! HELP!

Discussion in 'iPhone' started by CookieMonster95, Jan 2, 2012.

  1. CookieMonster95 macrumors newbie

    Joined:
    Jan 2, 2012
    #1
    Hi, so I got a new iPhone 4S a few days ago and I've been playing around with it. A lot of my friends have and use iMessage and I started using it too and talking to them and stuff. Everything worked fine. Then today, when I clicked on Messages and was about to send an iMessage to my friends in our group convo, a message appeared saying "Cannot Send Message-iMessage needs to be enabled to send this message" WTF. It was enabled a day ago and now it's not? Can someon please help me? I reset the network settings and did that google DNS server thing too, but no luck. HELP!
    Thanks :)
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
  3. CookieMonster95 thread starter macrumors newbie

    Joined:
    Jan 2, 2012
    #3
    Yeah, when I go there and the slider is on it just says "waiting for activation". look at the picture attachment.
     

    Attached Files:

  4. Coxey70 macrumors newbie

    Joined:
    Jan 21, 2011
    #4
    I had this problem because I turned it off and then after a few weeks decided to turn it back on again and got that message, try to login using your apple id and password not sure if this matters but when it didn't work I was round at someones house not connected to a wifi network I tried it again the day after at home and it worked straight away.
     
  5. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
  6. kristinepara macrumors newbie

    Joined:
    Jan 5, 2013
    #6
    It's because your apple ID account needs to be updated with your new card and stuff.. because your card gets renewed each year so you need to update the apple account with your new one..
     

Share This Page