iPhone iMessage question

Discussion in 'iOS 6' started by outlawarth, Jan 28, 2013.

  1. outlawarth, Jan 28, 2013
    Last edited: Jan 29, 2013

    outlawarth macrumors regular

    Joined:
    Mar 20, 2011
    #1
    My dad is currently overseas and we communicate mainly through iMessage on our iPhones.

    My question has to do with wanting to avoid paying international SMS charges. When I compose a new message to my dad and the send button is blue (as shown in the picture) am I assured that the message will go through iMessage and NOT sms?

    My dad is often in and out of Internet coverage how can I make sure he is online to receive iMessages?
     

    Attached Files:

  2. Bawstun macrumors 65816

    Bawstun

    Joined:
    Jun 25, 2009
    #2
    If you start typing your message and the button stays blue, it should send as an iMessage. Or at least, it will try to. Sometimes sent messages can revert from blue back to green if the person you are sending too has iMessage off, no internet connection, etc.

    ETA: This might not be accurate, but as far as *I* know there is no way to be sure the other end has an internet connection before sending. I've sent plenty of iMessages overseas that sent as blue, but opening up the app later they were now green because they were sent while the person was out of range or had no connection.

    You could always download any of the free apps available for messaging/texting that use your data connection instead of SMS. What's App, etc.
     
  3. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #3
    No you are not guaranteed it will go thru as blue. If you have the option to send as SMS enabled, if the iMessage fails it will retry as an SMS message - green...
     
  4. outlawarth thread starter macrumors regular

    Joined:
    Mar 20, 2011
    #4
    I see. Thank you. That was my main concern that I want to know if my dad is online to accept iMessages.
     
  5. Bawstun macrumors 65816

    Bawstun

    Joined:
    Jun 25, 2009
    #5
    Ah yeah, I forgot about that. You could always disable the option to try and send as SMS if the iMessage doesn't go through. Probably the only way other than using an alternate app to text your father though.
     
  6. Nicksd84 macrumors 6502

    Joined:
    Mar 4, 2010
    Location:
    Atlanta, GA
    #6
    Yea disable the send as SMS option in the settings. This way it will go through as an iMessage and he won't receive it till he has data coverage/wifi. This option won't automatically send it as an SMS until u hold down the message bubble and tell it to do so. Also you can tell once he's received it by the delivery receipt.
     
  7. Ste Nova macrumors 6502

    Joined:
    Jan 20, 2012
    Location:
    LL22, UK
  8. outlawarth thread starter macrumors regular

    Joined:
    Mar 20, 2011
    #8
    Thanks all for replies. My dad has the local sim. Seems like disabling sending as SMS is an option. The thing is... disabling sending as SMS is a global setting. What if I want to send SMS to other people besides my dad?
     
  9. Ste Nova macrumors 6502

    Joined:
    Jan 20, 2012
    Location:
    LL22, UK
    #9
    create 2 contacts,

    "dad 1" with phone number only
    "dad 2" with email only

    only text to the "dad 2" and it can only imessage as it doesn't know his number ;)
     
  10. outlawarth thread starter macrumors regular

    Joined:
    Mar 20, 2011
    #10
    Sounds good, thanks.

    Another question: if I disable sending as SMS can I still text my non-iPhone or non-iMessage contacts?
     
  11. wknapp0924 macrumors 6502

    Joined:
    Sep 14, 2012
    Location:
    Honolulu, HI
    #11
    No, If you disable SMS the only messages you can send would be imessages. The best option is creating the two contacts so you don't accidently send SMS to your dad. Hmm I could be wrong, maybe you can still SMS text with it off. I turned mine off and it just sent, so I don't know.
     
  12. outlawarth thread starter macrumors regular

    Joined:
    Mar 20, 2011
    #12
    Yes, that's interesting. I turned off sending by SMS but I was still able to send by SMS by long pressing the blue "bubble".
     
  13. Yptcn macrumors 6502a

    Yptcn

    Joined:
    Aug 24, 2012
    Location:
    Paris
    #13
    After reading this thread I disabled send as SMS and then sent a test SMS to my husband who doesn't have an iDevice and it worked .

    ----------

    Good to know , I had no idea about this ! :cool: I am from now on turning send as SMS off . Thanks for the tip .
     
  14. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #14
    You can--the disable SMS setting in the iMessage settings is related to sending SMS as a backup to iMessage messages, it doesn't actually disable SMS sending in general that's not related to iMessage (like to those who don't have iMessage).
     
  15. outlawarth thread starter macrumors regular

    Joined:
    Mar 20, 2011
    #15
    Excellent. Thank you.

    You're absolutely right: the "send as SMS" setting is strictly to prevent from sending an SMS automatically when iMessage is not available.
     
  16. Blorzoga macrumors 68030

    Blorzoga

    Joined:
    May 21, 2010
    #16
    I've actually had problems with that setting. Several times, I've had messages go through as text messages, even though I have the option to not send as SMS activated.
     
  17. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #17
    This is a rare situation where I might recommend using whatsapp. It only uses data
     

Share This Page