iMessage works sporatically on El Capitan

Discussion in 'macOS' started by YMark, Jul 10, 2016.

  1. YMark macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #1
    I have the exact same setup on my iMac and Macbook Air. On the iMac, the Messages app is flaky. Sometimes all messages sync up, sometimes they don't. I can be working on my iMac and an hour later I get a large flow of messages. I also get a lot of the red exclamation with the message "Not Delivered". This happens after the send bar gets about 95% complete across the top of the app. This works the same whether the receiver is an iPhone user or Android. This does NOT happen on my Macbook Air.

    If I reboot my iMac, all will work well for a few hours, maybe even a day. Then back to being flaky.

    Any ideas much appreciated.

    Thanks
     
  2. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #2
    Did you by chance create one of your machines from the time machine backup of the other? I did this and messages and mail were flakey as hell. I had to completely delete the account from one one of the machines and start from scratch to get it to work properly.
     
  3. YMark thread starter macrumors 6502a

    YMark

    Joined:
    Nov 7, 2008
    Location:
    Arizona
    #3
    No, I didn't. In fact, Messages has been working all along. This just started happening about a month ago, infrequently at first and now more often. Haven't applied any updates in a while either.
     

Share This Page