iMessages coming from iCloud account

Discussion in 'iOS 8' started by aggiesrwe03, Sep 26, 2014.

  1. aggiesrwe03 macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #1
    My iMessages are being sent from my iCloud.com address and not my phone number, in settings it is set that new messages come from my phone number. This is a problem for me!! I don't use my iCloud address I am an old me.com user and that is my primary address, but the biggest problem is that my friends have my phone number saved, NOT my iCloud address!! This is a bug, and I want it fixed!! Anyone else have this issue? I reiterate messages is set up to be from my number not the iCloud address I understand how all that works and that's the way I have it set up!!
     
  2. KuchiKopi macrumors regular

    KuchiKopi

    Joined:
    Sep 26, 2014
    #2
    You've set it in settings to come from your iCloud. Change it.
     
  3. XmeX macrumors regular

    Joined:
    Sep 21, 2014
  4. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #4
    Jesus Christ did you not read what I wrote?!?!? NO IT IS NOT SET THAT WAY ON ANY OF MY DEVICES!!!
     
  5. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #5
    Or just tell your friends to add your email to their contact card of you and stop crying.

    Hardly a ground-breaking bug.
     
  6. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #6
    Great idea, but not feasible.
     
  7. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #7
    Turn off iMessage. Then log out of iCloud. Log back in and enable iMessage. Check your settings again.
     
  8. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #8
    Troll? You mean, simple fix for simple problem?

    Why have your email enabled for imessages in the first place if you don't want to be using it?
     
  9. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #9
    Thank you, I tried this to no avail twice, but just tried a third time and it appears to be working I'll let you know if it stops, thanks again
     
  10. KuchiKopi macrumors regular

    KuchiKopi

    Joined:
    Sep 26, 2014
    #10
    I don't think you are going to the right setting. It's:

    Settings -> Messages -> Send & Receive.

    Set it there.
     
  11. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
    #11
    Midway through a text conversation with my son yesterday, he informed me that all of a sudden my texts were coming through from my iCloud account. Nothing had changed mid text. It's certainly an Apple iCloud bug, but probably not one they'll pay much attention to. My mother's had serious iMessage and Facebook issues since iOS 6. <shrug>
     
  12. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #12
    Why do you care though? iMessage is designed to use both, if the people you were communicating with new how to properly make use of contact cards they wouldn't even notice.
     
  13. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #13
    It not a simple fix for about 90% of the people I text regularly, as they don't understand the concept of iMessages vs. texts etc. seems to be easier to fix it on my end. I do not use the iCloud address I use the me address, it does not allow me to remove the iCloud address as an iMessages adress. Sorry about the troll comment I'm beyond aggravated at this and have weird to fix it numerous ways including apple support phone call, went through the whole "set your number as the compose address" speil. I was wondering if anyone else had this issue and if they found a fix for it.
     
  14. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #14
    So you're angry because your friends are morons with no concept of how to use the address book on their phone, which (as I've mentioned above in my other post) if they did they nor you would even notice this was happening.
     
  15. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #15
    I care because people like my mom, my wife, my supervisors, and a few others don't understand the difference in iMessages and texts, they just understand that they can see when I read a messages and vice/versa. My wife and mom are easy because I can add the address for them, but it's a bit uneccisary to add an address I don't want/need to use to their phone. It is confusing to them and frustrating to me. Not everyone uses iCloud/Apple products as 100% intended.

    ----------

    Yes my mother and wife are morons, they use their phone as a phone, and are not fanboys, my supervisors supervise hundreds of firemen and paramedics, they don't have time to screw around with a software problem related to an employees personal phone

    ----------

    That's where the iMessage settings are I wasn't doing it from the iCloud settings, there are no message options there. It is set correctly, and I had it working a min. Ago, but it has started again. I imagine this has something to do with the order of things on the server side.
     
  16. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #16
    It's 4? button presses to add an email to an existing contact which then "works" in the background & never has to be thought of or cared about again.

    If that really is to difficult for some people to grasp then I really have no words & wonder what they're doing with an idevice or how they manage to do anything else with it at all.
     
  17. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #17
    OP - have you unchecked all of your email address in the iMessage settings? If that is the case and you have "Start new conversations from" your cell phone #, and this problem persists, you should definitely contact Apple. They'd be the only ones who can help you w/ the issue at this point.
     
  18. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #18
    Again, not everyone is a fanboy, and I've given way more explanation than needed as to why I want a fix, I want the product to work as intended, not tell people to fix it on their end. If you don't have any other solution please stop calling family and friends "morons" their reasons for owning and how they use the device don't really matter. Thanks for your input, but at this point it's not really needed anymore.

    ----------


    Yeah that's the issue I'm having hoping to avoid another call...
     
  19. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #19
    Yes "fanboy" because can use one of the most basic tools found on every mobile phone made ever & apply that common basic skill to provide a simple solution to a simple problem.

    Ok then.

    Tldr this entire thread: it's not going away, take some easy advice or be stuck with the frustration until it gets fixed, which it might never since imessage is designed to use thow's tassociated emails anyway.

    Your "friends" are too busy to learn how thier expensive phone works but seemingly have enough time to complain to you about it.
     
  20. whsbuss macrumors 68040

    whsbuss

    Joined:
    May 4, 2010
    Location:
    SE Penna.
    #20
    Until you get it squared, you can disable iMessage so everything goes SMS. And for those responding from a previous conversation in iMessage to you, it will go Red and they can start an SMS.
     
  21. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #21
    It's simple, we don't control what other people do, be it smart or not smart. That's basically the end of that.

    We do have control of how it works on our side of things, or at least how it should work--if it's not working, the fix isn't to get other people to change something on their end, it's to get what's not working on your end fixed otherwise the underlying problem is still there.
     
  22. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #22
    That's like sending a letter in the post but it getting lost in transit. So you complain & they say "we have no idea why it didn't arrive" and you respond with "ok it's my fault I'll write more clearly on the envelope next time".

    Why blame yourself and create more work when you could simply educate those around you, who in turn will educate those around them. Ta da.
     
  23. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #23
    Because in this case something didn't work correctly on your end, even if it still wasn't your fault. Educating others is much harder, especially if you can't educate everyone involved in many cases. And they will educate those around them? It all sounds nice, but the imaginary utopia doesn't exist in our reality, and since we can only live in this reality that we have, seems like it's fairly pointless to try to live up to some utopia that doesn't exist and won't exist (at last certainly not with the current iteration of the human species).

    The feature on your end should work and if it doesn't it needs to be fixed as that's where the issue is. Even if everyone in the world will have you correctly in their contacts, the feature on your end is still not working, the problem perhaps might be masked on the receiver's end of things, but it doesn't change the simple fact that it's not working correctly on your side of things nonetheless.
     
  24. aggiesrwe03 thread starter macrumors regular

    Joined:
    Jan 25, 2009
    Location:
    TEXAS
    #24
    That is actually the perfect analogy, only not as you intended. The post office lost your mail so you get them to fix their problem, you don't contact the recipient and say change your address. Thanks for clearing that up, you weren't on the debate team were you?
     
  25. cheeyathebard macrumors newbie

    Joined:
    Sep 24, 2014
    Location:
    Raleigh, NC
    #25
    Both myself and my friend are having this issue too since we upgraded our iPhone 6s to 8.0.2. I've tried everything I can think of to fix it with no luck. I was going to try a reset next.
     

Share This Page