Incomplete Face Analysis in Photos

Discussion in 'Mac Apps and Mac App Store' started by schoibi, Oct 18, 2016.

  1. schoibi macrumors newbie

    Joined:
    Jun 21, 2016
    Location:
    Switzerland
    #1
    Hi there

    I am using the iCloud Photo Library with about 30k photos. The face analysis on my iMac, iPhone and iPad was no problem but somehow on my MacBook it does not want to run properly.

    I was running it in background for the last few days and now it has only analysed about 3000 out of the 30000 photos but also does not continue now. At the beginning the photoanalysisd process was running with a high CPU usage (~200%) but now it has stopped (0.0% CPU)... Also while it was running the analysis was extremly slow (e.g. 1 photo analysed per 10 minutes...).

    Does anyone have a clue why this could be? I have already tried to delete the whole library and begin downloading all photos from scratch but this also did not solve the issue.

    Thanks a lot for any help.

    Best
    Philippe
     
  2. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #2
    Mine is stuck at 0 again. I uninstalled Sierra from my MBP and thought the desktop would analyse the photos (it did) and sync through iCloud (it didn't). On my original installation every time I restarted it would go through another 100 or so, but that's hardly a useful solution – I have 13 thousand photos, not desperate enough to restart 130 times.

    On a side note, the fact that photo app is called Photos, spreadsheet Numbers, word processor Pages makes it SO EASY to google for solutions. Not. Thanks, Apple.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    It will stop if you have the Photos app running, so make sure you have quit Photos.
     
  4. navaira macrumors 68040

    navaira

    Joined:
    May 28, 2015
    Location:
    Amsterdam, Netherlands
    #4
    Sadly this makes no difference, photoanalysisd process remains at 0.0% activity. Force quitting it and restarting Photos doesn't change anything either. So far only a reboot makes Photos go on for a while. I'm at 1273 analysed though, so possibly I will only need to restart 10-11 more times...
     
  5. schoibi thread starter macrumors newbie

    Joined:
    Jun 21, 2016
    Location:
    Switzerland
    #5
    It is strange, if Photos is closed, the photolibraryd process is always running at 100% but the photoanalysisd (for the face analysis) is always at only 3%. On my iMac where the face analysis worked without problem the photoanalysisd process was running at 200% until all faces where analysed.

    I assume the problem could be that on my iMac the photos were locally saved but on my MacBook the photos are stored in iCloud. However, on my iPad where the photos are also stored in iCloud, the analysis worked without any problems...
     

Share This Page