install Areca card (1680x) onto 10.6.1

Discussion in 'Mac Pro' started by slater-k, Jan 8, 2010.

  1. slater-k macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #1
    Hi

    Does anyone have any experience of intsalling an areca 1680x (or similar) PCI raid card onto 10.6.1? I've had a right afternoon of it!

    After making a clean install of 10.6 i first tried to install as per the instructions on the CD and then their ftp site, but they both threw up errors ("getFileAttributes requires native support" and then "check log"). There was a thread here that mirrored my experience, and with a link that would solve it in 10.5, though the links are broken. Does anyone know the way to install (and do i really have to use terminal:eek:)

    Cheers
     
  2. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #2
    Once installed (drivers & software), you use a browser to access the card. So you do NOT have to use the Command Line Interface if you don't want to.

    I have a couple of questions:
    1. IIRC, you want to use this for OS X only. Is that correct?
    (Trying to use it with OS X and Windows both can be problematic, and you CANNOT boot both, as it can only hold EFI or BIOS for boot capability). There's not a card out there that can. It would mean separate cards in a MP (one with EFI to boot OS X, and another with BIOS to boot Windows, Linux or both).

    2. Do you plan to boot OS X from the array (sorry, I need a refresher to make sure I don't send you down the wrong path, and lead you to hair loss :eek: :p)?

    Assuming you want to boot OS X, you will have to load the EFI firmware (firmware expands into multiple parts, and you really only need to load the EFI section, assuming it's the newest firmware revision, 1.47 that came on the card). I've been using it shortly after it dropped with no problems. I don't use the EFI section, but gugucom does (another person or two I keep in contact with as well), and has been fine with it according to posts back and forth (emails with others). :)

    You don't have to have it to get the card installed however. Once installed, the easiest way to update the firmware is from the browser interface (IP address <assigned to the card at the factory> : Port, default should be 81).

    3. What have you done exactly?

    What you could try (without info, is to do another clean install of 10.6.1, and install the card only. When you go to load the disk, skip the driver (disk or downloaded), but do install the browser software and CLI package (you need this for the hidden recovery feature if you should ever need to use it). You may need to do a shutdown, and restart (can't recall for sure if it was needed or not, but it won't hurt).

    That seems to be the proceedure that worked in the linked thread you gave, and makes sense to me. BTW, if you do use Windows 7, the BETA Win7 drivers on their site do work (I've been using them with no problems for months).
     
  3. slater-k thread starter macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #3
    Hi nanofrog - thank you again for your kindness in helping me :)

    That's right

    Yes, just OS X
    (BTW, you might need a time machine, though as i say to my friends "the tide is turning":D)

    1. Clean install of 10.6 then 10.6.1 on SSD on ODD_SATA port (MP3,1)
    2. Double clicked "install_mraid_macpro.dmg" on disc that came with the card
    3. Got error message "getFileAttributes requires native support"
    4. Repeated step 2. which produced another error saying check log (as per the link in the first post)
    5. Tried to install the driver then ARCHTTP then CLI from the same disc, none of which worked
    6. Went to ftp site and got different versions of those files, tried to install
    7. Erase and install 10.6 again!

    I'm now going to make a clone of the OS SSD and fire up time machine, so that i can get back to where i am now without too much trouble, and then i'll do as you suggest, particularly because system profiler says that the card is there and the driver is installed (without me installing anything):
    ie just have the card in the pci slot or is there more to "installing" the card? Then i'll
    When you say
    what sort of thing would i type into the address bar of the browser (firefox - i've read that safari doesn't work too well)?

    Thanks again
     
  4. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #4
    NP. :)

    OK, thanks for this. Step 2 began the problem, and the second attempt (step 4) was a mistake. I'd have tried it myself though. ;)

    Very smart idea. :D

    No.

    The normal proceedure is to install the hardware (including drives and attaching all the data and power cables). Then proceed to install the drivers and software apps (ARCHTTP and the CLI interfaces).

    In this case, just get the hardware in (skip step 2, which will elliminate what happened in 3 & 4 ;)), and see if OS X has drivers that will work with the card (part of the default installation). You do need to get the ARCHTTP and CLI installed though, as I doubt that's been included in OS X. Especially ARCHTTP, as you need it to manage the card, including firmware (again, you won't have much need for CLI, but if you get into a situation you need to use the hidden recovery feature, you will).

    Anything you need to do with the card, is done the easiest in ARCHTTP. Note that's where you gain access to the logs. These are your best friend if you have problems, as that information is where you determine what happened.

    Once this is done, update the firmware (before attempting to install the OS on the array), because it won't be able to boot until this is completed. Obviously you will also need to do a proper restart.

    We can go through the various features/settings once you have it up and running if needed.

    Also, if you've not yet gotten a UPS, get one. It's a necessity, not an option. Seriously. You really should do some testing with it to learn how it will react under failure conditions.

    BTW, the card will beep on startup (normal), and cannot be stopped (it happens when the card first gets power). It won't be able to manage the alarm until the firmware is loaded. Learn to live with it. gugucom put a piece of tape over his (about drove him crazy... :eek: :p). The only other option is to desolder it from the board, and I wouldn't recommend it. It has it's uses. ;)

    If this doesn't work, we'll have to go from there, as it's possible an error occured during the driver installation previously. The drivers on Areca's site are from 2009/9/04, and listed as 10.5.6 compatible. But others have been using them with no problems (other 1680 series models, usually the 1680ix12/16/24 models). That's why I'm not sure if the previous attempt was borked, or if that card has some odd issue (I wouldn't think this the case, as they're based on the same design, just changes in port count, and the PCB is smaller due to the fewer ports and cache is soldered to the board rather than via a DIMM slot).

    It's the ARCHTTP program that does this for you. You launch it, and highlight what you want to do (as it's the only card, you will have 2 listings; one to manage the card <Controller #1 PCI = access to all the creation/management/features of the card, and where you need to go to do firmware updates>, and the other to create an array <Cnfg Assistant = quick method for creating an array>).
     
  5. frimple macrumors 6502

    Joined:
    Nov 18, 2008
    Location:
    Denver, CO
    #5
    For what it's worth, both gugucom and myself have been unable to get their ArcHTTP web interface to work inside OS X. I reverted to using the CLI, he booted into his separate windows volume and used the web interface there. I believe that there are some problems with the web interface that won't allow it to work in OS X.

    Also, AFAIK, all you will need to do to make the RAID card volume(s) bootable is to install the EFI firmware. Mine came with the standard (BIOS) firmware and I was able to install to the drive and change it to the primary start up disk, however until I loaded the EFI firmware it would not boot off of it. It did boot without having to install their software however, using only the EFI firmware it was a bootable disk.
     
  6. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #6
    I had forgotten to mention it lately, but Safari and ARCHTTP do NOT work together properly. Use a different browser, such as FireFox (never tried Opera,... though). You'll be able to gain access to it that way. :)

    BIOS = Default out of the box, so if you want to boot OS X, you do have to flash the firmware with the EFI portion. It will work as is once the drivers are loaded, but not boot. This can allow you to boot Windows, and use it under OS X.

    It's when you want to be able to boot both OS X and Windows you have problems, due to Apple's EFI based firmware (you actually can in an Itanium, which is EFI based, so long as the Windows version supports it <UEFI is backwards compatible with EFI, which Vista and Win7 are UEFI capable of UEFI 2.0>). You don't require separate cards in a BIOS based system either.
     
  7. slater-k thread starter macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #7
    Yes, that did it - i didn't install the driver, i just used the driver that came with 10.6 and then installed the ARCHTTP and CLI - those both came from the Areca FTP site, inside the SnowLeopard folder - use the one installer to install both, but it should be the older of the two available. And as you say, safari just won't work.

    Funnily enough, one of the new RE3 discs that i bought for the raid is totally kapput, and one of my old RE2 GP's seems to have messed up my old raid just hours before ... so the old adage that it's not if your drives will fail, but when, came true but luckily everything was backed up.


    Thanks, i would like to ask your advice ... i'm 2 drives down right now, and it'll probably be tuesday before i'm back running, so i'll ask then if that's ok (and after reading the manual:))

    Strangely, as a throwback to when i had another mac, i've got three! One for the MP, one for the 8 bay enclosure, and one for the monitor and router etc ... which order would you suggest - the best UPS for the enclosure, the second best for the MP and the last for the monitor? Nice question, that:p

    I can understand that, it freaks me out when you restart and it beeps away like crazy:eek:

    Cheers :D
     
  8. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #8
    I sent you a PM on it, but I'll post it again, as it's useful for others. ;)

    There's a couple of thing to try:
    1. Check the firmware revisions of the drives, and compare them to the HDD Compatibility List. If they're older than the versions listed, they either
    a. Don't work (can't even create an array)
    b. Cause continual Drop-outs, which then initiates a rebuild. Wash, rinse, repeat... It will drive you nutz.

    Also, remember, in your case, it's a SAS card, which tend to be really picky with SATA drives, and why you end up forced to use enterprise in the first place. But it still has to have both the right series (they can't test every single model in a family of drives, but the adage is, if one works, so will the others as a general rule), and the firmware must be that listed or newer. You may need to contact Areca and WD on this, if the revision does NOT match up.

    2. Run SMART tests on each and every drive BEFORE attempting to create an array. Remap if necessary. This can help you sort a defective drive with the least amount of aggravation and effort.

    3. (Forgot this one in the PM :eek:), double check the cable connections, as a cable may not be on properly (not latched, angled,... causing a contact to be open = drive won't work). Both data and power (I've dealt with both, and even bad cables on occasion).

    The above steps (particulary 1 & 2) are good practice to do when setting up new RAID equipment. It can solve or diagnose quite a few issues for you (with as little effort and time as possible, though not much is really quick with RAID). ;)

    Have you already done the above and/or sent them off for an RMA?

    Nice. :D Handy devices in basic situations (brown-out protection), but a real necessity with RAID, especially if a parity based array is involved. ;)

    If you mean highest load (device) to the highest rating (UPS) and so on moving down, Yes. :)

    They are a tad loud, and will startle/annoy you, even when you know it's going to happen. :p
     
  9. slater-k thread starter macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #9
    Hi,

    Yup: 1. Firmware's cool and 2. i tried to check them but they're not showing SMART supported ... "Scan" in drive genius 2 takes all of a couple of seconds per drive, so i'm thinking that's not really going to cut the mustard ...

    but in the meantime, would you mind casting your eye over these settings that i'll use in creating the raid:
    "Greater two TB volume support" - yes, 64bit LBA
    "Stripe Size" - 128Kb

    (to give me a 7 disc RAID 6 array, with extra one disc being a hot spare, coming to 5Tb. I saw what you wrote on another thread, so i'll do the testing as you advise:
    Would it be bad to get the array working and then flash the BIOS later on?

    Thanks again ... can't wait to get this working:D

    Oh, one thing i was going to do was create a 300Gb partition at the top of the array for PS scratch, and i was reading on another thread about ssd compared to RAID, and i thought i could install a copy of OS X on that 300Gb partition and carry out a few speed tests - would that be of interest (OS X is on ODD_SATA 80Gb SSD)?

    Cheers
     
  10. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #10
    You can check your card's settings in ARCHTTP, and see if there's the ability to set SMART functions as active in the settings, as default would be Disabled given it's a SAS card (I've not used that specific card, so I'm not sure if it has it).

    As per the softeware, NO. You need to run the utility provided by the drive maker. In this case, WD.

    Looks good, but you may want to experiment with the stripe size. You may also want to turn TCQ = Enabled if it's not already (similar to NCQ).

    It sounds like the card's firmware is fine (flash was good), so no need to mess with it.

    Ultimately, if the EFI section didn't go in properly, it won't boot. So you'll know for sure if you try it. :p

    You could, but the array is best left as a single logical partition in your case given you've the OS on an SSD. I do make a short stroke partition (small amount in from the outermost tracks for OS).

    You want to avoid cutting it up if used for simultaneous access (i.e. multiple partitions being accessed at the same time, as the avg. throughput will drop as a result of the slower <inner> tracks for the last partition/s).

    So I'd advise leaving it alone. The array, and hopefully adquate RAM will effectively reduce, if not eliminate the need for scratch space anyway (it was a stop-gap measure to make up for systems with very little RAM back when it was super expensive). HDD use made sense, even with the performance gap between the two given the drastic financial investment required. No longer though. :)
     
  11. slater-k thread starter macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #11
    Apparently PS won't access the user folder and the scratch at the same time, so having them both on the same disc is not meant to impact on performance (unlike having the OS and scratch on the same disc).


    The largest files that PS can work with is 2Gb, something that i have (albeit rarely) bumped up against before. With multiple history states and running filters, i'd imagine that my 16Gb RAM could be used ...
    with this in mind, would you say that having the scratch space on such an array, is damaging or just simply not necessary? If the latter, i might go ahead with it just for those rare occasions when i'm working with really big files, to give me peace of mind while i've got my fingers crossed hoping that the system won't fall down:eek:
     
  12. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #12
    I wasn't aware of that, as I figured you could be loading filters as needed while using the scratch space.

    You really shouldn't need scratch space though.

    You might want to look into creating a few RAM disks and stringing them together (there's a How-To in MR somewhere), as it can allow you to get around the memory limit of PS.
     
  13. slater-k thread starter macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #13
    I'll check it out - many thanks for you excellent advice as always:D:D
     
  14. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #14
    :cool: NP. :)

    I hope it helps speed things along for you, as addressing the system's bottlenecks will really benefit you (it's one of the primary purposes for RAID afterall...). :D :p
     
  15. Cre8vtv macrumors newbie

    Joined:
    Feb 19, 2009
    #15
    Areca 1680xi Set Up Help on MAC XSERVE *Advice needed

    HI, I've almost gotten my 16tb Cloud Media Raid up but need some help on figuring out the functions of the Areca 1680Xi card.

    Here's what I've got.

    Xserve (late 09) running SnowLeopard 10.6
    -PCIe Extender Card (Host)

    A333R 16bay PCI-e host JBOD/RAID enclosure
    -PCI-e Extender Card (Target) slot 1
    -Areca 1680xi in slot 2
    -8 x 2tb Hitachi HDD's

    I've gone through the install and set up process and pretty much have the thing talking and running well. It took a few days, but I got it. My goal is to use this 16tb in RAID 6, 10, or 60 as a mass media storage device for 3 edit rooms on FCPHD. I've heard it's even possible to use as an Edit Source Raid over the network. We have a 10gig switch running our network. In addition, we post preview projects on the xserve internal raid via network for client reviews. So you see, we need all connected.

    In a perfect world, this RAID should show up on the network for all edit rooms to use as needed. I think I need the Xserve to drive it and so they are connected currently via the PCI-e extender cards. The Xserve is directly connected to the network via Ethernet port 1, and port 2 is connected to the Areca 1680xi's port as a second method of communication with it if needed. **Perhaps this could go direct to the network but haven't tried that yet.

    I've used Areca's http set up page and believe I've started the process. I set the raid group across the 8 drives, and also built the volumes. After a day of the raid building itself, the Areca says it's set up and "normal" however, I don't see it on my xserve desk top. If I go to xserve system profiler, I see the volumes and but no single raid set as I had hoped. No way to make the drives or RAID appear on the desktop/network from what I can find. When I do a total restart the xserve sees the drives and wants to reinitialize and I know I don't want that because it makes it a "software" raid under the mac vs. the Areca. I'm not a pro, with this type thing and would love some advice on how to get my new raid to show up on the network via the xserve or direct to the network... Any thoughts would be most appreciated. I got it to work via mac software raid, but of course that defeats the purpose of the monster horsepower the 1680xi is supposed to be. I think there's something I'm not doing right in the set up via http. Areca's controller setup is a bit confusing to me. What steps should I be doing and in what order to achieve my goal?

    Please contact me if you have some steps I should follow to make this work and thank you in advance. jimj@cumumlusent.com
     
  16. slater-k thread starter macrumors regular

    Joined:
    Jan 13, 2008
    Location:
    London
    #16
    Hi,

    I think you only have to initialise the array to get it ready. Once the volume is produced by the raid (and apologies because i'm sure i'm getting the vocab wrong) it then has to be formatted for your system ... i think it needs to be initialised with HFS+ (which is mac os extended) because the card won't do this. Unless you tell it to, disc utility won't integrate your volume into an array - at the moment as far as your computer is aware, it's just a big disc and the actual computer (rather than the card) doesn't take part in the RAID process.

    HTH
     
  17. Cre8vtv macrumors newbie

    Joined:
    Feb 19, 2009
    #17
    Helpful info..HTH, can you highlight

    Good insight. So I'm not quite sure how to initialize the Raid now that volumes are built.

    The odd thing about the Areca http set up to me is that it has you build the RAID set first. (Which I did with all 8 drives, telling it I wanted RAID 6) It did this with no problem. Then the next step it wants you to do is create the Volumes from the Raid Set. *Which is backward to me? Anyway, I did this and after a number of hours (normal) it says all is normal and active with volumes equal to about 14 tbs with 2 tbs as back up buffer. (This is the card talking to me)

    On the xserve side, the system profiler sees the Volumes, but not a RAID set. Are you saying I now should use the HFS+ setting on the Xserve Disk Utility and have it build a RAID from the Volumes it now sees? **Wouldn't that be a software raid vs. hardware on the Areca. Wouldn't that re-initialize over my volume format the Areca set up? Forgive my ignorance on this one... just want to be sure I'm not erasing my efforts of yesterdays volumizing:eek

    Let me know your thoughts and thank you!
    Jim
     
  18. Cre8vtv macrumors newbie

    Joined:
    Feb 19, 2009
    #18
    Added question for you HTH

    I forgot to ask... you mention that the card won't do HFS+ (Mac Extended) unless I tell it to do so. Is there the tab or something on the http set up panel to the Areca to tell it to do that???

    Or if I do that through the RAID BUILD function on the xserve disk utility, will that take care of it, yet still give me all the horsepower I'm after from the Areca vs a software raid on the mac side?

    Sincerely, Jim
     
  19. frimple macrumors 6502

    Joined:
    Nov 18, 2008
    Location:
    Denver, CO
    #19
    Do you see the volumes in Disk Management? You'll have to open disk management and create a HFS+ partition on the new disk that's there.

    The RAID functionality is all handled by the card itself. What you should see in disk management is one 16TB (or less depending on what RAID level you used) disk without a partition on it. There you can create all of the partitions that you want.
     
  20. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #20
    I tried to visualize what you have for physical equipment, and how it's set up, but I couldn't find anything on the Enclosure or quite understand what you mean with Extender card.

    Any clarification could help immensely, such as manufacturer and model numbers. ;)

    This is possible, but it can be tricky to accomplish if you've not done it before.

    OK. You CANNOT connect the 1680's Ethernet port that way. It needs a direct connection to a switch or router (own port, not taken off Ethernet #2 on the back of the Xserve). It doesn't need to be 10G though. That port is for Remote Management, SMNP, and NTP server access.

    1. Is the boot disk attached to the card?
    If so, you need to be sure the firmware was flashed with the EFI binary (can be found on the disk or Areca's website).

    Otherwise, you only need drivers installed if it's data only. Though flashing it wouldn't be a bad idea, as I wouldn't think you're trying to use it in a dual OS environment (it can only hold the BIOS or EFI boot code, not both - no card can). ;) :p

    2. I presume you got the drivers installed, as you've been able to access the card's functions (I presume through ARCHTTP and a browser). BTW, Safari typically has problems with ARCHTTP, and Firefox solves that issue for most. It's a good idea to install the CLI as well, just in case you ever need to access Level2Recovery (hidden function in the card), that can save your hide if the Partition Tables are ever lost (it stores a copy on the card's ROM).

    Please bear with me, I just want to understand the physical aspects first, to be sure there's no issues there. There's lots of details involved, and it can be frustrating. :rolleyes: ;)
     
  21. Cre8vtv macrumors newbie

    Joined:
    Feb 19, 2009
    #21
    Replay

    Thank you all thus far. Here are the answers to the questions and more questions...

    1) My one question to HTH per your mention of the Disk Manager. Are you speaking of the Disk Manager on the Xserve? If yes, I do indeed see the volumes there as created by the Areca. Just haven't grouped them together on the Xserve Disk Manager and asked it to RAID them because I thought that would get rid of all the work the Areca did to volumize and take over as a software raid. My thinking could be wrong here and could use your insight if so. If you're speaking of a disk manager on the Areca Card, I am on speaking terms with it at the moment, through Http. Once the group of drives have their volumes set, it does not give an option to then raid those together. Make sense? So should I just do the RAID set up function on the MAC side?

    2) The JBOD/RAID set up I have my Areca 1680xi installed into is the mAGE316U40-PCI-E-EXP w/ 8 of the slots currently populated with 2tb hitachi HDD's The next 8 will become populated as needed on a later date. The xserve connecting all these as together is the os 10.6 xserve from late 2009. 2.26GHz Quad-Core Intel Xeon "Nehalem" processor.

    I have indeed flashed all the ROMS as they suggested in set up. BIOS, CLI, BOOT, FIRM. THings do seem to communicate great.

    As for the Ethernet between the card and the xserve, it is being seen by the xserve and I thought it could be used for fast updates and such. Based on your comment, I will indeed connect it to our switch instead.

    Thank you both and look forward to hearing more...
    jim
     
  22. Cre8vtv macrumors newbie

    Joined:
    Feb 19, 2009
    #22
    Also

    FYI- This raid is Data only and I don't see ever using it as a boot disk. Not setting that up as the Xserve is driving. My entire goal is to have a super fast RAID on our inhouse network so edit rooms can share media quickly and even possibly use the RAID as an active source for edit... (although it's more being used as a deep storage for finished projects that never really are finished.) : )
     
  23. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #23
    This is odd (though I've not attempted it on OS X Server, it should be the same as the Client edition - for servers, I stick with Windows or Linux). Once the set was created on the card, it should be visible to the Xserve as a single logical drive (once rebooted).

    This might seem silly, but I'd try a shut down, then a cold boot (thinking drivers). You might need to re-install the drivers for it as well. I'd even try shutting down the system, followed by the enclosure. Then power up the enclosure, and restart the system (cold boot), given the methodology of the enclosure (RAID card gets separate power).

    That's not my favorite method (RAID card in the unit, and a communications card in the server). I prefer the RAID card in the system, and daisy-chain enclosures (SAS expanders).

    I'd hope it's not the case, but this could also be the source of your issues.

    It's caused problems before, particularly with NTP servers IIRC (not seen).

    Had to ask. There are those that will place a RAID1 for boot, and whatever's needed for data, as it's a preferred solution than a software RAID1 (many think it's better, as I do - the card will hold the Partition Tables in it's ROM).
     
  24. Cre8vtv macrumors newbie

    Joined:
    Feb 19, 2009
    #24
    In answer to your question about the boot up from cold. When I boot up the drives first, then the xserve, the Xserve eventually presents me with 8 warnings that it sees 8 disks that are unreadable by this computer. "Would I like to initialize them? Ignor? Cancel?" I currently am choosing Cancel until I can figure this out. Again, when I run DISK MANAGER on OSX it sees the drive volumes. I can choose to raid them from there and WILL see them on the desk top, however, unless I'm wrong (Which is entirely possible :eek:) I'm afraid that I'd be creating a MAC software raid vs. the Areca Raid.

    Any thoughts?

    As far as the card in the 16bay unit vs the Xserve. I've tested it both ways, and while the card in the xserve works fine, it's sloppy with long SAS cables running to the backplane in the drive unit. The PCI-e extender card is supposed to create a perfect/seamless "additional PCIe slot" to the xserve as if the host computer has the slot internal. It seems to work that way.

    JJ
     
  25. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #25
    Now you understand why I don't care for the physical locations of the cards. ;) It's a major PITA, as the card and system are initializing (loads firmware) separately, and not in the proper order (system, RAID card, system finishes). Having the RAID card in the system eliminates this mess.

    Given the system is small, I'd dump the enclosure (or get the correct adapters from pc-pitstop and convert it to a simple, dumb box). Expansion can be handled with SAS expanders, which can also be obtained separately (either as a separate device, or card you'd have to install in the enclosure).

    I know the cabling can be messy in comparision, but it eliminates major headaches. And besides, in your case, you're only talking about 2x SAS cables vs. 1x data cable from the system to the enclosure anyway. SAS expanders daisy chain from one unit to another, so you don't have so many cables to the back of the system anyway. :p The worst I've dealt with, were 6x per card (24 port cards). Zip ties can clean it up fairly well. Not the prettiest, but it's doable and inexpensive (less than $5USD for a pack of 12" ties will even be sufficient for 8m cables). But if you're dealing with multiple systems or cards per system, then the flooring (or overhead cable racks) would be needed. ;) I've no idea what kind of space you're equipement is located. So if I've missed something, don't get upset. :D

    Data centers with pull-up flooring is a most wonderful method of hiding the rat's nest that tends to follow servers, and grows over time. :rolleyes: ;) You don't seem to be in that position, or need it from what I can tell. Even the additional cable (as the Ethernet runs won't change) is an insignificant price to pay IMO. :eek: :p

    BTW, when you indicate Hitachi drives, do you mean their SAS drives?
    (Just want to be sure you won't run into cable length issues, as SAS cards are picky as hell with SATA drives, and cable lengths and adapters used with them). Otherwise, they're fine with SAS signals, given it's a much higher voltage signal (20V vs. less than 1V (600 mV max per SATA spec)).
     

Share This Page