Installing Catalyst 15.11 Beta

Discussion in 'Windows, Linux & Others on the Mac' started by aleksoctop, Nov 12, 2015.

  1. aleksoctop, Nov 12, 2015
    Last edited: Nov 18, 2015

    aleksoctop macrumors regular

    Joined:
    May 8, 2011
    #1
    Hi guys,

    Trying to squeeze the most performance out of Fallout 4.
    Before you boot me for not searching the forum for a solution, I need to say - I've searched and followed a couple of guides. This is not my first time installing Catalyst drivers by changing the right string, generating new cat files and signing, i've successfully installed a dozen previous drivers.

    However, the new drivers are not at all alike to the old files and I find myself at a loss of knowing what to do here.

    I've followed these two guides:
    Guide 1, Guide 2

    As I understand, at this point it should just work. For the past X drivers the steps have always been the same, but in this 15.11 release the strings are different and I'm not certain I'm calling the right ones out.

    Hardware: nMP, d700

    Can anyone help? Has anyone managed to install 15.11?

    Edit:
    SOLVED!!!!!!! Literally lactating with joy!

    I used a combination of the two methods I stated above.
    Edited the .inf and the installer cfg as stated in G2 (but pertaining to my specific Hardware ID that I got from Device Manager, then generated .cat using inf2cat from Windows 8.1 Kit, then restarted with disabled signature verification, ran Driver Signature Enforcement Overrider as admin, enabled test mode, signed both inf and cat files I made in c:\Test, then updated the driver from the Device Manager (manually select, have disk). TA DAAAA!

    Ps- If you intend to use DDU to wipe all your gfx drivers, DO NOT restart immediately after, as this could leave you with a useless windows installation with the infamous "black screen with active cursor" bug. Better to get rid of your old drivers via the regular AMD Uninstall in your Programs dialog in Control Panel. I learned the hard way and have to reinstall a terabyte of stuff.​
     
  2. steberg macrumors newbie

    Joined:
    Oct 27, 2013
    #2
    Well, I'm trying to get it to work on my mid 2015 M370X. I'll try the guides you linked to.
     
  3. aleksoctop thread starter macrumors regular

    Joined:
    May 8, 2011
    #3
    Ugh. Changed appropriate strings (based on vendor and hardware IDs) in inf, rebuilt .cat, disabled signature enforcement and tried to install via Device Manager. No dice. Says my drivers are already up to date. :(

    If anyone had any tricks up their sleeve, you'd be a Dearie to speak up.
     
  4. steberg macrumors newbie

    Joined:
    Oct 27, 2013
    #4
    Got 15.11beta to work on my M370X; took me all afternoon....:)

    http://www.3dmark.com/3dm11/10519619

    I ran DDU to clean out all old AMD drivers and after that installed catalyst clean. Only problem is I cannot change display brightness.

    Thanks for the links!
     
  5. sickntired macrumors member

    Joined:
    Dec 9, 2012
    #5
    Please update us if you find a working solution.
     
  6. aleksoctop thread starter macrumors regular

    Joined:
    May 8, 2011
    #6
    Did you sign your driver yourself or did you use Driver Signature Enforcement Overrider?
     
  7. aleksoctop thread starter macrumors regular

    Joined:
    May 8, 2011
    #7
    Ok, so I ran DDU and like an idiot restarted into safe mode and got the black screen on startup with an active pointer.
    So I formated the drive, put my clone of a clean W8.1 back on and installed the latest Bootcamp AMD driver instead.

    HERE

    Fallout 4 runs better than ever, no microstutter, absolutely no frame drops.
     
  8. sickntired macrumors member

    Joined:
    Dec 9, 2012
    #8

    I have tried those drivers and I have problems rebooting the computer if I have crossfire activated. The computer will just boot to a black screen -- I would then need to manually turn off computer and then power up and then it will boot to desktop ok. If crossfire is deactivated prior to rebooting, it will reboot to desktop ok. I am hoping AMD will update these drivers soon.
     
  9. aleksoctop thread starter macrumors regular

    Joined:
    May 8, 2011
    #9
    Oh, yeah, I've gotten that one too. It on/off works. Sometimes it restarts and the whole screen looks like it's interlaced with offset between the images until I restart. Still wish I knew how to install new drivers.
     
  10. heeroyuyj macrumors newbie

    heeroyuyj

    Joined:
    Nov 19, 2015
    Location:
    China
    #10
    hi, im a nMP user, and try to install 15.11 beta driver on win 10 x64

    well, i did find hw ID of my nMP's D300 (both are PCI\VEN_1002&DEV_6810&SUBSYS_012A106B&REV_00)

    so i try to search those strings in "AMD-Catalyst-15.11Beta-64Bit-Win10-Win8.1-Win7-Nov3\Packages\Drivers\Display\WT6A_INF\C0296068.inf"

    then here comes:

    ExcludeID=PCI\VEN_1002&DEV_6608&SUBSYS_3D2813CC
    ExcludeID=PCI\VEN_1002&DEV_682C&SUBSYS_3D2913CC
    ExcludeID=PCI\VEN_1002&DEV_6649&SUBSYS_3D2A13CC
    ExcludeID=PCI\VEN_1002&DEV_692B&SUBSYS_3D2B13CC
    ExcludeID=PCI\VEN_1002&DEV_6938&SUBSYS_013A106B
    ExcludeID=PCI\VEN_1002&DEV_6920&SUBSYS_014D106B
    ExcludeID=PCI\VEN_1002&DEV_6920&SUBSYS_014C106B

    what should i do now?
     
  11. Khyrios macrumors newbie

    Joined:
    Sep 2, 2015
    #11
    Apple just updated Bootcamp...
    best thing: it fixes the long pause before restart problem with crossfire on my nMP...

    Driver Packaging Version: 15.201.2001-151005a-295390C
     
  12. JoSch macrumors regular

    Joined:
    Feb 22, 2013
    #12
    I have an HD5770. The only thing necessary for me was to set EnableFalcon.
     

Share This Page