Insufficient privileges

Discussion in 'macOS' started by Chinashaw, Jun 10, 2007.

  1. Chinashaw macrumors member

    Aug 18, 2005

    I have my MBPro and am set up as the only account on the computer and it is set up as admin. I have checked absolutely every box to enable me to install items; but each time I do try to install I get the error message

    The operation cannot be completed because you do not have sufficient privileges for some of the items.

    I wondered if anyone had seen this before or had an answer?


  2. dartzorichalcos macrumors 65816


    Mar 23, 2007
  3. gnasher729 macrumors P6


    Nov 25, 2005
    You didn't say how you tried to install items; that makes guessing necessary, which is why my response is completely different from the previous posters one.

    As a MacOS X "administrator" you can install anything you want if you know how to, otherwise you can't. The assumption is that you can't be allowed to shoot yourself in the foot if you don't even know how to pull the trigger.

    Most software can be dragged into the Applications folder without problems. Other software comes with an installer that will ask you for a password at the right time. Some software can be installed by typing commands into "Terminal". Typing commands into Terminal makes it possible to mess up a Macintosh as much as you like, that's why some things are not allowed.

    If you precede any command in Terminal by "sudo" it will let you do anything. Don't complain if this causes problems later.
  4. Chinashaw thread starter macrumors member

    Aug 18, 2005
    Thanks for that. The programmes I tried to install where Skype (update) and Firefox (update). All I did was try to drag them into the applications folder to overwrite them. And at that point I was asked if I wanted to do this. Which I said yes to. Then the second message came up.

    I am not sure I am competent enough to install stuff in any other way. Thanks also for the article, I have followed what it says and will update on the results.



  5. jasonbedell macrumors newbie

    Oct 26, 2009
    Kansas City, MO
    Change Ownership of Firefox Application

    I had this same problem upgrading from Firefox 3.0 to Firefox 3.5. I fixed it by changing the "ownership" of the Firefox app by typing the following at the command line:

    sudo chown -R [your-usernmame] /Applications/

    It will prompt you for your password. Once this runs, you should be able to run your new install as usual.
  6. Paragon19 macrumors newbie

    Dec 19, 2009
    I just wanted to say for the sake of people looking for answers on this, especially those using Google, that the above solution worked on my MacBook Pro. Using the sudo command for Firefox made it install properly afterward (I was also trying to upgrade to 3.5.6).
  7. drspringfield macrumors newbie

    Dec 11, 2009
    You could also just throw the existing app in the trash and then copy in the new one.
  8. analoren macrumors newbie

    Dec 20, 2009
    updating skype version

    I wonder if you can help me in a similar problem. Just tried to install a newer Skype tells me I don't have sufficient privileges for some of the items. How can I get around this?
  9. mileslong macrumors 6502


    Apr 29, 2005
    Newport Beach, CA
    as mentioned above, you can either drag the application into the trash or even into another folder like documents or something and you can then install the new version.
  10. macman0910 macrumors newbie

    Jul 17, 2010
    Diner Dash Install Error

    I tried to install Diner Dash Flo on the Go but whenever I open the installer it says "This installer requires admin privileges to run."
  11. jtimleck macrumors newbie

    Feb 8, 2008
    Baltimore, MD
    thanks for people's input - I'm still having the problem system wide - I did a clean install of the OS onto a new disk and copied (when prompted during the install to move any previous users over from another disk) my previous user info (prefs, network etc.) but now when I try to install (and yes, with admin privileges, and yes in this case drag and drop) I get this error message. Furthermore it also will not permit me to access the files from the OLD system on the other disk. So this suggests to me that the privileges (permissions etc) were set, and while copied over during the fresh install, the referencing of the location of the permissions must be in conflict with the two different disks (i.e. You know you have access permissions as the user but the permissions while at that level ref to the wrong place). I'm rebuilding the permissions now with Disk Utility and will see how that goes. The reason for this is because while you can copy over preferences from the old disk to the new (by using "Get Info" and at the bottom editing access privileges, dragging, dropping over to the new disk and giving your admin password to permit the copying) any other referred to files by the app, or the permissions files themselves are still "corrupt" near as I can tell and then still won't work.
  12. Florie macrumors newbie

    Oct 22, 2009
    I just got rid of all the parts of my former Skype and the dragged the new one on top of the Applications folder just fine. Simple. THANKS!!!!!!
  13. bmcgonag macrumors 65816


    Mar 20, 2007
    I have a client who is seeing this issue on a Shared USB drive connected to a netowrk machine.

    Each person in their office uses a mac to connect to a single mac that has a USB drive attached.

    Two of the three can create a new folder, but then can't drag anything into it.

    permissions are set to be ignored on the Volume. It is shared. Just not sure what's going on.

    Any ideas.
  14. shiva81 macrumors newbie

    Apr 7, 2011
    insufficient privileges

    HI all: new to the forum. I read the above thread; how do I type in the command at the command line? In other words, I am not sure I know how to get to the command line on a mac like one does for windows. If someone can explain that, it would be helpful for us less techie folk.
    Also: did try to drag skype into the trash and reinstall a new one; but that did not work.

    Someone said one should make a folder and put it in there???
  15. Spikestrip macrumors member


    Apr 1, 2011
    To get to the command line, you need to open an application called Terminal. You'll find it in the Applications folder, inside another folder called Utilities. Or you can use Spotlight, the magnifying glass in the top right corner, to find it. As stated above, Terminal will allow you to cause actual damage to your computer if you are not prudent. Typing Sudo before a command gives you all the privileges you need to erase or move or do anything, and it doesn't ask if you are sure you want to, so be extra sure you are typing the lines correctly.


Share This Page