Internet not connecting

Discussion in 'OS X Mavericks (10.9)' started by Fiendishone, Jul 31, 2014.

  1. Fiendishone macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #1
    Hi, I am recently having a problem connecting to the internet, when I go through diagnostics it tells me that my IP has failed, checked with my provider and they say everything working fine their end. If I go to network and get the assist button up it goes through and then says it needs keychain access, allow, or always allow, I click always allow and then everything works just fine. This keeps happening, can anyone tell me why and how to fix? I'm using Mavericks 10.9. :)
     
  2. dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
  3. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #3
    WiFi through my BT router. Ooops sorry should have included that info in the original post!! :eek:
     
  4. dzejms, Aug 1, 2014
    Last edited: Aug 2, 2014

    dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
    #4
    Internet not connecting

    1. Repair keychain
    2. Remove your network from preffered network list
    3. Turn airport off and on
    3a. Restart bt hub.
    4. Try to reconnect.
     
  5. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #5
    I am new to things Apple, so please bear with me.

    How do I repair keychain?
    I have removed and re-setup all my email, that didn't work for long.
    I don't think airport is on, does it need to be, if so where will I find it?
    Restarting hub worked for short period.
    Obviously, haven't tried all these things together and then re-tried, will do so as soon as I know how. :eek::eek:

    Thank you very much for your help, it is really appreciated!!!
     
  6. dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
    #6
    Open keychain access from /Applications/Utilities

    Then press cmd+alt+a or click keychain access menu and choose Keychain First Aid

    Type your password and click Start to verify. If repair is needed reapeat that with "repair" radio button selected.
     
  7. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #7
    Have tried that and keychain verify said everything was fine.

    If I go into network and click assist me and diagnostics then go through the process if sorts things out. It tells me that the system wants to access keychain and I always click always allow, then the problem is 'fixed". Problem is that this KEEPS happening! Is there something else I should do? It is really annoying!!!!!
     
  8. dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
    #8
    Have you tried removing your network from keychain?
     
  9. Fiendishone, Aug 3, 2014
    Last edited: Aug 3, 2014

    Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #9
    How do I do that?

    I looked in keychain under login (on the left) then went down to passwords (on the left) then over to bthub that said network password, then I changed that under access control to allow all applications to access this item. Is this ok?

    Not sure if it has cured the problem as it hasn't had long enough to screw up again!
     
  10. dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
    #10
    Open Keychain Access
    Type your wifi network name in search field
    When it appears in the middle of the window right click and choose delete.

    You may have it more than once.

    Then reboot your laptop or turn airport off/on and reconnect. It should ask you for wep/wpa key.
     
  11. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #11
    I think I have found it, it lists the name my hub goes under and then it says airport network password, it is in twice once under system and once under iCloud. I also have a bthub and that says network password and under keychain it says login.

    Do I have the correct items and do I need to delete all 3 places. Just checking to make certain as once I have done this I won't be able to get back on line if I have messed things up!! ;)
     
  12. dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
  13. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #13
    Have done that and re-booted, re-entered the security code for the hub and all seemed to be fine. This was last night. This morning internet is working mail is coming in but can't send. and I am getting the same error messages as before. I have gone through the network diagnostics and it says that everything is working. :confused:
     
  14. damidget macrumors regular

    Joined:
    Aug 3, 2013
    Location:
    Brisbane, Australia
    #14
    Instead of going to run diagnostics, go to System Preferences > Network > Advanced > TCP/IP and click "Renew DHCP lease".

    This has worked for me even though my router doesn't support DHCP.
     
  15. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #15
    If your email is comming in, then your internet is fine. If you cant send email, you haven't set up your outgoing email server correctly.
     
  16. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #16
    Thanks damidget, I have tried that, shall just have to wait and see what happens later...

    T'hain Esh Kelch, The Mac set everything up automatically, I have checked the setting and everything looks just fine.

    Is there anyway this could be caused by my router hub? I am having same sort of problems with my windows PC, at times? i.e. it won't connect to internet and mail is down.
     
  17. dzejms macrumors member

    dzejms

    Joined:
    Aug 23, 2013
    Location:
    London
    #17
    Open two terminal windows:

    One with ping 4.2.2.2

    And one with ping 192.168.1.254


    If your internet goes does check which ping is still working.
     
  18. Fiendishone, Aug 5, 2014
    Last edited: Aug 5, 2014

    Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #18
    I recognise the 192 address but when I try to get the 4.2.2.2 safari tells me that the server is not responding.

    Although, today I have had no trouble, it was connected when I opened the lid and it is still connected!!!! WOW
     
  19. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #19
    I am back to not connecting properly!!!

    I feel certain that it must be something to do with the keychain access. If i go into keychain and select the bthub and set it to 'allow all applications access to this item' will that help and is it safe? at the moment it is set to 'confirm before allowing access' surely this cannot be correct?
     
  20. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #20
    I don't see how that would be the problem. What that setting means is to only allow the app or process that created that password to access the password and not allow other, unrelated apps access. That is as it should be.

    As an aside, if you can still receive email but not send it, it may be because of that third password you removed from keychain earlier. I suspect that was your outgoing mail password and you will need to reenter that in Mail to send outgoing messages (assuming your Internet is working).

    Let's try something you have already done, but you did not do it at the same time that I can see. Remove the BT network from the preferred network list and also remove it from keychain like you did earlier.

    Then go to the network pref pane here and select wifi then the minus at the bottom to completely remove the wifi interface. Then click the plus to add it back. Then click the settings cog at the bottom by the minus and select set service order and make sure to move wifi to the top.

    Now save all of that then restart and go through setup again to establish the connection with your password etc and let's see what that does.

    [​IMG]

    What version BTHub do you have? When this trouble starts, do you see anything going on with the troubleshooting lights here that would indicate a problem?
     
  21. Fiendishone, Aug 6, 2014
    Last edited: Aug 6, 2014

    Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #21
    Can now send and receive mail, that is sorted.

    I have no error lights showing on my hub that says everything is normal. Shall try as you suggest and report back.

    I am back up and running, as you can see.

    Weaselboy: I followed your instructions and when it came to naming the connection the Mac suggested 'Home' so this is what I did, it went through to almost the end when it told me it could not find my connection, but it did give me the option of selecting 'Automatic' which I did and everything has gone through ok. Will let you know what happens later on today or tomorrow, it takes a while for the IP failure notice to come up, normally after the Mac has been sleeping for a while.

    Thank you so much for your help.
     
  22. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #22
    Well, guess what! I still have the same problem!! I worked ok yesterday, didn't lose it at all, but this morning it was telling me the same old thing. Although, when it gave me the choice of clicking 'Home' or "Automatic" I clicked 'Home' and it connected! As soon as I click always allow keychain access it works :confused:
     
  23. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #23
    Each time this happens, try the ping test dzejms mentioned. That first IP is a DNS server in the Internet so that will tell you if you are connected to the Internet. The second IP is the address of your BTHub. If you can ping the hub that at least tells you you have a wifi connection to the hub and perhaps the issue lies outside your Mac and with the Internet connection itself.

    When this happens and there is no connection, what do you see for an IP address for wifi in the Network pref pane in System Prefs.
     
  24. Fiendishone thread starter macrumors member

    Fiendishone

    Joined:
    Jul 20, 2014
    Location:
    Bucks, UK
    #24
    I have tried the hub address and can get hold of that when this happens, have not been able to connect to the 4.2.2.2 at all, even when I have connection. this page fails to load safari states server where this page is located isn't responding.

    I came home and found that I was down again, turned off the hub and rebooted it, problem solved. To me it says that it is BT's problem, although they swear that it is not!! could it be the hub or do you thing it is more actual connection?

    I have even tried changing the channel that is used for the hub.
     
  25. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #25
    You won't be able to reach those IP addresses in your browser. The 4.2.2.2 is a DNS server. You will need to ping then in Terminal.

    It is sounding more and more like an issue with BT and not your Mac I agree.
     

Share This Page