iOS 10.2.1 won't play local video file

Discussion in 'iOS 10' started by Jerry_Lodriguss, Feb 24, 2017.

  1. Jerry_Lodriguss, Feb 24, 2017
    Last edited: Feb 24, 2017

    Jerry_Lodriguss macrumors newbie

    Joined:
    Feb 24, 2017
    #1
    iPad 4th Gen
    iOS 10.2.1
    DropBox 36.2.2
    GoodReader 4.12.0.

    I have a simple HTML5 page with a video embedded in it.

    http://www.astropix.com/test/test.html

    It plays fine when viewed directly on the web in Safari, Firefox, and Chrome on the iPad.

    But it won't play when downloaded in GoodReader, or from DropBox as a zip file and opened in GoodReader as a local file.

    https://www.dropbox.com/s/bkkvod26mmh1tie/test_video.zip?dl=0

    If I navigate to the folder with the video, the video will play by itself in GoodReader, it just won't play in the HTML page.

    The zip file can also be downloaded here: http://www.astropix.com/test/test_video.zip

    Is this some new restriction on local files from Apple in the latest version of iOS?

    Is there a way to download an HTML5 video page to the iPad and save it as a local file and have it play in something in iOS? Or is the file system restricted?

    Videos would play in GoodReader prior to the installation of iOS 10.2.1.

    Thanks in advance,

    Jerry
     
  2. friednoodles macrumors 6502

    Joined:
    Feb 4, 2014
    #2
    I can confirm it works in Textastic just fine on iOS 10.2.1, so maybe it's something specific with those apps. Or, are you running a content blocker that might have rules impacting local paths in a Safari View Controller, but not on external paths? If you have any enabled, try disabling all content blockers and rechecking, just to eliminate it as a possibility.

    iOS 10.2.1 did include a number of WebKit related security patches, and although some are related to cross-origin stuff, none of them should impact that situation.
     
  3. Jerry_Lodriguss thread starter macrumors newbie

    Joined:
    Feb 24, 2017
    #3
    Thanks for your reply.

    I'm not running any content blockers that I know of unless it's built in to iOS...

    Did you actually download the zip file and look at it in Textastic? And the video worked there? I will have to try Textastic then.

    I'm confused because I had the problem in GoodReader, but you are talking about a content blocker impacting local paths in Safari View Controller, but I don't know what that is...

    Jerry
     
  4. friednoodles macrumors 6502

    Joined:
    Feb 4, 2014
    #4
    Apps can add "content blockers" to Safari that do things like block ads, web tracking scripts, etc. You can see if you have any by going to Settings > Safari > Content Blockers. That would be the first thing to check, just to be sure. These content blockers also are applied to "Safari View Controller", which is the system framework provided to apps so that they can show websites inside the app. It may be that Dropbox and GoodReader don't use this and instead use a lower level way of showing web content, where Content Blockers may not apply anyway. But I think it's worth checking if you have any just to rule it out first.

    With Textastic, you can load a zip file into it and it unzips it as a folder so you can view the files. I don't know how Dropbox and GoodReader work, but it's possible that when you view a zip file in those it only extracts the one file you want to view, rather than extracting all of the files, in which case that may explain why the video isn't playing in those apps.
     
  5. Jerry_Lodriguss thread starter macrumors newbie

    Joined:
    Feb 24, 2017
    #5
    Hi friednoodles,

    Thank you very much for that info, I will definitely check to see if there's anything blocking the videos.

    I'm pretty sure that GoodReader unzipped the entire zip file.

    Additional data points:

    I tried GoodReader and the same zip file on my wife's iPhone, and the video played there just fine.

    I also wiped the iPad, and completely reset it, and re-installed GoodReader, and it did not play the video.

    Jerry
     

Share This Page