IOS 10 - Calendar Alerts not working

andrema2

macrumors member
Original poster
Apr 3, 2008
44
0
Hi

Since IOS 10 my Calendar alerts won't go off. It's not only the sound or vibration that doesn't work, there is no notification whatsoever.

I reboot the iPhone, reinstall the OS and still the same.

I also noticed that the widget Up Next is not showing anything, even if the calendar widget does.

Any idea on how to solve this ?
 

supersalo

macrumors 6502
May 14, 2010
383
133
I'm having an issue with other notifications not showing up. I'd wait until 10.0.2 is out and see if that helps any.
 

marf1million

macrumors regular
Jul 23, 2013
111
65
An Mhí
iOS 10.1.1 I'm still having this problem, no calendar notifications at all on my iPhone 7 plus, somehow they work just fine on my iPad Air though.

Does anyone have a solution?
 

Kulfon

macrumors 6502a
Nov 4, 2013
521
469
I have the same issue, I do not get calendar alerts. Frustrating. Any idea what to do?
 

marf1million

macrumors regular
Jul 23, 2013
111
65
An Mhí
I have a feeling that events that were made prior to ios10 are the ones that don't give alerts. Any events I have added to my calendar since upgrading to ios10 have alerted me, but not ones made on ios9.
 

fitter328

macrumors newbie
Dec 15, 2016
4
1
I have a feeling that events that were made prior to ios10 are the ones that don't give alerts. Any events I have added to my calendar since upgrading to ios10 have alerted me, but not ones made on ios9.
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
 
  • Like
Reactions: kimmer123

marf1million

macrumors regular
Jul 23, 2013
111
65
An Mhí
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
Thanks for the suggestion but I've always had do not disturb set that way since do not disturb was available so that probably isn't it. I'll switch it to when the phone is locked and back to always, just in case it does work haha.
 

Nunnsby

macrumors newbie
Jan 9, 2017
1
0
Thanks for the suggestion but I've always had do not disturb set that way since do not disturb was available so that probably isn't it. I'll switch it to when the phone is locked and back to always, just in case it does work haha.
The above switch to "Always" under Settings > Do Not Disturb > Silence worked for me. Had this issue since the upgrade to iOS 10.2. It was affecting both Exchange and Google Calendars using the iPhone native Calendar app. Oh, did a reboot after the change as well.
[doublepost=1483973824][/doublepost]
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
The above switch to "Always" under Settings > Do Not Disturb > Silence worked for me. Had this issue since the upgrade to iOS 10.2. It was affecting both Exchange and Google Calendars using the iPhone native Calendar app. Oh, did a reboot after the change as well.
 
Last edited:

REOTECH

macrumors newbie
Feb 23, 2017
1
3
Try Settings>Notifications>Calendar and make sure notifications are set to on. This had been driving me mad for weeks. Final straw was missed appointment at the vets this morning so decided to get to the bottom of it. My notifications was turned off, turned them on and hey presto, it works.
 

Jimmyss

macrumors member
Feb 11, 2017
73
13
Mine is working just fine. I had an alert yesterday. And it sounded perfectly well.
 

RoyalScam

macrumors newbie
Oct 31, 2016
2
0
Brooklyn, NY
I am just about at the end of my rope with this issue.

I have a Mac Pro, a MacBook Pro, iPhone 6 and iPad mini 2. Calendar alerts all pop up and sound just fine on every device EXCEPT the iPhone 6 - which is really the primary device I NEED to hear/see them.

I have rebooted, hard rebooted, reset Network settings, toggled different settings and accounts on and off - I can NOT get this to work on the iPhone 6. This seemed to start on iOS 10.2. My Notifications list screen shows "empty". Only on the iPhone 6.

Must I really factory reset the whole phone? MUST I?!
 

cyguy

macrumors newbie
Mar 31, 2017
1
0
Try Settings>Notifications>Calendar and make sure notifications are set to on. This had been driving me mad for weeks. Final straw was missed appointment at the vets this morning so decided to get to the bottom of it. My notifications was turned off, turned them on and hey presto, it works.
This did the trick for me, thx!
[doublepost=1491013842][/doublepost]
This did the trick for me, thx!
[doublepost=1491013916][/doublepost]
I am just about at the end of my rope with this issue.

I have a Mac Pro, a MacBook Pro, iPhone 6 and iPad mini 2. Calendar alerts all pop up and sound just fine on every device EXCEPT the iPhone 6 - which is really the primary device I NEED to hear/see them.

I have rebooted, hard rebooted, reset Network settings, toggled different settings and accounts on and off - I can NOT get this to work on the iPhone 6. This seemed to start on iOS 10.2. My Notifications list screen shows "empty". Only on the iPhone 6.

Must I really factory reset the whole phone? MUST I?!

Look at REOTECH post. That worked for me. I was having the same issue as you and this was the only one that worked for me. Good luck!
 

kimmer123

macrumors newbie
Apr 4, 2017
1
0
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
Thanks, this trick worked to fix the annoying calendar glitch :)
 

RedHondaF4i

macrumors newbie
Jun 1, 2017
2
0
I am just about at the end of my rope with this issue.

I have a Mac Pro, a MacBook Pro, iPhone 6 and iPad mini 2. Calendar alerts all pop up and sound just fine on every device EXCEPT the iPhone 6 - which is really the primary device I NEED to hear/see them.

I have rebooted, hard rebooted, reset Network settings, toggled different settings and accounts on and off - I can NOT get this to work on the iPhone 6. This seemed to start on iOS 10.2. My Notifications list screen shows "empty". Only on the iPhone 6.

Must I really factory reset the whole phone? MUST I?!
I posted this on another thread in here. I found this on another forum. I had to do #1 and #2. I guess calendar alerts are located in two places one in the notifications and one in sounds and haptics. Alerts have to be on in both places. I tried it with each one off and it only worked with both on.

1. Settings-Notifications Scroll down to "Calendar Alerts" and then select the Alert Tone you want to use Or
2. Settings-Sounds Scroll down to "Calendar Alerts" and then select the Alert Tone you want to use.
3. Check the "Do Not Disturbed" times. Settings-Notifications-Do Not Disturb.
4. Settings-Notifications-Calendar and make sure that the "Alerts" feature is enabled under the "Alert Style" option.
 

Tina George

macrumors newbie
Jun 9, 2017
1
0
John, thank you SO much. Just stumbled upon your fix and it has totally resolved my calendar / reminder alert problem. It was driving me MAD! Thank you!


[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
 

KatGaladriel

macrumors newbie
Oct 13, 2015
2
0
confused sorry trying to thank someone but it post my message randomly somewhere ugh - you will have to delete this one
 

phredbruce

macrumors newbie
Aug 2, 2017
1
0
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
[doublepost=1501683524][/doublepost]I am on 10.0.3 and changing the setting in "do not disturb" to "Always" also resolved my issue.
[doublepost=1501683622][/doublepost]
[doublepost=1501683524][/doublepost]I am on 10.3.3 and changing the setting in "do not disturb" to "Always" also resolved my issue.
 

LGHwy8

macrumors newbie
Aug 17, 2017
1
0
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
[doublepost=1502997485][/doublepost]This is such crazy cakes!!! Why on EARTH does this work?! Switched to Always, calendar events started dinging! Thanks!!!!
 

Wildheart3

macrumors newbie
Apr 21, 2016
17
3
[doublepost=1481815670][/doublepost]I too had this problem. I tried all fixes, talked to Apple support and Apple store, etc. When checking Do Not Disturb was off (and it was!) I dug down to bottom of settings and where it shows Silence I switched the check mark from "Only when iphone is locked" to "Always" My alerts have worked flawlessly since then. Some weird bug I suspect, give it a try.

Cheers,
John
Yep.
Another thumbs up for this solution :)

I've missed a few alerts and almost missed appointments because of this issue.
I was almost tempted to go back to the stock Apple Calendar, which, IMO, is nowhere near as useful as the Google Calendar in terms of features, functionality and ease of syncing between iPhone/P.C. and back.

This issue occurred both when updating to iOS 10.3 and when I switched from an iPhone 6s to a 6s Plus and I noticed I wasn't receiving weekly alerts/reminders/appointments..

I tried your fix and was chuffed when my Monday morning alerts appeared..

Thank you very much..I have saved this fix in my favourites, should this issue ever arise again with an iOS update/change of phone..

Cheers, once again..
 
Last edited:

TonyC28

macrumors 68000
Aug 15, 2009
1,612
4,692
USA
Does anyone know how to get alerted when someone you invite to a calendar event accepts or declines it? I get them on my Mac but not on iPhone. I do get alerts for invitations and my events.
 

Wildheart3

macrumors newbie
Apr 21, 2016
17
3
Yep.
Another thumbs up for this solution :)

I've missed a few alerts and almost missed appointments because of this issue.
I was almost tempted to go back to the stock Apple Calendar, which, IMO, is nowhere near as useful as the Google Calendar in terms of features, functionality and ease of syncing between iPhone/P.C. and back.

This issue occurred both when updating to iOS 10.3 and when I switched from an iPhone 6s to a 6s Plus and I noticed I wasn't receiving weekly alerts/reminders/appointments..

I tried your fix and was chuffed when my Monday morning alerts appeared..

Thank you very much..I have saved this fix in my favourites, should this issue ever arise again with an iOS update/change of phone..

Cheers, once again..
Just thought I'd report back in regarding the fix I tried using John's recommendations.

It worked for a week, or so..and then, all of a sudden it's not working anymore :(

Very strange!

I was wondering whether anybody else had had this experience and if, so, whether you managed to get around it?
Many thanks...
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,638
993
Using a third-party calendar/reminders app on iOS and or computer?

Had something similar happen a couple of weeks back. Was trying different calendar apps for Mac (Fantastical, BusyCal) a couple of weeks ago to replace stock Reminders and Calendar apps (long story why). One of them, and can't pinpoint which (have suspicions which), but the alerts for all my events and reminders were messed up after starting to try these apps. Stopped getting alerts.

Solution was to go into iCloud and restore an old Calendars/Reminders backup pre-new apps and then go through each event and reminder to make sure alerts were correct again, and to enter any new events/reminders that the restore did not cover.

Was a pain, but this was what finally worked. Wasted a lot of time trying to restore via importing old Calendar Archive, importing ICS files, signing out/in of iCloud, restoring via TimeMachine.
 
Last edited:

fitter328

macrumors newbie
Dec 15, 2016
4
1
The above switch to "Always" under Settings > Do Not Disturb > Silence worked for me. Had this issue since the upgrade to iOS 10.2. It was affecting both Exchange and Google Calendars using the iPhone native Calendar app. Oh, did a reboot after the change as well.
[doublepost=1483973824][/doublepost]

The above switch to "Always" under Settings > Do Not Disturb > Silence worked for me. Had this issue since the upgrade to iOS 10.2. It was affecting both Exchange and Google Calendars using the iPhone native Calendar app. Oh, did a reboot after the change as well.
[doublepost=1505930710][/doublepost]Hi again everyone,

A bit of an update to my post on this problem. I have since found a fix that at least worked for me the other day. I was not getting alerts and had checked settings, checked with Apple etc. I then remembered I had an old iPad issued by work several years ago and had set up on my iCloud account but subsequently never used and was left in a file cabinet. I dug it out the other day and found the battery dead and the date time had reset itself to 01 Jan 1970! After charging and finally setting the date and time correctly,I then did a factory reset which removed the device from my iCloud account. My alerts have worked perfectly since.

So if you are still having alert problems have a look around for old devices and get them off your iCloud account. Hope this helps!

Cheers,
John
 

Wildheart3

macrumors newbie
Apr 21, 2016
17
3
Just thought I'd report back in regarding the fix I tried using John's recommendations.

It worked for a week, or so..and then, all of a sudden it's not working anymore :(

Very strange!

I was wondering whether anybody else had had this experience and if, so, whether you managed to get around it?
Many thanks...
Hi all.
I thought I'd mention, that I tried a different "fix" although it may've been touted before.

I thought I'd try deleting/closing my Gmail Account from the options in the Google Calendar App and then adding the account again.

I've had to wait a few days, but, sure enough, this (Monday) morning I received a Google Calendar notification.

Just thought I'd bring it up, just in case, it's a fix a few people haven't tried..

As to whether it lasts, that remains to be seen.
A few "fixes" I've tried have been OK for a week, or two and then the problem as re-occurred! ;)
 

fitter328

macrumors newbie
Dec 15, 2016
4
1
Hi Wildheart3,

I have since found what was really causing my problems with alerts. I had an old iPad from work that sat unused in a file cabinet. When I dug it out the battery had died and the date/ time had set itself to 01 Jan 1970. After recharging and resetting the date and time through settings I did a factory reset and removed the device from my iCloud account. My alerts have worked perfectly since (going on 2 months now).

Cheers,
John