iOS 11.2 Beta 2 Bug Fixes, Changes, and Improvements

Discussion in 'iOS 11' started by SumYoungGai, Nov 6, 2017.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. Banglazed macrumors 68020

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #101
    Seems fixed
     
  2. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #102
    It's definitely a bug... and the workaround is to set up a keyboard text replacement string to convert "i" (lower case) to "I" (upper case).

    http://appleinsider.com/articles/17...11-i-bug-until-future-software-update-arrives
     
  3. g35 macrumors 6502a

    Joined:
    Dec 13, 2007
    #103
    Has anyone experienced this? Unplug lightning headphones while audio is playing, and the audio continues to play. It’s supposed to stop once the headphones are removed. This is on iPhone 7 and playing podcast through Overcast app. Doesn’t seem to happen with other apps playing audio
     
  4. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #104
    How did you come to the conclusion that removing the headphones from the device should cause the music to stop? If you remove headphones from a radio, does the music stop? Expecting the music to stop when you remove the headphones is illogical. The correct action, IMO, would be to continue playing the music over the built-in speaker.

    The correct action to stop the music from playing would be to use the playback controls to stop/pause the music playback.
     
  5. g35 macrumors 6502a

    Joined:
    Dec 13, 2007
    #105
    Because that’s how iPhones have behaved since, I don’t know, 2008? 11.2 dev beta 2 is the first time an iPhone has failed to stop the audio upon removing the headphones
     
  6. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #106
    I've never experienced the behavior you're reporting as a problem. And hasn't iOS 11 in general taught you that "it always did it this way" doesn't apply? (I'm thinking of the Control Center Wi-Fi and BT controls).
     
  7. mfender macrumors regular

    Joined:
    Apr 27, 2017
    #107

    I didn't believe it, until I duplicated on my Iphone 6 going between Spotify and youtube. That is a very strange bug, indeed!
     
  8. g35 macrumors 6502a

    Joined:
    Dec 13, 2007
    #108
    Look dude I’m just asking if anyone has found this bug. It’s well known that this is how it has always worked. Here’s a thread from 2010. http://ask.metafilter.com/144048/disable-iphone-autopause

    11.2 beta 2 would be a weird point for Apple to yank this feature, so i assume bug. Try it for yourself, if you have another device running beta 1 or earlier. Thanks for your incredibly constructive replies
     
  9. mariusignorello macrumors 65816

    Joined:
    Jun 9, 2013
    #109
    Just reconfigured HomeKit and it must be a bug with tvOS 11.2 beta 2. My iPhone X had beta 2 of iOS 11.2 on Friday and Remote access worked fine with tvOS 11.2 beta 1.
     
  10. ajscorpio69, Nov 6, 2017
    Last edited: Nov 6, 2017

    ajscorpio69 macrumors regular

    ajscorpio69

    Joined:
    Sep 8, 2016
    #110
    Same here. I updated to beta 2 after restore from 7 Plus to X, but hoping new updates for beta don't pop up now that the profile is gone.
     
  11. macintoshmac macrumors 68030

    macintoshmac

    Joined:
    May 13, 2010
    #111
    Don't know why you're being so brash for something that's been there since I have known iPhones. I personally have loved the fact that taking the headphones off would stop the music playback, since my (first) iPhone 4s. I'd expect the behaviour to continue with lightning connector as well. If it doesn't with iOS 11.2, then this piques curiosity as to what is going on, and would, prima facie, appear to be a bug. What's so wrong with the poster's remarks that gets you so excited?

    And no, iOS 11 in general has not taught that "always like that" won't work any longer. It's not that iOS 11 is rewriting the entire alphabet and grammar.
     
  12. simonmet macrumors 68000

    simonmet

    Joined:
    Sep 9, 2012
    Location:
    Sydney
    #112
    Is the App Store Bluetooth nag still present? So annoying!
     
  13. Feyl macrumors regular

    Feyl

    Joined:
    Aug 24, 2013
    Location:
    Czech Republic
    #113
    Well, that's a puzzle.
     
  14. honglong1976 macrumors 65816

    honglong1976

    Joined:
    Jul 12, 2008
    Location:
    UK
    #114
    Ok, iBooks is annoying now. Worked great on iOS10.

    iOS11 - download books (only about 500mb worth). Randomly they will all disappear (even with 7GB free) weeks later.

    Is this happening to anyone else? I have done a fresh iBook install, fresh iOS11 install, same!

    I have reported to Apple.
     
  15. ignaciobarrena macrumors regular

    ignaciobarrena

    Joined:
    Dec 25, 2016
    #115
    Hope they enable Apple Pay P2P and iCloud iMessages syncing... .2 release already and none of these features are enabled, don’t forget that they showed them as big features in iOS 11
     
  16. Brutonus macrumors newbie

    Joined:
    Aug 17, 2013
    #116
    After updating iOS, it replaced my Proximus (Belgium) carrier settings profile with a wrong carrier settings profile (vtr 30.5.1, a carrier from Chile after looking it up). This causes my iPhone to report "No service" intermittently. I've already tried restoring network settings, removing sim, rebooting.

    When I go to Info in the Settings.app, I get the alert that a carrier settings profile update is available, but tapping it does nothing.

    Any idea how to fix it without a full reset and reinstall?
     
  17. Cu5co macrumors regular

    Cu5co

    Joined:
    Dec 22, 2015
    #117
    No it is not.
     
  18. Shyos, Nov 7, 2017
    Last edited: Nov 7, 2017

    Shyos macrumors newbie

    Joined:
    Mar 26, 2014
    #118
    I've got the exact same issue, tried everything... except DFU as the iPhone X doesn't want too for some unclear reason. Guess we'll have to wait to a next version. Found the DFU... restoring now... let's see if it helps. (https://support.apple.com/en-us/HT201263)
     
  19. honam1021 macrumors regular

    Joined:
    Nov 4, 2012
    #119
    The stuttering has been around for a long time, whenever you encounter it or not depends on the apps you use. On my Pro 9.7 that's still running iOS 10.3 launching YouTube or Discord and then open the app switcher will cause it to stutter as long as the said app is visible.
     
  20. Wad12355 macrumors newbie

    Joined:
    Jul 25, 2012
    Location:
    London/Kiev
    #120
    Has anyone else got this annoying thing back 11.2 beta 2... I can't stand it.
     

    Attached Files:

  21. iOSBry macrumors 6502

    Joined:
    Jan 16, 2013
    #121
    The weather widget issue is still occurring for me - weather app shows 34° for my location and the widget shows 39° and did all day yesterday.

    This is an install as new.

    iOSBry
     
  22. daio macrumors regular

    daio

    Joined:
    Apr 14, 2011
    Location:
    Germany
    #122
    My iPad Pro 9.7" is behaving a little weird since updating. Swiping up from the bottom of the screen no longer brings the dock into view. Four-finger gesture and double click home button brings me to dock and multi-tasking view however. Restarting the device fresh brings the functionality back as it always was but after half an hour of using, it's gone again. Again a restart and it works but it is always only temporary. Weird. Will report to Apple shortly.
     
  23. macintoshmac macrumors 68030

    macintoshmac

    Joined:
    May 13, 2010
  24. pacpac2017 macrumors newbie

    Joined:
    Sep 27, 2017
    #124
    Hi, when updating from one IOS 11 beta to a higher beta, is it any point in doing a full restore and set up as a new phone, or just do the update OTA?
     
  25. Jukens macrumors regular

    Joined:
    Jun 13, 2013
    #125
    Well this broke the slide up gesture to bring up the dock and multitasking on my iPad Pro. Works for a bit then randomly stop until i restart the device. And they still haven’t fixed the disappearing text entry/ keyboard in messages.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page