Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

frou

macrumors 65816
Mar 14, 2009
1,116
1,379
How many years has this been going on for you? I have lost track.
Safari's overall iCloud syncing sometimes not working at all, or being heavily delayed, has indeed been going on forever. But AFAIK the positioning bug is actually a new thing that started around the time this thread was created.
 
  • Like
Reactions: rui no onna

D1STORT1ON

macrumors member
Mar 24, 2011
37
16
VA
Well I fixed it but it was because of a mistake. Short version of it is all devices were turned off icloud, all bookmarks were deleted, then I imported them again into my mac from Chrome. Then I turned icloud sync back on for the phone and ipad. Deleting all my bookmarks was unintentional, but it did seem to solve the problem
 

antiprotest

macrumors 68030
Apr 19, 2010
2,990
7,866
Oh jeez. Not years, just past few months. This is a problem from years ago?!???
Yes it started many years ago and was never fixed. Apple has probably moved on with other priorities like shared tab groups yada yada and this will never be fixed.

From my experience and observation, you could have multiple Apple devices and not run into this issue for years, but if it ever hits you, it is unfixable and it will never stop.

Regardless of what you try, and even if it seems to be fixed, it is never truly fixed. The problem will inevitably return.
 
  • Like
Reactions: Beachlover516

NewYorkRanger

macrumors 6502
Oct 27, 2010
350
187
I found a fix that worked for me. On MacBook, go to Safari and open Bookmarks. Right click Favorites and sort by Name. Then Command Z to undo back to the original order. This will re-sync the order across devices.
OK, this worked for me!!!!

My bookmarks are under "Bookmarks Menu" but I followed your instructions doing the exact same thing you did. I right clicked and sorted by Name, followed by a Command Z to revert to my original order. I then moved the recent bookmarks that were jammed at the top of the list to their proper spots I wanted them. Went to check on my iPhone and those bookmarks stuck at the top now in fact moved to the spot I put them on my Mac.

I then did a test to see if this is really fixed - tried to save some new bookmarks and they are now saving at the BOTTOM of the list as it did before AND seem to carry over across devices as well! Even when I move the new bookmark, it carries over to the new spot across devices.

Will continue to test but looks like this is the fix!
 

zidaneism

macrumors newbie
Dec 18, 2020
6
8
OK, this worked for me!!!!

My bookmarks are under "Bookmarks Menu" but I followed your instructions doing the exact same thing you did. I right clicked and sorted by Name, followed by a Command Z to revert to my original order. I then moved the recent bookmarks that were jammed at the top of the list to their proper spots I wanted them. Went to check on my iPhone and those bookmarks stuck at the top now in fact moved to the spot I put them on my Mac.

I then did a test to see if this is really fixed - tried to save some new bookmarks and they are now saving at the BOTTOM of the list as it did before AND seem to carry over across devices as well! Even when I move the new bookmark, it carries over to the new spot across devices.

Will continue to test but looks like this is the fix!
OMG it works! I think it does the same thing as suggested by another guy replied earlier that, it can be fixed if you reordered the bookmarks one by one. Your method is surely the faster version lol.
 

blindferret

macrumors newbie
Jul 5, 2011
2
0
I found a fix that worked for me. On MacBook, go to Safari and open Bookmarks. Right click Favorites and sort by Name. Then Command Z to undo back to the original order. This will re-sync the order across devices.
Thank you so much for the solution. This bug has been annoying me for months.
 

WilliamG

macrumors G3
Mar 29, 2008
9,614
3,351
Seattle
I found a fix that worked for me. On MacBook, go to Safari and open Bookmarks. Right click Favorites and sort by Name. Then Command Z to undo back to the original order. This will re-sync the order across devices.
Thank you for this. I've been driven nuts by the problem for a little while now. Kudos.
 

Tr55

macrumors newbie
Sep 23, 2021
23
11
For those who find this and need to do it, too, note that you must do it to every bookmark folder separately.
What about if you don’t have a Mac?

Can you do it on Windows with iCloud app?

Update

Answer? Yes you can.
It works in Firefox with the iCloud app in Windows syncing bookmarks.
 
Last edited:

Cocorico

macrumors member
Jan 5, 2013
89
1
France
"I found a fix that worked for me. On MacBook, go to Safari and open Bookmarks. Right click Favorites and sort by Name. Then Command Z to undo back to the original order. This will re-sync the order across devices."
When I do that (clik on Favorites) I do not see "sort" but "display inside of the folder" and "open new tab" and "open new folder"…
Can you help ?
Thanks.
 

NewYorkRanger

macrumors 6502
Oct 27, 2010
350
187
When I do that (clik on Favorites) I do not see "sort" but "display inside of the folder" and "open new tab" and "open new folder"…
Can you help ?
Thanks.
Need to do it in the ‘edit bookmarks‘ setting, not the menu itself.
 

frou

macrumors 65816
Mar 14, 2009
1,116
1,379
So are we just going to have to do this Sort By Name, Undo workaround every so often for months and years, or is Apple actually going to fix the root cause? :confused:
 

mario-64

macrumors 6502
Jun 23, 2012
289
127
I can’t get this to work. My bookmarks aren’t in a sub folder. The only sub folder I have is Favorites. How are you supposed to sort bookmarks not in a sub folder?
 
  • Like
Reactions: dKupe

Ken1222

macrumors member
May 16, 2011
58
21
Havre de Grace, Md
Thanks for the tip...it appears to have worked on the iMac and initially did not work on my two iPads and iPhone. I closed all the processes and the bookmarks are now all in synch!
I am hopeful but skeptical (knowing Apple as we all do) that this fix will hold long-term.
 

mario-64

macrumors 6502
Jun 23, 2012
289
127
How are you all sorting bookmarks on Mac? I see no option for that unless they’re inside a folder.
 
  • Like
Reactions: dKupe

talhak

macrumors newbie
Feb 16, 2020
16
3
I found a fix that worked for me. On MacBook, go to Safari and open Bookmarks. Right click Favorites and sort by Name. Then Command Z to undo back to the original order. This will re-sync the order across devices.
Thank you very much for this workaround, worked like a charm! 👏👍
 

dKupe

macrumors member
Apr 10, 2011
54
26
I found a fix that worked for me. On MacBook, go to Safari and open Bookmarks. Right click Favorites and sort by Name. Then Command Z to undo back to the original order. This will re-sync the order across devices.

This finally bit me today in Safari 12.5.1 on my Mac- and alas this trick didn't fix mine. Basically my Bookmarks menu was always sorted by Date Added. Well that isn't a sort option- there is only sort by Name and sort by Address. It is a scrambled mess now. I just now turned off iCloud Safari syncing, but I guess the horse is out the barn. This sucks!

EDIT: Tried to re-organize this mess and gave up. Instead I deleted ~/Library/Safari/Bookmarks.plist and replaced it with one from a backup from a couple weeks ago. Worked perfectly. I'm leaving Safari iCloud sync turned off for now and I am going to be sure I frequently backup that plist file routinely before I turn it back on.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.