iOS 5 GM Bugs & Problems (Let's document them here)

Discussion in 'iPhone' started by Gregintosh, Oct 7, 2011.

  1. Gregintosh, Oct 7, 2011
    Last edited: Oct 7, 2011

    Gregintosh macrumors 68000

    Joined:
    Jan 29, 2008
    Location:
    Chicago
    #1
    Hi Everyone,

    I installed the GM release of iOS 5 on my iPhone 4 and things have been working pretty well for now. For the record, I am not jailbreaking my device for now (though I plan to in order to run My-Wi when I go on vacation next month to share my connection with my MacBook Air).

    While iCloud is not enabled yet (I am not a developer) I can't get photo streaming to work, and of course iWork and such won't be updated until the 12th. Since I don't have a compatible iTunes version, Wi-Fi synching is also a no go yet. So those things will resolve themselves soon as the official release launches.

    However, I have noticed a few bugs or unexpected changes in the software which look like will be around until at least iOS 5.1. I was thinking maybe we can start a thread to keep track of issues and any workarounds to resolve them.

    Here are the issues I've had:

    ISSUE 1: When previewing a podcast in iTunes, the minute I lock the phone or go back to the home screen the preview stops playing. This is annoying because I used this to get around the 20MB over 3G limitation when listening to podcasts on the go. (When the phone won't let you download the podcast because its too big, you can still listen to it via the preview button.)

    I was typically able to hit the preview button on a 2 hour long podcast, close the screen or even go to another app, and just stream the whole thing over 3G in the background. Now it seems this will be very inconvenient if not impossible to do.



    ISSUE 2: For some reason I occasionally get a message that says I am not subscribed to any cellular data service. This is incorrect, obviously. Also, it doesn't seem to impact my ability to get data. (Despite this message coming up in the middle of a browsing session, my websites load as normal and I am able to get e-mail, etc.)

    I am hoping this may be resolved with a carrier settings update in the near future.



    ISSUE 3: When I tried to play anything in the music app it just wouldn't play. I would select a song, hit play, the button would turn into a pause button but it would be stuck at 0:0. Even if I moved to another point in the song, it would just be stuck on that point and not move. Toggling between Pausing and Playing repeatedly did not help. No songs or podcasts or any audio files would play.

    Luckily, this was immediately resolved by just restarting the phone. It only happened once for now, but I am hoping this was just a freak thing and not a recurring problem as it would get annoying to have to restart the phone that often.

    Especially if one is relying on a tethered jailbreak, if this issue did come up you'd basically be stuck without being able to play any music on your phone until you got to your computer. That would really suck if you are out on an all day trip.



    ISSUE 4: Trouble downloading podcasts. I tried to download a podcast and it would get to about 12KB and get stuck. No movement for a while. Maybe this is just the particular podcast, but I have never seen this happen before and it never happened even on this podcast (well not this specific episode, but same podcast) on iOS 4.X.

    Also I noticed a podcast appeared in Music, but when I clicked on play it said I needed to be connected to a Wi-Fi network to play it. I believe this means Music app shows podcasts as available before they have finished downloading. Before, only once a download was finished would it appear as available for listening.

    I have double checked this, and this is indeed what happens. As soon as you hit download on a podcast it appears in the Music app as available for listening despite it not finishing to download yet.



    ISSUE 5: Battery Life. The battery life is taking some hits due to bugs in the software. I am pretty sure its bugs or glitches because while typically battery life is the same, there are some times when one of the issues mentioned above happens and the battery starts draining quickly.

    (I am also not using the reminders app yet, and I know thats been another common complaint regarding its effects on battery)

    For example, I tried to download a podcast and it was stuck on 12KB for a while. In just a matter of about 15 minutes the battery went from 100% to 93%. Pretty quick drain. Weird considering that the radios must have been on but no data was being transferred.

    Also, at another point in time I had turned the phone off with 98% battery and when I turned it back on I had 96%.



    I think that's all the issues I can think of so far. Everyone who is running the iOS 5 GM feel free to chime in!

    I also think that Apple should provide a way to disable the 20MB limitation over 3G. I think instead of a prompt saying connect to a Wi-Fi network to download this, there should be a question instead. "This file download is XXX MB big. Would you like to proceed with the download or wait until you are connected to a Wi-Fi network?"

    I pay for my data (not unlimited) so if I want to eat up some of that I should be able to rather than be forced to look for a Wi-Fi network.
     
  2. Stuipdboy1000 macrumors 6502a

    Stuipdboy1000

    Joined:
    Jun 30, 2007
    Location:
    Perth, Scotland, UK
    #2
    Not a bug or problem, just a gripe.

    I dislike how albums with various artists is sorted in the 'Music' app. Before they would show up under the artist's respective letter but now they all show up under 'Various Artists'.

    Don't suppose anyone knows how to change this easily rather than having to go and change details?
     
  3. Project macrumors 68020

    Joined:
    Aug 6, 2005
    #3
    I can no longer see Personal Hotspot in settings. Fine in all of the betas but disappeared in the Gold Master.
     
  4. Gregintosh thread starter macrumors 68000

    Joined:
    Jan 29, 2008
    Location:
    Chicago
    #4
    Are you on Verizon or AT&T? I am on Verizon and I see "Set Up Personal Hotspot" in the Network Settings. I am not subscribed to this service though, so I can't confirm if it disappears or works if you actually pay for this service.
     
  5. psh1998 macrumors newbie

    Joined:
    Oct 7, 2011
    #5
    ios 5 bugs

    im on ios 5 gm and I haven't had any of those problems have u tried restarting your device ?
     
  6. HelveticaNeue macrumors 6502a

    HelveticaNeue

    Joined:
    Apr 24, 2010
    #6
    I haven't had any of these issue. The only bug I've come across is that even after you've deleted all the photos you've taken, the camera app still displays the little thumbnail in the lower left hand corner to enter the camera roll.

    But this is minor.

    Oh, and on my iPad my Events in photos don't display the correct cover images, but an update to iTunes or iPhoto may fix that before Wednesday.
     
  7. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #7

    I am on Rogers in Canada and I can confirm the same thing. Personal Hotspot is now gone. Once the official launch occurs I'll do a restore. I have a feeling there will be a carrier settings update as well.
     
  8. Spectrum Abuser macrumors 65816

    Spectrum Abuser

    Joined:
    Aug 27, 2011
    #8
    I had a feeling iCloud wasn't completely launched, yet. Every time I tried to backup in a WiFi area it would act like it finished the process, but then would not recognized I ever backed up to begin with when I checked my iCloud storage. I did manage to create my iCloud eMail and @ME.com eMail service though. And the Wifi sync indeed does not work on iTunes Beta 7 or at least for me.
     
  9. bellaisa macrumors regular

    Joined:
    Oct 5, 2011
    #9
    my iOS5 device keeps "searching" for signal even I'm taking the train underground, usually it stays at "no service", i think that's killing my battery. anyway to prevent this?
     
  10. uiop. macrumors 68020

    uiop.

    Joined:
    Jul 22, 2008
    Location:
    Grand Rapids, MI
    #10
    My laptop had a difficult time connecting to my personal hotspot (AT&T), not sure what the issue was.

    Also, when I try to reorder the items in the notification center, the setting doesn't always save.
     
  11. QuarterSwede, Oct 7, 2011
    Last edited: Oct 7, 2011

    QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #11
    iCloud backup works randomly for me and only automatically. Manually always tried but fails before it's finished. It's been doing that for several betas now.

    Personal Backup vanished for me as well. I'm on at&t.
     
  12. macfanboy macrumors 6502a

    Joined:
    Jun 5, 2007
    #12
    check the music section under settings
     
  13. Djlild7hina macrumors 6502a

    Joined:
    Mar 28, 2009
    #13
    the music app is picky with some songs (i listen to japanese songs with hiragana and katakana characters) while some appear fine others just crash the app. was fine prior to beta 4 but they havent fixed the issue yet. other than that... i haven't seen anything yet
     
  14. tadad1 macrumors 6502a

    tadad1

    Joined:
    Oct 20, 2008
    #14
    Try Settings>General>Reset>Reset Network Settings and then reboot. Worked for me to bring Personal Hotspot back.
     
  15. navindralr macrumors member

    Joined:
    Jun 29, 2010
    #15
    the main problem I see is that when using photo stream, there is no way to delete pictures off the iPhone that are in the photo stream. Certain pictures I do want in photo stream, and some I don't. Wish there was a little more control of this... at least the option to delete. I know this isn't a bug, but I would say it's somewhat of a problem.

    Somewhat related.. when you try to delete pictures from photo stream in iPhoto, it says "Photo Stream photos cannot be deleted."

    maybe there is a way to delete them or a work around and I'm blind? (I know there's a way to completely delete all photo stream photos through iCloud.com, but obviously that defies the point, as well as turning off photo stream.
     
  16. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #16
    Occasionally, the weather widget in the Notification Center will claim that it's unavailable, even though the weather app is working just fine. That's the only "bug" I've encountered thus far.

    I have found some annoyances, though:

    1. There's no way to fine tune which calendars appear in the Notification Center, or specific time periods.
    2. You can't delete photos from Photo Stream from your device. The only way I've found to do that is through iCloud.com when you view your account settings.
     
  17. Amnesia87 macrumors 6502

    Joined:
    Jun 19, 2010
    #17
    Issue 42 - Siri isn't working on my iPhone4... LAMESAUCE... I don't want to wait for my new phone to arrive nextweek... I want to play nau!!!
     
  18. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #18
    Didn't work. I'll try reinstalling the GM tomorrow and see if that makes a difference.
     
  19. Tom8 macrumors 6502a

    Joined:
    Oct 28, 2010
    #19
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Issue 1. iCloud email isn't pushing. I have to open the app for it to be receives. Possibly an iCloud server issue, rather than iOS 5

    Issue 2. I tried listening to a podcast over 3G and it brought up the screen with the volume controls as usual, but the content would not play.
     
  20. 78-bit macrumors newbie

    Joined:
    Sep 29, 2011
    #20
    Is there a way to force lock screen notifications to appear only in a list? I hate the old-style modal notifications.
     
  21. boss.king macrumors 68040

    boss.king

    Joined:
    Apr 8, 2009
    #21
    Out of curiosity, hows battery life and general performance on the 3GS? Any real issues?
     
  22. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #22
    Also worked for me.:)

    I originally got this suggestion from Apple.com's official troubleshooting page. Amazing how useful their self-help resources are...
     
  23. Pez555 macrumors 68000

    Pez555

    Joined:
    Apr 18, 2010
    #23
    i am having an issue where i keep getting a pop up to enter my icloud password....anyone know how to get rid of this?
     
  24. gdjsnyder macrumors 6502a

    gdjsnyder

    Joined:
    Apr 19, 2010
    Location:
    Swoyersville, PA
    #24
    The only bug I have found in the GM, and I had experienced this since beta 4 is double text alert sounds for one new notification. Example, text tone tri-tone went off twice when I received an iMessage a few minutes ago. It went off twice when I received one new Facebook notification an hour ago. Not too huge, but annoying none the less.
     
  25. sanke1 macrumors 65816

    sanke1

    Joined:
    Nov 9, 2010
    #25
    Text tone plays two/multiple times whenever I receive any alerts or SMS. Very annoying.
     

Share This Page