Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iOS 6's 'Do Not Disturb' Not Shutting Off Automatically on New Year's Day

MacRumors

macrumors bot
Original poster
Apr 12, 2001
50,415
11,806



Some iOS 6 users who use Apple's scheduled "Do Not Disturb" feature may find that their iPhone, iPad or iPod touch hasn't automatically disabled the feature on New Year's morning.

The issue was reported on Whirlpool forums as well as our own MacRumors forums. The "Do Not Disturb" feature silences calls, alerts and notifications when it is enabled. Users may optionally schedule "Do Not Disturb" to activate between specific hours. This allows you to automatically disable calls and notifications while you sleep.

It's this scheduling feature that appears to be misbehaving on New Year's Day. MacRumors reader Spacesamurai posted about his experience:
I am in Japan so it is 2013, and I am finding that my iOS devices (iPhone 4 and iPad 2) are showing "Do Not Disturb" even though it is outside of the time I set for them. Not sure if this is related to the new year. Reloading the devices does not help and the software is up-to-date.
Spacesamurai's experience has been echoed by others, but not everyone.

Apple has had other bugs in the past related to New Year's day. In years past, Apple has had issues with alarms not going off into the new year. Fortunately, the "Do Not Disturb" feature does not disable alarms set with Apple's built-in Clock app.

Article Link: iOS 6's 'Do Not Disturb' Not Shutting Off Automatically on New Year's Day
 

vthree

macrumors member
Sep 23, 2009
71
28
whirlpool forums?

LOL


happy new years guys. hope everyone has an awesome and safe night.
 
Comment

stefman

macrumors regular
Jul 17, 2002
156
4
I'm in Singapore and I had no problems this morning. So I wouldn't say it's everyone.
 
Comment

Bathplug

macrumors 6502a
Jul 12, 2010
885
226
The beginning of the end of the world as we know it. Hide yo wife, wide yo children!
 
Comment

TMar

macrumors 68000
Jul 20, 2008
1,679
1
Ky
Year after year and Apple can't seem to figure out how to calendars and clocks to work together.
 
Comment

JS82712

macrumors 6502a
Jul 1, 2009
799
0
it's not a bug, it's a feature; your iOS device wants you to hear all the 'happy new year' texts from your friends!
 
Comment

mrgraff

macrumors 65816
Apr 18, 2010
1,002
661
Albuquerque
Why should DND automatically shut off on New Years anyway? :rolleyes:

Perhaps part of the code that determines when to deactivate DND checks the year along with the time? Maybe the DND isn't turning off because it isn't finding 2012 in the date - and therefore would explain why it would work if you turn it off manually and then back on - since the 2013's match?

That said, even with any other iOS issues, I refuse to believe that Apple is that sloppy... I hope.
 
Comment

krravi

macrumors 65816
Nov 30, 2010
1,173
0
Apple didn't want to silence the phone for the New Year. What with all the greeting calls and all...
 
Comment

MacMan1620

macrumors member
Apr 18, 2012
38
0
It's nice to see all these trolls making a small issue look like the end of the world. Oh no!, "do not disturb" has ruined my New Years.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.