iPad cant connect to the internet, wifi is connected.

Discussion in 'iPad Tips, Help and Troubleshooting' started by sd147, Apr 18, 2016.

Tags:
  1. sd147 macrumors newbie

    Joined:
    Jun 14, 2012
    #1
    hello,

    my ipad third gen is connected to wifi, but cant connect to the internet.
    thats the only device in house with that problem.
    the wifi unit has been replaced but it didnt help.

    i have a video here which shows the problem:
    https://streamable.com/hcbr

    would be great if anyone got an idea.

    greets
     
  2. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Try changing 2 items in your iPad's Wifi settings.
    Remove the text "fritz.box" in Search Domains (Such-Domains) You might need that for unknown reasons, so this is just a test.
    Change "DNS" from your local router setting to one of the world-wide public DNS servers, such as OpenDNS, or DNS-WATCH (whose servers are located in Germany, if that is relevant for you :D ) The setting for DNS can be changed to 84.200.69.80
    You may not need to reboot your iPad, but I would do a reboot just because I like to do that after changing any network setting :D
     
  3. sd147 thread starter macrumors newbie

    Joined:
    Jun 14, 2012
    #3
    thanks for your answer.
    the problem is alyways there, it doenst matter which router/network the ipad is connected to.
    so your idea wont and didnt work.
     
  4. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Nothing about my suggestion changes your router, or your network.
    It's only a couple of network settings, that may (or may not) help.

    So, you tried both suggestions, just to make me happy, despite the fact that you had tried both before? :D
    Did you try rebooting after you changed the iPad Wifi settings?
    And, your iPad won't connect to the internet in other locations (completely different wifi, maybe a public wifi local for you?
    Do your WiFi settings ALWAYS show that your iPad shows good DHCP settings on other wifi networks? (showing different IP settings when connected to other Wifi routers?)

    Have you tried a full erase/restore through iTunes?
     
  5. sd147 thread starter macrumors newbie

    Joined:
    Jun 14, 2012
    #5
    sorry for the late answer.
    i tried everything you can try.
    i replaced the wifi unit inside,too

    its the same with every router
     
  6. Cassie2015 macrumors member

    Cassie2015

    Joined:
    May 10, 2016
    Location:
    United States
    #6
    I also have a similar problem with my ipad air 2, I connected to wifi, but it will lose connection often and I need to connect it again or reboot. I think you can try to connect your friends wifi or your Mobile hotspot to test whether the internet is stable or not
     
  7. organicCPU, Jan 26, 2018
    Last edited: Jan 28, 2018

    organicCPU macrumors 6502a

    organicCPU

    Joined:
    Aug 8, 2016
    #7
    Did you find a solution for this problem? A friend's situation is similar.

    With an iMac, iPhone and two iPads connected to the home WiFi, the iPad Air 2 isn't able to connect to the internet. The iPad Air 2 is on the latest iOS 11. Sometimes it can connect, but most of the times it can not, especially if connected to other WiFi networks before. Then it has happened that it forgets the password for the local WiFi or is just unable to connect. All other devices are working fine.

    If I configure the iPad Air 2 manually (IP, mask, router), a green checkmark shows up in the settings at the selected network and the WiFi symbol shows quite a good signal strength, but there's still no internet connection possible with Safari.
    If I set automatic configuration on the iPad Air 2 for the home network, the network setting gets a wrong mask (255.255.0.0) and the IP is not corresponding to the network. Then no green checkmark is shown and no internet connection possible. In that case it doesn't ask for a password, what makes me think that there should be no other network with the same name and strange mask around.

    Making a WiFi analysis from the iMac gets:
    - There are many devices around. But, if I disabled the iMac WiFi, there should be at least one additional channel of the 2,4 GHz band available for usage again.
    - There are some WiFi networks not having consistent local settings. The strange thing is, that in the analysis the own network doesn't show the correct country code. I might set this up somewhere in the router, but it shouldn't matter so much, should it?
    - The general signal strength isn't good, set up a repeater, etc. The iMac I used for analysis is placed in another room that doesn't have a good signal strength and therefore is usually wired, but even if the iPad Air 2 is taken directly nearby the router, where the signal should be good, there is no internet connection with Safari.

    I don't own iOS devices personally, so please don't mind some dumb questions:
    - How can I soft reset the iPad or the iPad's WiFi module?
    - Is it just pressing system recovery in iTunes to full erase the iPad Air and install the last backup?
    - Other things I could try?
     
  8. chfilm macrumors 68000

    chfilm

    Joined:
    Nov 15, 2012
    Location:
    Germany
    #8
    My dad has the exact same issue with his iPad 2017. It does work at home, but certain public wifis he can connect to but gets no internet connection at all. His iphone SE at the same time works flawlessly in that very same network.
    Latest ios installed.
    We did try the "Forget network" and re-connect trick, also did a reset off the network settings, but to no effect.

    Any thoughts? Is this an ios bug on ipad??
     
  9. flaubert macrumors regular

    Joined:
    Jun 16, 2015
    #9
    @chfilm: you might want to check to see if the iPad in question has any profiles stored (profiles are like a bundle of settings that can control network behavior in odd ways). You look for them in Settings > General , then look for a Profile entry down near the bottom of the page. Sometimes a profile gets stored as part of a VPN configuration or something like that, but then if the provider goes away or the account expires weird things happen. The name of the profile, if present, usually gives you a clue as to what app installed it, and then you can decide whether to delete it.

    In the worst case you can probably make a backup of the iPad, and then do a complete re-install of operating system firmware (which Apple confusingly refers to as a "restore" of firmware).
     

Share This Page