iPad IPadOS mouse & Smart Keyboard not functioning together

maciver59

macrumors newbie
Original poster
Jul 19, 2019
4
0
Does anyone face the same issue? I’ve no problems connecting any mouse to my iPad (whatever bêta release) but once I try to use the Smart Keyboard while the mouse is functioning then I can’t use the keyboard (chaotic behavior). Changing the mouse doesn’t help.
I’d really appreciate your support.
Thx
 

Tom G.

macrumors 68020
Jun 16, 2009
2,195
1,001
Champaign/Urbana Illinois
I’ve noticed when using a mouse with my Smart keyboard that the on screen keyboard does not go away. Therefore you have a great deal of onscreen real estate that you can’t use.
 

Chrisd999

macrumors newbie
Dec 17, 2017
24
10
I’m using the apple smart keyboard with my logitech bluetooth mouse at the same time, no issues. I’m on the public beta ipadOS that was updated about 10 days or so ago (not the most recent oone from 2 days ago). Yes, the soft keyboard pops up while im inputting text on the hardware keyboard, but then goes away when not inputting text, so no big deal.
 

clubtech

macrumors member
Jan 2, 2009
73
36
I’ve noticed when using a mouse with my Smart keyboard that the on screen keyboard does not go away. Therefore you have a great deal of onscreen real estate that you can’t use.
There’s a setting to disable that under accessibility so that the on screen keyboard won’t show up when using the mouse.
 

mofo124452

macrumors newbie
Aug 29, 2019
2
0
I found that, it’s called “Show Onscreen Keyboard. It’s default is on, and you want it off when using a Smart Keyboard. Thanks.
Hi there. I. have that toggled off. The issue for me is assistive touch. I have to have that toggled on to make the mouse work. When assistive touch is toggled on for me, the apple magic keyboard keys (well some of them) stop working but Magic Mouse works fine. If I toggle off assistive touch, keyboard works perfectly but, of course, no mouse function. Has anyone found a workaround for that?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.