Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Tijdelijk

macrumors 6502
Original poster
Jul 8, 2017
267
234
Maybe it's me but many times even with a strong wifi signal or 4G/5G signal there is no internet acces what so ever.

Nothing works.
Turn on and off airplane mode fixes the connection.

Happens with the iPhone 12.
Any one else?

Really annoying when mail and messages can't be received until the on and off of the airplane mode.

Never had this with the iPhone 11.
Or maybe it's ios 14.2?
 
  • Like
Reactions: Brettka7

Tijdelijk

macrumors 6502
Original poster
Jul 8, 2017
267
234
Yes is saw this topic.
But they also have no signal.

I have full signal
 

TrueBlou

macrumors 601
Sep 16, 2014
4,531
3,619
Scotland
Never, even with a poor connection, as long as I have some sort of data connection, it all works as it should.

Obvious, question, but have you tried resetting your network settings? Settings > General > Reset > Reset Network Settings
 

Tijdelijk

macrumors 6502
Original poster
Jul 8, 2017
267
234
Never, even with a poor connection, as long as I have some sort of data connection, it all works as it should.

Obvious, question, but have you tried resetting your network settings? Settings > General > Reset > Reset Network Settings
Yep tried it all.
Even fresh install
 

Apple_Robert

Contributor
Sep 21, 2012
34,979
50,997
In the middle of several books.
If you are looking at the cellular bars to ascertain signal strength, that is not always a reliable method. To get more accurate picture of actual signal strength, try putting the phone in field test mode and then look at the numbers. I haven’t tried it on my iPhone mini but, I would think the process still works.

 

Tijdelijk

macrumors 6502
Original poster
Jul 8, 2017
267
234
If you are looking at the cellular bars to ascertain signal strength, that is not always a reliable method. To get more accurate picture of actual signal strength, try putting the phone in field test mode and then look at the numbers. I haven’t tried it on my iPhone mini but, I would think the process still works.

It also happens with wifi sitting 3 feet from the router.
 
  • Like
Reactions: Random Dude

beach bum

macrumors demi-goddess
Oct 6, 2011
8,254
29,233
Philly
If all other options to resolve fails and it isn’t an issue with your cell carrier, I would submit for a replacement especially if this is a frequent problem.
 
  • Like
Reactions: Apple_Robert

ericwn

macrumors G4
Apr 24, 2016
11,993
10,749
Since the problem seems general network connectivity a d that on an intermittent basis, I’d set it up from scratch, no data at all on the device to see if it comes back. If it does, return for hardware issue. I’d Film the problem with another device just for documentation sake too - especially with intermittent issues people will be more empathic if you provide evidence.
 

seezar

macrumors 6502a
Jan 18, 2018
567
582
I have the problem intermittently on both an iPhone 12 mini and 12 pro. The issue only happens on 5G, if I switch to LTE the problem goes away. Only way to get the 5G working again when the problem happens is to toggle cellular data. Rebooting the phone or toggling airplane mode doesn’t help.

For the time being I’ve just disabled 5G. The problem is very intermittent but don’t want to be caught without data without realizing it so I’m ok living with just LTE for now. Since it happens on both phones for me, I assume it’s a software issue of some sort.
 

tekchic

macrumors 68020
Apr 19, 2010
2,056
1,763
Phoenix, AZ
I'm having this issue with my 12 Pro Max. I'm on 14.3, it was also doing it on 14.2. For me it just seems to be the wifi. It's to the point that I'm using 5G/LTE most of the time at home because I'm annoyed with the wifi not really working.

I'm connected, but I have almost no internet. I did a speed test yesterday when the wifi was acting up, and it was 0.8mbps down on my iPhone, 8mbps up. Tested from my iPad, got the normal 85mbps-ish speed that it should be.

Saw in other places that people were changing the wifi router's SSID name and password, letting the phone connect, then changing it back, but that didn't fix my issue. It's pretty annoying and I've never had the issue with an iPhone before.
 

snerd

macrumors newbie
Oct 18, 2020
6
2
I’m finally gobsmacked over it! My 12Pro constantly loses signal from home WiFi router. Nothing else does. Probably 5-7 times a day, sitting within 10 feet! My last hope is turning off the 5G, but that shouldn’t be effecting WiFi?
 

kawa636r

macrumors 6502
Feb 28, 2016
412
290
Spain
I’m finally gobsmacked over it! My 12Pro constantly loses signal from home WiFi router. Nothing else does. Probably 5-7 times a day, sitting within 10 feet! My last hope is turning off the 5G, but that shouldn’t be effecting WiFi?
i have got the same as you, a lot of people are complaining on apple forum discussion
 
  • Like
Reactions: Random Dude
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.