iPhone 3.1.3 has tethering enabled again

Discussion in 'Jailbreaks and iOS Hacks' started by 4np, Feb 3, 2010.

  1. 4np macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #1
    Hi,

    On a Dutch forum many people are reporting the Tethering option has returned after updating to 3.1.3. However, there are also people who did not see the tethering option (like me).

    [​IMG]

    I was wondering if people here see the tethering option again? And if people know how to enable tethering (again?) if you do not see the option.

    I have a -never jailbroken- factory sim lock free Belgian iPhone 3GS 32GB on a Dutch cellular provider (Telfort Sim Only) and I do not see the tethering option. I have also tried installing the Telfort.ipcc but no luck either.

    Perhaps it has something to do with the provider? I use Telfort, which is in fact a daughter company of KPN (with which people are reporting tethering options). In my 'About' screen I see Network 'NL KPN' and Line 'NL Telfort', perhaps in 3.1.3 the Network Line will define if you can tether or not?

    Let me know :)

    Cheers!
     
  2. 4np thread starter macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #2
    Fixed

    Doing a restore (without restoring from a backup) and setting the iPhone up as a new iPhone fixes the issue. I now also have tethering settings available :)
     

    Attached Files:

  3. Dave6195 macrumors newbie

    Joined:
    Jul 7, 2009
    #3
    Is this the only way to fix it? Im not seeing tethering after the update but I really dont like the idea of setting up my iphone and all its settings from scratch? Any help please?
     
  4. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #4
    Just because the tethering control is there doesn't mean you can tether.
     
  5. umdirector macrumors newbie

    Joined:
    Nov 10, 2009
    #5
    AT&T tethering?

    So I am unclear. I have an AT&T phone. I used ben.m to tether. I have not upgraded phone as it ends it. Does this new update allow tethering with the AT&T ben.m config? Can I finally update?
     
  6. pratik5705 macrumors newbie

    Joined:
    Jan 13, 2009
    #6
    I can confirm that benm tether does not work on 3.1.3.

    I had it working on 3.0.1. Upgraded to 3.1.3 and I was happy to see it in General - Network. But when I turned it on, the settings vanished. Then I headed over to help.benm.at and tried to install the mobile config. I could install it yesterday (before benm put up 2.0 of his mobileconfig). With the old mobile config tether did not work. Can not install with new mobileconfig. Get an error saying "profile format not recognized". Tried to install config from unlockit.co.nz. Could install that, but does not enable tethering.

    I think with 3.1.3 tethering is enabled only for factory unlocked sims. Thats what unlockit.co.nz says.

    UPDATE: the benm site says that they know of the issue with the profile and AT&T customers and are working towards a fix. I will post back when the fix is posted.
     
  7. 123walter macrumors member

    123walter

    Joined:
    Jun 26, 2008
    Location:
    Petersburg VA
    #7
    Dont do it!

    I used to tether. I upgraded to 3.1. Using benm..I dont anymore. I dont have to, it was just an experiment..but my son does..and he stays on 3.0 and is able to tether. The restore thing....yes the tether screen comes back, until you choose to tether..then it goes away.(It did to me anyway) restore doesnt fix it.
     
  8. to1986 macrumors regular

    Joined:
    Oct 15, 2009
    #8
    Is the tethering only enabled on factory unlocked iphones? My iphone is locked on O2 UK, and i cant seem to get it to work.
     
  9. 4np thread starter macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #9
    Browsing back to the Dutch forum I mentioned earlier I see a clear pattern that people with a contract phone from T-Mobile do not have tethering available, while people with a Belgian (factory sim lock free) iPhone on other cellular providers (mainly KPN) do have tethering available.

    Apparently some time ago there has been a cellular provider update through iTunes for T-Mobile. I guess that that update somehow blocks the tethering ability? Did you have the same on O2?

    Perhaps Apple allows tethering for all phones, except if a provider they have a contract with does not want to allow it?

    That raises the question if there are people with a factory sim lock free iPhone on a carrier that has an exclusivity contract with Apple. Let's say someone with a Belgian iPhone on T-Mobile NL. Do they have tethering options available?

    [edit]just asked the same question on the Dutch forum as well... let's see what happens...[/edit]
     
  10. 4np thread starter macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #10
    Apparently, provider unlocked T-mobile phones on the T-mobile network do not show tethering, but when you put a KPN (who allow tethering) sim in the iPhone they do show tethering. That sounds like it's a carrier restriction within the iPhone OS?
     
  11. 123walter macrumors member

    123walter

    Joined:
    Jun 26, 2008
    Location:
    Petersburg VA
    #11
    Keep 3.0

    Just for the sake of argument..(i already lost tethering) I tried upgrading to 3.13...and tried the beta version over at ben.m..Im still tetherLESS.(My son wants to upgrade his 3gs....and he still has 3.0..so Im the guinea pig)
     
  12. to1986 macrumors regular

    Joined:
    Oct 15, 2009
    #12
    well after the 3.1 firmware update the option did disappear, however when the 3.1.2 update came out the 'set-up tehthering' option returned. However when u click it it asks me to go to the o2 website. It makes no difference if i download the profiles from benm.at

    I suppose it would make sense if they only allowed factory unlocked sims to have tethering, it is annoying though. Is there a way to unlock an iphone without jailbreaking it?
     
  13. gndagnor macrumors newbie

    Joined:
    Mar 28, 2009
    #13
    I got my iPhone 3G S here in Malaysia. Changed from the official service provider, Maxis to Celcom. After updating to 3.1.3, I didn't see the tethering option at first.

    Then I went to the Network settings to change the APN for the 3G connection and noticed that there's an "Internet Tether" section at the bottom. Put in the 3G settings in the blanks then the option to turn Internet Tether on/off was available in the main Network page. Tested it out on bluetooth and USB and both working fine!
     
  14. Fry-man22 macrumors 6502

    Fry-man22

    Joined:
    Nov 25, 2007
    #14
    You can tether 3.1.x

    I'm tethering 3.1.2 on my device and have been for about a month using the comm center hack posted at the link below. I really think this will work with 3.1.3 as well but I don't know. I'll report back on 3.1.3 after I confirm, but 3.1.2 works for SURE. Once you ssh the patched file over and load the mobile config it's just like it was in the good ol' 3.0 days...

    http://www.redmondpie.com/enable-tethering-on-iphone-3g-3gs-3.1.2-firmware-eqw846/
     
  15. Dyvim macrumors newbie

    Joined:
    Feb 4, 2010
    #15
    ...if you're jailbroken

    Well, yeah, jailbreakers have a variety of choices to enable tethering, and I'm sure they work on jailbroken 3.1.3 as well. I think what people are curious about is whether 3.1.3 enables tethering for non-jailbroken phones the way it worked on 3.0 and 3.0.1 (often had to install a custom mobile config file from benm or similar site but no jailbreak required). And it seems that 3.1.3 does enable tethering for non-jailbroken carrier unlocked phones. Which is great for many Europeans but doesn't help us AT&T customers (esp. since AT&T refuses to offer an official tethering plan).

    Looks like I'll be staying at 3.0.1 for a while longer now...
     
  16. BfB macrumors newbie

    Joined:
    Mar 10, 2010
    #16
    For those of you who are on AT&T, in order to get tethering on 3.1.3, the only current option is to jailbreak, and then installing MyWi. The IPCC tethering hack will not currently work on 3.1.3. Hopefully a future version of redsn0w will address this.

    Anyway, if you want to jailbreak, below are some instructions I typed up for 3G users (modified from RedmondPie and a few other places), to make it easy. You can obviously also jailbreak a 3GS, but not using these instructions. Also, keep in mind, there currently isn't a publicly available unlock for 3.1.3 (for those needing to use it on non-AT&T networks), so I'd suggest NOT updating to it. If on a version prior to 3.1.2, you can update to 3.1.2 and follow the instructions below.

    iPhone 3G Jailbreak Instructions (if running non-jailbroken 3.1.2 or 3.1.3)

    Extremely Important: These instructions are assuming that you have already done a FULL backup of your iPhone BEFORE attempting the proceedures below. Do NOT attempt without doing a backup first.

    Step 1: Download redsn0w 0.9.3 for Windows here.

    Step 2: Download iPhone OS 3.1.2 for iPhone 3G here. It is suggested to download it to your Desktop for ease of finding. If you already have 3.1.2 on your computer, you can skip this step.

    Step 3: Start redsn0w 0.9.3. Point it to the original iPhone 3.1.2 firmware to proceed. If on 3.1.3, this is required because redsn0w 0.9.3 cannot read or validate iPhone 3.1.3 firmware.

    Step 4: Now select “Install Cydia” option.

    Step 5: Now make sure your device is both OFF and PLUGGED IN to the computer before you click “Next”. At this stage you will be presented with a screen where you will have to quickly hold “Power” button and then while holding the “Power” button, you will now have to hold “Home” button too. Now after few seconds release “Power” button but keep holding “Home” button until installation begins.

    Step 6: Sit back and enjoy while redsn0w will do all the rest for you. Once done, your iPhone 2G will restart automatically and you will find it jailbroken with iPhone firmware version 3.1.3. You can now delete the 3.1.2 firmware from your Desktop.


    Activate Tethering Hack

    AT&T Customers: Install the IPCC Tethering Hack by going to http://is.gd/8QYHa on your iPhone. Install the mobileconfig, reboot, then turn on tethering in Settings→General→Network.

    Non AT&T Customers: Read the section entitled "What is the IPCC tethering hack?" here: http://wikee.iphwn.org/howto:rs9

    Note: The IPCC Tethering Hack does NOT yet work on 3.1.3. There is another option for 3.1.3 called "MyWi", which can be downloaded through Cydia. Installing "MyWi" should install "Rock", as well. If not, you can find it through Cydia, as well.


    Install asBattery (enables battery % meter on 3G) (OPTIONAL!)

    Step 1: Launch Cydia (it may go through an update process, and may even restart the iPhone springboard - if so, just restart Cydia when done). You can use Rock for this instead, FYI.

    Step 2: Tap on "Manage" tab at the bottom.

    Step 3: Then tap on "Sources".

    Step 4: Tap on the "Edit" button on the top right corner.

    Step 5: Tap on the "Add" button on the top left corner.

    Step 6: Tapping on add will open a pop-up where you need to enter the URL of the repository. Please enter the following exactly:

    http://apt.iphone-storage.de

    Step 7: Now tap on the "Add Source" button. Please wait for the repository to be installed. Once completed, return to Cydia, and hit "Done" at the top right corner.

    Step 8: Now tap on the Search tab at the bottom right corner of Cydia and search for "asBattery" (type it in to search exactly for it).

    Step 9: Click on and open the program.

    Step 10: Then tap the "Install" button at the top right, then click on "Confirm" on the next screen. This will install asBattery on your jailbroken iPhone.

    Step 11: After asBattery is successfully installed, reboot your iPhone (hold the power button on the top of the phone and fully power the phone off, then turn the phone back on).

    Step 12: You should now be able to enable the battery percentage indicator via the Settings App (General->Usage->Battery Percentage) just like iPhone 3GS users. Note: If for some reason your phone locks/freezes up during/after this, hold down the "Home" button and the "Power" button at the same time and wait for the phone to reboot. This will rectify it.
     
  17. IBradMac macrumors 68000

    IBradMac

    Joined:
    Jun 27, 2008
    Location:
    Ohio
    #17
    Awesome Bfb. Thank you.

    It's been a while since I have been jailbroken and decided to do it again for tethering. :)
     
  18. heartcookie macrumors newbie

    Joined:
    Mar 14, 2010
    #18
    @ BfB

    My iPhone is on 3.1.2 still, jailbroken with blackra1n--I installed Rock and also MyWi--it doesn't work. MyWi just closes after being open for maybe 10 seconds...
     
  19. BfB macrumors newbie

    Joined:
    Mar 10, 2010
    #19
    It's definitely not 3.1.2, nor is it because it was jailbroken with blackra1n. There is probably a corrupted file. I have 3.1.2 that is jailbroken, along with Cydia, Icy, Rock, and MyWi, and MyWi works perfectly (I've also done multiple other phones, and no issues). I'd suggest you uninstall MyWi then reinstall it. Otherwise, I suggest you restore to the factory 3.1.2, then jailbreak with redsn0w, then install the IPCC tethering hack, like I outlined above.

    Also, if you've had it for more than 7 (or is it 10?) days, it will not work anyway. You'll have to pay for it ($9.99).
     
  20. rokuez macrumors newbie

    rokuez

    Joined:
    May 18, 2008
    Location:
    ca, west la
    #20
    i'm on 3.1.3 with at&t as my carieer tried yoru instructions and it didn't work :(

    does my wifi need to be on ? i generally just use 3g . would i tether , meaning hav eto have a physical usb cable from iphone to macbook pro?

    i go to settings --> general -- > then at the bottom there is "Profile US AT&T Tethering

    i click on that it takes me to this profile page...



    not sure what ot do from there. there is a more details thing i can click on but no way to enable / disable tethering
     
  21. BfB macrumors newbie

    Joined:
    Mar 10, 2010
    #21
    if you read my thread above, it explains what you have to do.
     
  22. myuserid08 macrumors 6502

    Joined:
    Mar 15, 2008
    #22
    Has anyone managed to get tethering working on a unlocked 3.1.3 iPhone (O2)?

    Got my phone connected to bluetooth, tethering enabled, but when I click connect on my macbook it says device unable to connect.
     
  23. bradl macrumors 68040

    bradl

    Joined:
    Jun 16, 2008
    #23
    Hate to say it, but no joy for me, with 3.1.2 jailbroken.

    The jailbreak with redsn0w works perfect, just as the DevTeam laid it out. But the IPCC BfB mentioned above doesn't get me the Internet Tethering in Settings - General - Network. The option for Cellular Data is there, but nothing towards tethering.

    BL.
     
  24. bush1974 macrumors member

    Joined:
    May 1, 2009
    #24
    Are you using blacksnow? If not, install it even if you don't need the unlock. Tethering should return.
     
  25. BfB macrumors newbie

    Joined:
    Mar 10, 2010
    #25
    If it doesn't work, you can always install "MyWi". It works even on 3.1.3.
     

Share This Page