Iphone 3G Jailbreak 2.1 WIFI Problem...Please help!

Discussion in 'Jailbreaks and iOS Hacks' started by silverka, Nov 18, 2008.

  1. silverka macrumors newbie

    Joined:
    Nov 18, 2008
    #1
    Ill try to keep this brief...

    I just used Quickpwn 2.1 to jailbreak my 3g. First time doing this and all went well. No problem. I began using Cydia and Installer and played around with some themes and such. I wanted to install some themes that were not on cydia nor installer..I.E. one from the internet website..so I installed the Openssh package, again no problem. Then downloaded WINscp...again no problem. Prior to jailbreaking my iphone I have never had any problems with my wifi at my home. In fact my Pc is on wireless, as I sit here and type. I always have a strong connection on my Iphone 3g, but after jailbreaking I cant get it to keep a connection. It will find my network, and says it connects to it, but the edge symbol stays up there and no wifi symbol..If I go to settings and hit the airplane mode off then back on the wifi symbol comes on and I have a true connection..but the moment that I try to connect to anything, such as mail..app store, cydia, installer, openssh the wifi symbol drops off and the Edge symbol comes back up...all the while under wifi settings it says i am still connceted. So here is what i have done...
    1 Reset network settings....did not fix
    2 tried a static Ip...did not fix
    3 Restored/Revirginized Iphone and then set up wifi again...absolutely no problems, wifi connects and symbol stays put. I then jailbroke the phone again and the exact same problem...the wifi symbol will stay put untill I try to use something that makes a connection. I really wanna keep my phone jailbroke..i really like the customizing but if I cant keep wifi going I have no choice but to return to the land of simpleness. Please dont send me back to simpleville..wont somebody help me Please
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Do a full Restore of the entire iPhone. When iTunes asks you to set up from backup or set up as new phone select Set up as new Phone. This will eliminate and prevent all bad settings in the old configuration from coming back and leave you with a fresh start. After that just sync in your music, movies and contacts using iTunes. Jailbreak using Pwnage not Quickpwn.

    Word of advice, stick to the themes listed in Installer and Cydia, they are way safer than other themes.
     
  3. silverka thread starter macrumors newbie

    Joined:
    Nov 18, 2008
    #3
    Thank you for the response...I did exactly that when I did the restore after the first jailbreak. I set up as new phone. Still same problem. I will restore again and try using pwnage instead and see if that works
     
  4. Gota3g macrumors newbie

    Joined:
    May 27, 2009
    #4
    Hello, I just found this thread searching through google, which matches the problem I have with my 3g 8gig iPhone with 2.2.1update.

    I get the 3g, edge, and wifi mark randomly changing every couple seconds and every time it changes I would lose connection and have to reconnect or reopen whatever page or downloads I'm doing.

    This started happening pretty much right after jailbreak, and even after restoring the iphone to a new state I'm still getting wifi problems.

    I would stand right next to my wifi hub and the phone would still randomly have a e or 3g or the wireless mark.

    My brother with the larger cap 3g iPhone does not have any problem with connection. I used the same exact program to jailbreak and pretty much installed the same programs from cydia.

    Did you find out what the problem was?
    Thanks
     

Share This Page