iPhone 4.0 backup error

Discussion in 'iPhone' started by anjinha, May 16, 2010.

  1. anjinha macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #1
    It's pretty well known that there's an error that prevents the iPhone from backing up in 4.0. I know that you can get around that by installing the SDK but I wanted to avoid that because I have very limited space in my laptop. I saw somewhere that it was possible to fix that in iTunes but I can't find the thread. Can anyone help?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Is it an error or design by apple?

    If by design, I'm not sure there's a work around
     
  3. anjinha thread starter macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #3
    It's an error. I know I saw a fix somewhere but I can't find it.
     
  4. outphase macrumors 65816

    Joined:
    Jun 13, 2009
    Location:
    Parts Unknown
    #4
    It's not an error. There's a change in how backups are taken.

    The workaround you are looking for is iPhoneSystemComponents.pkg within the SDK packages.
     
  5. anjinha thread starter macrumors 604

    anjinha

    Joined:
    Oct 21, 2006
    Location:
    San Francisco, CA
    #5
    What do I do with it?
     
  6. outphase macrumors 65816

    Joined:
    Jun 13, 2009
    Location:
    Parts Unknown
    #6
    Install it.
     
  7. geko29 macrumors 6502

    Joined:
    Nov 10, 2008
    #7
    There was a "packages" folder in beta2 that contained the iPhoneSystemComponents.pkg, but I personally couldn't find it in beta3, so I wound up installing the whole base Xcode. I even checked the contents of the main installer and couldn't find the requisite .pkg file inside. Not saying it isn't in there somewhere (it has to be), but they made it a lot more difficult to find.
     

Share This Page