iPhone 4.0 WiFi issues

joelwalker71

macrumors newbie
Original poster
Apr 21, 2007
10
0
I have upgraded to iPhone 4.0, everything is working fine, expert for I am unable to join my WiFi network. It says, unable to connect. Has anyone else had this issue or know of a fix?

Thanks alot,
Joel
 

tavella81

macrumors newbie
Apr 8, 2010
1
0
I have a 3GS and I cannot connect either. Reset my network settings, rebooted, I'm lost at this point.
 

mudassarm251

macrumors newbie
Apr 22, 2009
7
0
no wifi 3GS

Same Here Tried Connecting "unable To Join" Reset Network Settings But Still Nothing... :(
 

CrownSeven

macrumors member
Aug 14, 2008
75
33
Same here. I've read that it works with some routers and not with others (I'm using netgear).
 

rc1993tx

macrumors newbie
Apr 8, 2010
16
0
i would add on to this but mine hasnt even added 4.0 to it -_-
"preparing to restore"
 

Neepawa

macrumors newbie
Apr 8, 2010
9
0
I'm having the same problem with my 3GS and a D-Link DIR-825 router. I tried it with both WPA2 and no security and had the same problem both ways.
 

Machinegun

macrumors newbie
Aug 25, 2009
15
0
Solution

Hey guys, I think I've found a solution. I'm using a Linksys WRT160n v.3 with custom firmware (DDWRT), and I had the unable to join wifi network message multiple times. I even reset my network settings multiple times which didn't help.

Then I remembered reading this support page from Apple:

http://support.apple.com/kb/TS3304

So, I set my router to G only and renamed that to whateverG then I tried to connected to it, and it worked! I'm now connected to my router so give it a try guys. I hope this helps :)

EDIT: Apparently, when I set it to B,G,N (mixed and my default from when I first started off with the problems) then I get the unable to connect message again. But B and G mixed is perfectly fine. Go figure.
 

CrownSeven

macrumors member
Aug 14, 2008
75
33
That worked beautifully! I have dual channel router, so I set one to be B + G only, and it worked! Thank you sir!
 

MacFan23

macrumors 6502
Feb 17, 2010
360
313
Hey guys, I think I've found a solution. I'm using a Linksys WRT160n v.3 with custom firmware (DDWRT), and I had the unable to join wifi network message multiple times. I even reset my network settings multiple times which didn't help.

Then I remembered reading this support page from Apple:

http://support.apple.com/kb/TS3304

So, I set my router to G only and renamed that to whateverG then I tried to connected to it, and it worked! I'm now connected to my router so give it a try guys. I hope this helps :)

EDIT: Apparently, when I set it to B,G,N (mixed and my default from when I first started off with the problems) then I get the unable to connect message again. But B and G mixed is perfectly fine. Go figure.
Sorry for my ignorance, but could someone explain this in laymen's terms?
 

Neepawa

macrumors newbie
Apr 8, 2010
9
0
Sorry for my ignorance, but could someone explain this in laymen's terms?
Modern routers use the latest 802.11n Wi-Fi standard, and most can support a wireless network using both 802.11n and the older 802.11g at the same time in the 2.4 GHz frequency band. However, the iPhone only supports 802.11g, and with the 4.0 upgrade for some reason it was no longer connecting to mixed g/n networks. Once the network was switched to 802.11g only, the iPhone could connect.

This might pose a problem if you have 802.11n equipment that you want to connect at 2.4 GHz, but most 802.11n routers can also support a second wireless network in the 5 GHz band. As in my case, you can then have 802.11g devices at 2.4 GHz and 802.11n devices at 5 GHz, all in one happy network.

Hopefully that helps.
 

MacFan23

macrumors 6502
Feb 17, 2010
360
313
Modern routers use the latest 802.11n Wi-Fi standard, and most can support a wireless network using both 802.11n and the older 802.11g at the same time in the 2.4 GHz frequency band. However, the iPhone only supports 802.11g, and with the 4.0 upgrade for some reason it was no longer connecting to mixed g/n networks. Once the network was switched to 802.11g only, the iPhone could connect.

This might pose a problem if you have 802.11n equipment that you want to connect at 2.4 GHz, but most 802.11n routers can also support a second wireless network in the 5 GHz band. As in my case, you can then have 802.11g devices at 2.4 GHz and 802.11n devices at 5 GHz, all in one happy network.

Hopefully that helps.
Thanks a lot for that :)
But I'm left a little confused about how to switch

I'm using Mac OSX 10.6.3 and a Belkin N+ Router which supports b,g and n
Would anyone mind posting a step by step?
 

Neepawa

macrumors newbie
Apr 8, 2010
9
0
Would anyone mind posting a step by step?
  1. Grab your router's manual at http://en-us-support.belkin.com/app/answers/detail/a_id/125
  2. Go to page 39
  3. Login to the router and go to the screen pictured
  4. Change the "Wireless Mode" to "802.11b+g"
  5. Apply changes; the router will probably have to reboot

This should allow your iPhone to connect, but it will also slow your Mac's connection from 802.11n to 802.11g since your router doesn't support a separate 5 GHz network.
 

MacFan23

macrumors 6502
Feb 17, 2010
360
313
  1. Grab your router's manual at http://en-us-support.belkin.com/app/answers/detail/a_id/125
  2. Go to page 39
  3. Login to the router and go to the screen pictured
  4. Change the "Wireless Mode" to "802.11b+g"
  5. Apply changes; the router will probably have to reboot

This should allow your iPhone to connect, but it will also slow your Mac's connection from 802.11n to 802.11g since your router doesn't support a separate 5 GHz network.
Awesome, that worked. Thanks a ton!
 

szhrmp

macrumors newbie
Feb 27, 2009
8
0
What a bug! I cannot believe that Apple hasn't tested this. I never had a problem connecting devices via Wifi to my router (printer, laptopts etc) - only the iphone 4.0 doesn't work anymore.

The solution to disable wireless-n is not really an option for my 50Mbit cable connection ...
 

joelwalker71

macrumors newbie
Original poster
Apr 21, 2007
10
0
What a bug! I cannot believe that Apple hasn't tested this. I never had a problem connecting devices via Wifi to my router (printer, laptopts etc) - only the iphone 4.0 doesn't work anymore.

The solution to disable wireless-n is not really an option for my 50Mbit cable connection ...

Completely agree with you, it's not on for me either. I use the 'N' speed transferring files between computers, plus i also have 50Mb. Hope apple bring out a beta 2 fast, seen as you cant downgrade.
 

Neepawa

macrumors newbie
Apr 8, 2010
9
0
If you have a dual-band router it's not quite as bad, but still annoying. I wonder if they introduced this problem when they added 802.11n support for new hardware?
 

andylyon

macrumors 6502a
Jul 23, 2008
753
8
London
Isn't this the same Wi-Fi problem that the iPad has been experiencing? Something to do with dual channel routers?

AnDy
 

rc1993tx

macrumors newbie
Apr 8, 2010
16
0
installed 4.0 on my iphone 3gs 16gb
and it works AMAZING!

wifi works and apps load a lot faster
 

Neepawa

macrumors newbie
Apr 8, 2010
9
0
I found an even better solution here. It seems that it's not 802.11n in general that's the problem, it's specifically the (optional) use of 40 MHz bandwidth through channel bonding. I switched my router back to g/n with a fixed 20 MHz bandwidth and the iPhone was able to connect at 802.11g while my Mac connected at 802.11n.

Hopefully that helps out those that want to keep 802.11n and have the iPhone 4.0 connected at 2.4 GHz.
 

iYellow

macrumors member
Jun 24, 2008
43
0
  1. Grab your router's manual at http://en-us-support.belkin.com/app/answers/detail/a_id/125
  2. Go to page 39
  3. Login to the router and go to the screen pictured
  4. Change the "Wireless Mode" to "802.11b+g"
  5. Apply changes; the router will probably have to reboot

This should allow your iPhone to connect, but it will also slow your Mac's connection from 802.11n to 802.11g since your router doesn't support a separate 5 GHz network.


Will wifi work on 4.0 if I choose "802.11n+g" ?

My brother has a very old mac, so the b+g won't work with his iBook which only does 802.11n. :confused: