iPhone 4, 4.2.1 jailbroken SBSettings "phone" toggle help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by LaClaire, Feb 6, 2011.

  1. LaClaire macrumors newbie

    Joined:
    Feb 6, 2011
    #1
    First off, i will admit that i'm a n00b at jailbreaking. I had it on my iphone 3GS and now my iphone 4. There was a SBSettings toggle on my 3GS jailbreak that would turn my phone app off, and my signal bar would appear "no service". I have installed SBSettings on my iphone 4 and tried everything but it just wont appear on the sbsettings slide down menu. Is anyone else having this problem or know a way to fix it. Any help is GREATLY appreciated.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    My phone toggle appears fine on sbsettings.
    Make sure its enabled. Open Sbsettings/more/set toggles and then select "phone" toggle to on.
    Then go back to the previous tab you were on sbsettings and the phone should respring. If it doesnt do it manually.
     
  3. LaClaire thread starter macrumors newbie

    Joined:
    Feb 6, 2011
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Weird, works fine here.
    You did a respring after you set the toggle to on? You try switching it on/off a few times etc...
     
  5. GTC macrumors newbie

    Joined:
    Feb 7, 2011
    #5
    me too

    I have the same issue. I...
    Flipped the toggle back and forth rebooting....Nope
    Re-installed sbsettings...Nope
    Uninstalled sbsettings, deleted var/mobile/Library/SbSettings/Toggles, rebooted, installed sbsettings, rebooted....Nope
     
  6. Synergie macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #6
    Same issue here, the phone toggle won't show up... I just turned it off. The 3G toggle does the same thing anyway doesn't it? At least for those of us without EDGE (Telus). At least if I turn off the 3G toggle, it turns off both my data and phone.

    I usually just use Airplane Mode anyway... I never have a need to just turn off the phone itself unless it's for the ringer and then I just use vibrate.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Are you all on 4.2.1 or 4.1 with this problem?
     
  8. neko girl macrumors 6502a

    neko girl

    Joined:
    Jan 20, 2011
    #8
    Why don't you use the Airplane toggle? You can still use WiFi in Airplane mode.
     
  9. greensauce macrumors newbie

    Joined:
    Feb 8, 2011
    #9
    I am having this same issue iPhone 4, 4.2.1, untethered jailbreak with greenpois0n

    What is frustrating is I have the "No SIM" error with my iPhone 4 see here. The sbsetting phone toggle FIXED this issue. All I had to do was turn that on and off and it fixed the problem. Now I have to go to Settings->General->Reset->Reset Network Settings (or pop out my SIM card).

    This error is very frustrating for me and I hope a fix is found soon.

    Also Airplane mode does not fix this issue. Only the phone toggle did that.
     
  10. LaClaire thread starter macrumors newbie

    Joined:
    Feb 6, 2011
    #10
    I used my phone toggle in order to keep unwanted texts from coming through while i was with a lady friend. No service > airplane logo
     
  11. ivandr macrumors regular

    Joined:
    Jul 1, 2010
    #11
    What SBSettings skin would that be? I really like it!
     
  12. webvan, Feb 8, 2011
    Last edited: Feb 8, 2011

    webvan macrumors member

    Joined:
    Oct 22, 2009
    #12
    Same problem here, been struggling with that since upgrading my 3GS to 4.2.1 yesterday, no way to get the "phone" toggle to appear.

    I think there's an issue with an SBSsettings, at least for some of us, because if you try to change the order of the toggles it doesn't get memorized. Same problem on my iPad so I suspect it's not something to do with the configuration of my iPhone 3GS.

    EDIT : I think I'm onto something, using SBSschedule, I only have 3G, Airplane, AutoLock, Bluetooth, Data, Location, Wi-Fi in the list of toggles...the only toggles that SBS Settings can show.
     
  13. LaClaire thread starter macrumors newbie

    Joined:
    Feb 6, 2011
    #13
    "A Uinique". The Theme costs 2.99 in cydia. Nit sure if you have to have the theme in order to get the sbsettings skin though.
     
  14. webvan macrumors member

    Joined:
    Oct 22, 2009
    #14
    It's gone, I just got that after sending en email to BigBoss via Cydia : "4.2.1 and newer users: Phone toggle does not work and has been disabled. It is not a "bug" that it does not show up. Use airplane."

    Bad news, in Airplane mode the phone doesn't ring...which makes sense, but doesn't work well for me as I want Sipphone to ring!
     
  15. Nightowl4272 macrumors newbie

    Joined:
    Feb 13, 2011
    #15
    The Phone toggle is gone? That's disappointing. I can think of situations where it would be nice to disable calls but still allow data through.

    It also seems odd that the option activate the toggle would still be on the SBSettings Set Toggles screen when the toggle itself has been disabled.
     
  16. webvan macrumors member

    Joined:
    Oct 22, 2009
    #16
    Looks like a bug, hopefully it can be ironed out. The fix I've found is poor : remove the SIM card at home...and of course I forget to put it back in almost each time!
     
  17. penix macrumors newbie

    Joined:
    Jan 1, 2009
    #17
    I just restored to clean version v4.2.1 and I'm having a number of issues now that I didn't have with v4.1.

    - The Phone toggle is turned on, but missing.
    - The Location toggle does not work.
    - Push not working on hacktivation using Push Doctor or SAM.

    I was able to fix push by restoring and just activating with an old AT&T SIM I had. The other two I can't find a fix for.

    For anyone who might be having a problem with Ultrasn0w giving a "No Service" or "Invalid SIM" error, this is how I fix that problem. Turn on airplane mode, then reboot the phone. Respring is not enough; you must reboot. Then after it comes up, wait about 30 seconds, then disable airplane mode. Sometimes it takes a few minutes, or takes more than one try, but I've always got it working again.
     
  18. Evilmonkee42 macrumors member

    Joined:
    May 5, 2009
    #18
    Well, at least I know I'm not the only one having this problem now.

    I just updated to 4.2.1 from 4.1 and re-jailbroke yesterday.

    Bummed to hear about the Phone toggle as I preferred that to the airplane toggle. Even so, this does not address the fact that you cannot reorder the toggles either. This bugs me more than the non-functioning phone toggle. I'm used to a certain layout and knowing where certain toggles are and now they are all screwed up. Really messes with the OCD in me. ;)

    Is this another bug with 4.2 that hopefully will be fixed soon?
     
  19. iWhitey88 macrumors newbie

    Joined:
    Feb 21, 2011
    #19
    Hey everyone. Long time MacRumors:Forums follower, first time poster here. Yesterday I updated my iPhone 4 from 4.0.1 to 4.2.1 and rejailbroke. I noticed that the phone toggle didn't work so I started to look around online and stumbled on this post. I was dissappointed to find out that they turned the phone toggle off. Hopefully someone can create something similar and throw it up on Cydia for us.

    On a different note, I noticed that some of you guys were having issues with your toggles not staying where you want them. I am not having this issue with my SBSettings. I think I know something to help you guys. Next time you move your toggles, try following this procedure.

    1. Click "move toggles"
    2. Move toggles you want
    3. Unclick "move toggles"
    4. Click "move toggles"
    5. Unclick "move toggles"
    6. Click button to go back to main SBsettings screen.
    7. Click Home Button
    8. Let phone respring.

    After following these steps, your toggles should be where you moved them. Hope this works for you guys. It works for me. Good Luck!
     
  20. Evilmonkee42 macrumors member

    Joined:
    May 5, 2009
    #20
    iWhitey thanks for the tip. I actually found that out earlier when I came across some release notes for sbsettings and one part caught my eye where it said something about changing the "Move Toggles" button to "Save" because it was causing confusion. Well, I never saw the button change to "save" but I tried clicking it again before exiting and letting it respring. I didn't have to do steps 4,5, and 6(doing it twice) for it to work though, but I guess it couldn't hurt.

    So at least I have my toggle positions back the way I like it but I do hope the phone toggle get's updated.
     
  21. webvan macrumors member

    Joined:
    Oct 22, 2009
    #21
    Got informed of an update for SBSSettings Toggles (or was it just SBSsettings ?) via Cydia today so I was hopeful the phone toggle would be back, but alas not :-(
     
  22. Evilmonkee42 macrumors member

    Joined:
    May 5, 2009
    #22
    Hmm, haven't seen an update to either in Cydia so far today(just checked).

    Latest version of sbsettings still shows as 3.2.1. You?
     
  23. webvan macrumors member

    Joined:
    Oct 22, 2009
    #23
    Yes, same here? I checked SBSsettingsToggle but couldn't see the version.
     
  24. Sethide macrumors newbie

    Joined:
    Jan 17, 2011
    #24
    That's too bad because sometime I would like to turn off the phone while using GSP. I believe with Airplane mode on the GPS is off :confused: (not sure at all but it seems like so)
     
  25. tforst macrumors newbie

    Joined:
    Mar 24, 2011
    #25
    are any of you using an unlocked iphone 4? i am and it occasionally shows no service or 1 bar (but no carrier name) and the only way to fix this is to turn the phone off and reboot it (sometimes i need to reboot multiple times before t-mobile shows back up). Everytime i turn it off it gets stuck on the apple logo and i need to plug into my computer and run the redsn0w program to get it turned back on... does the sbsettings app phone toggle feature (if it wasn't disabled) fix the no service or 1 bar problem on unlocked iphone 4's?

    any help would be appreciated.
     

Share This Page