iPhone 4 interface not so smooth?

Discussion in 'iPhone' started by lentus, Jul 11, 2010.

  1. lentus macrumors member

    Joined:
    Jul 11, 2010
    #1
    Hey,
    I've had my iPhone 4 16gb for about a week now and I'm loving it.
    It's just that the interface isn't as smooth as I'd like it to be.
    For e.g. when I unlock from the lock screen to the first page of icons the animation is a little jerky (low FPS).
    Or when I use the double-tap home button for multitasking, then tap back to home screen it stutters a bit aswell. When I repeat the process, the next attempts seem smoother. It's like the phone needs to "load the process" before it starts doing it smoothly.
    Is anyone else experiencing this?
    Should I restore the firmware? I haven't touched it on my new iP4 yet.
    Thanks for your replies in advance!
     
  2. xmtgx macrumors regular

    Joined:
    Jun 21, 2010
    #2
    No problems here, happened on my 3g though i hated it.
     
  3. LegendKillerUK macrumors 6502

    Joined:
    Apr 9, 2010
    #3
    I noticed this on my mates iPhone 4 awell.

    Hell, in the advertisement on Apples site when the girl sends a text it doesn't jump into the bubble and into the conversation window totally smoothly. I think the days of the always slick UI are probably over just because the phone does so much more than it orginally did.
     
  4. bobdigi macrumors regular

    Joined:
    Jun 23, 2010
    Location:
    Baton Rouge, LA
  5. Feffi macrumors newbie

    Joined:
    Jun 23, 2010
  6. lentus thread starter macrumors member

    Joined:
    Jul 11, 2010
    #6
    do you mean restoring?
    restarting doesn't help
     
  7. Dr Kevorkian94 macrumors 68020

    Joined:
    Jun 9, 2009
    Location:
    SI, NY
  8. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #8
    did you set it up as a new phone or restore it from a backup from an older phone (if you had one)
     
  9. Jordan921 macrumors 68040

    Jordan921

    Joined:
    Jul 7, 2010
    Location:
    Bay Area
  10. HiFiGuy528 macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
  11. lentus thread starter macrumors member

    Joined:
    Jul 11, 2010
    #11
    yeah it actually was a restore of my old iPhone 3G
     
  12. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #12
    that could be the problem. my 3G lags soooo bad so as soon as my 4 gets here I'm just gonna set it up as a new phone instead of copying whatever is slowing it down/draining the battery so bad over to the new phone. you could back it up then set it up as a new phone and see if that helps and if not just restore from your backup or bring it back. I think it would fix it though.
     
  13. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #13
    I had this problem too. I too restored from a previous backup and had slowdown doing certain actions. Going to settings, general, reset and resetting my settings solved a lot of problems with my phone. It won't erase any data but you will have to redo your mail settings etc
     
  14. tuatha macrumors regular

    Joined:
    Jun 24, 2010
    #14
    what the hell is with laggy touchscreen keyboards anyway?

    seems like every manufacturer suffers from this to some degree. you'd think the keyboard would be one of the more important things on a smartphone, but nobody seems to be getting it right.
     
  15. Tom G. macrumors 68000

    Tom G.

    Joined:
    Jun 16, 2009
    Location:
    Champaign/Urbana Illinois
    #15
    No problems with this on my former 3GS and no problems that I've noticed on my iP4.
     
  16. itsmemuffins macrumors 68030

    itsmemuffins

    Joined:
    Jun 23, 2010
    #16
    My iP4 is as smooth as butter :)

    I set it up as new ;)
     
  17. michaelfields macrumors regular

    Joined:
    Apr 8, 2010
    #17
    awesome :D
     
  18. Fernandez21 macrumors 601

    Fernandez21

    Joined:
    Jun 16, 2010
  19. bluer101 macrumors regular

    Joined:
    Jun 22, 2010
    #19
    I set up our ip4's as new since some people have had some problems. Besides we were coming from the original iPhones also, so a fresh start was needed.
     
  20. LoLife macrumors regular

    Joined:
    Jun 1, 2010
    Location:
    Reno, NV
    #20
    My i4 has a little lag on it when sending messages, typing and little things like that. Screen to screen is smooth though. I haven't even set my phone up to itunes yet but when I do I will sync it to my old 3G
     
  21. lentus thread starter macrumors member

    Joined:
    Jul 11, 2010
    #21
    ok so how do i setup my ip4 as a new phone and still keep all my data? :)
     
  22. insidmal macrumors 6502

    insidmal

    Joined:
    Jun 24, 2010
    Location:
    Eugene
    #22
    how strange, whenever i use mine i'm always amazed by how smooth and fast it is.. sometimes I open and close apps just cause i get in awe when i see how fast and smooth the transition is, lol
     
  23. upsguy27 macrumors 65816

    upsguy27

    Joined:
    Jun 25, 2007
    Location:
    Arizona
    #23
    Yep, mine's been lagging recently. The keyboard will lag when I'm typing or when I use multitasking to switch to an app it will take forever to load the app, like it's reopening it.

    Also, I had the problem yesterday where if you locked the phone, after the lock noise, it would make weird sounds. I heard of someone else having that problem.
     
  24. HiFiGuy528 macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
    #24
    Mine was set up as new iPhone. I never restore from backup.
     
  25. OHCasper macrumors newbie

    Joined:
    Jul 6, 2010
    #25
    Chock me up as another having this problem. Typing lags, switching apps is jerky, etc. The typing is especially bad when typing in an input box on a website, such as this forum.
     

Share This Page