iPhone 4 ios4.0 update > 4.1 NOT 4.2

Discussion in 'Jailbreaks and iOS Hacks' started by will0407, Dec 18, 2010.

  1. will0407 macrumors 6502a

    Joined:
    May 20, 2006
    #1
    Hi,
    I have an iphone 4 on ios4.0. I want to update to 4.1 NOT 4.2 as I want to be able to call facetime emails. I also want an untethered jailbreak hence only wanting to go to 4.1

    Is there a way to do this? I've googled a fair bit but can't seem to find anything.

    Will
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    You can only upgrade to 4.1 if you have the SHSH saved.
     
  3. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #3
    I'm pretty sure Apple has stopped signing iOS 4.1, meaning that you can't update to it. You can only go directly to iOS 4.2
     
  4. will0407 thread starter macrumors 6502a

    Joined:
    May 20, 2006
    #4
    Is there no way to block the apple verification process?
     
  5. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #5
    :eek:
     
  6. Rajani Isa macrumors 65816

    Rajani Isa

    Joined:
    Jun 8, 2010
    #6
    Block? No. Circumvent? Yes... by having your SHSH blobs saved.

    The only other way I think might do what you want, won't work (IIRC) for iPhone 4.

    Have you previously jail-broken your current phone? If so, cydia MIGHT have your blobs.
     
  7. will0407 thread starter macrumors 6502a

    Joined:
    May 20, 2006
    #7
    yes, my iphone is currently jailbroken, ill save my SHSH now and give it a try again using the guide i found online
     
  8. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #8
    Unless the old SHSH were saved when Apple was still signing / sending them out, you will only be able to save the latest on, which is 4.2.1.
     
  9. will0407 thread starter macrumors 6502a

    Joined:
    May 20, 2006
    #9
    OK, guess I'll have to wait for an untethered jailbreak then :(
     
  10. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #10
    you can save future shsh but not past. my shsh blob is saved for 4.2.1 even though I am still 4.1. word is untethered jb Christmas Eve fingers crossed!
     
  11. lokerd macrumors 6502a

    lokerd

    Joined:
    May 2, 2010
    Location:
    Beaumont
    #11
    Hello. I just bought a ip4 to serve as a iTouch with GOOD camera to compliment my iPad.

    The seller informs me it has 4.02 and is NOT jailbroken.

    From this thread, I see I can not upgrade to 4.1.

    Was there a reason the poster wanted to do 4.1 rather than 4.2.1 OTHER than not be able JB? IOW, what did 4.1 offer over 4.0.2???

    Also, can I easily JB the 4.02 right now? Or must I wait for the 4.2.1 Christmas present.

    Thanks!
     
  12. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #12
    4.2.1 is a tethered jailbreak, meaning every time you reboot your iPhone you did the software to turn it back on.

    On 4.0.2 you can either jailbreak with LimeRa1n or www.jailbreakme.com (on safari/iphone).

    When Apple releases a new firmware they stop signing the old one on their servers. So the only way to get to the old iOS version is by having the SHSH files saved. SHSH are needed to downgrade/upgrade/restore your iPhone.
     
  13. dgstan macrumors 6502a

    Joined:
    Jun 29, 2010
    #13
    I believe 4.0.2 patched the PDF exploit used by jailbreakme.com. You probably meant to say "On 4.0.2 you can either jailbreak with LimeRa1n or GreenPois0n".

    4.1 has many features 4.0.2 didn't have, most important (to me anyway) was the HDR camera.
     
  14. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #14
    Yeah. My fault. You're right.
     
  15. lokerd macrumors 6502a

    lokerd

    Joined:
    May 2, 2010
    Location:
    Beaumont
    #15
    Hmmm. So if I jb it when I get it, I won't be able to restore? Iow, if I back it up when I get it, I can't save the shsh incase I need to restore?

    Sounds like it would be better to just up it to 4.2.1 and then be patient.

    Wow, I didn't realize that!!! The camera was a motivating factor in getting the ip4. Sounds like based on the above, I should up the phone to 4.2.1 since I have a jbed iPad anyway.
     
  16. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #16
    Exactly. The SHSH are needed to restore when Apple stops signing the firmware. You don't have to be jailbroken to save the SHSH blobs either. TinyUmbrella will save them if you are not or are jailbroken.
     
  17. mikelegacy macrumors 65816

    mikelegacy

    Joined:
    Dec 5, 2010
    Location:
    Pittsburgh, PA
    #17
    All good information, as im new to jailbreaking! Thanks a lot!
     
  18. mikelegacy macrumors 65816

    mikelegacy

    Joined:
    Dec 5, 2010
    Location:
    Pittsburgh, PA
    #18
    And also, I've read that you can downgrade from 4.2 to 4.1, If you have the 4.1 IPSW couldn't you just jailbreak using that and then kick it out of recovery mode with TU and voila 4.1! Or am I completely stupid? haha
     
  19. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #19
    Yeah. When you downgrade the iPhone, after it's finished in iTunes you'll get an iPhone error message 1015 or 1604 (iPhone stuck in recovery). Then you use TinyUmbrella to kick your iPhone out of it.
     
  20. mikelegacy macrumors 65816

    mikelegacy

    Joined:
    Dec 5, 2010
    Location:
    Pittsburgh, PA
    #20
    l was just saying because couldn't that be a solution to the OP's problem? he could just upgrade, then downgrade and he'll be on 4.1 where he wants. idk, this is all new to me so I'm just speculating haha.
     
  21. noiceT macrumors 6502a

    Joined:
    Jul 7, 2008
    Location:
    Catalina Wine Mixer
    #21
    You still need to have saved shsh blobs for 4.1. (upgrade or downgrade) of any fw that is not the current, for iphone 4 at least. This varies however per different devices. I.e. 3G can upgrade and downgrade freely, as apple signs all fw on that device.
     
  22. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #22
    Partly true. With 4.0 and higher on the 3G you need the SHSH to downgrade. If you went from 4.0 to 3.1.3 then you don't need the SHSH.
     
  23. will0407 thread starter macrumors 6502a

    Joined:
    May 20, 2006
    #23
    After reading through all this, and understanding some of it, it seems like i'll have to wait for the 4.2.1 jailbreak
     
  24. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #24
    4.2.1 can be jailbroken on all devices. Depending on which device you have the jailbreak will be tethered or untethered.
     
  25. will0407 thread starter macrumors 6502a

    Joined:
    May 20, 2006

Share This Page