iPhone 4 iTunes Error 1004

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fabian9, Jun 24, 2010.

  1. fabian9 macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #1
    I received my iPhone 4 today and didn't restore the correct backup. So I wanted to restore the phone so that it would give me the option of restoring a different backup again... I shouldn't have done that.

    iTunes failed to restore and it's giving me iTunes Error 1004. I've tried it about 10 times now, re-downloading OS4, different computers, different USB cables, etc. and it keeps giving me 1004.

    Has anybody else had this before? I saw that a couple of other people are getting 1004 errors over in the apple support forum, but there doesn't seem to be a solution so far.

    Been on the phone with Apple for 30 mins to ask for advice, they basically told me to do the same thing as I've already done.

    Any ideas?
     
  2. fabian9 thread starter macrumors 65816

    fabian9

    Joined:
    Nov 28, 2007
    Location:
    Bristol, UK
    #2
    just in case anybody else runs into this.

    if you have modified your hosts file in order to backup your iBBC and iBSS files to jailbreak, you'll have to set it back to the original in order to avoid error 1004.
     
  3. tekninjoe macrumors newbie

    Joined:
    Jun 24, 2010
    #3
    how?!

    how do I go about resetting the hosts file so I can restore? Please help this sucks not being able to use my new iphone :(
     
  4. JReynolds macrumors 6502

    Joined:
    Apr 16, 2009
    Location:
    Where the Air Force sends me
    #4
    BUMP

    same problem! how do we make our itunes work again?

    PLease help
     
  5. Love Juice macrumors regular

    Joined:
    Jun 2, 2008
    #5
  6. p-rice macrumors regular

    Joined:
    Apr 18, 2010
    Location:
    Las Vegas
    #6
    Thank you so much. I was getting a little worried because I leave to Hawaii in the morning and I didn't want to board the plane with a semi-broken iPhone 4.
     
  7. tekninjoe macrumors newbie

    Joined:
    Jun 24, 2010
    #7
    thanks for your help

    I was freaking out yesterday and therefore impatient but using the clue of hosts file I went ahead and removed all host files from private/etc. Restarted, restored, once it got to the 55% area of the restore where it had been stopping.. I ran BLACKRA1N to purge it and voila it worked.. LOL then I replaced the hosts files.. Me and my impatience :) Thanks again though your way will likely help in the future :)


    FYI: Using BlackRa1n as a purge is an awesome way to install custom fw without having to deal with DFU mode :)
     
  8. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #8
    I'm having the same problem. I've fixed the host file to be normal but I keep getting the same error. I've even tried reinstalling iTunes. No luck. =(

    EDIT: LOL @ self. As always, a reboot does the trick. After the changes to the host file & reinstalling iTunes, I didn't reboot before trying to restore. Oops!
     
  9. durtyd929 macrumors newbie

    Joined:
    Jun 29, 2010
    Location:
    Miami, Fl
    #9
    I've been having the same problem with the error code, I've been trying to restore because my push notifications arent working on my iphone 4 either. I have modified the host file as well(for my 3gs). When I try editing it back to normal, I am unable to save the changes due to insufficient access privileges. So I modify the access privileges and am still unable to save the changes to the host file, I am following the instructions exactly, this is frustrating to say the least. If I am unable to to make these changes, I can't restore from this computer. If anyone can offer some insight, I would greatly appreciate it!
     
  10. Hunter109 macrumors newbie

    Joined:
    Dec 24, 2008
    #10
    This will bypass the error 1004. After it installs the iOS4.1 update it sends your phone into recovery mode and says you have to recover it...so its installed, so why do you have to recovery it? You dont.

    If you have a mac you can download this app called Recboot. (google it)

    have your iphone plugged in, and open the app. click exit recovery mode and your iphone will boot right up running the new updated version.

    As far as i know recboot is still only for mac and not windows based systems.

    PS - I got the 1004 error as well
     
  11. cmycl macrumors newbie

    Joined:
    Jul 16, 2010
    #11
    The fix

    Love Juice is spot on!

    Go to /private/etc/ then open your host file. If you have anything saying "gs.apple.com xx.xx.xxx.xxx" (x=IP), you will need to delete or comment this out. You can comment out the entry by placing a "#" before the entry. Save the file and you should be good to go!

    This is a fix for Macs.
     
  12. goodcyning macrumors newbie

    Joined:
    Jul 16, 2010
    #12
    Love Juice, thank you

    forgot I had done this to downgrade a few months ago (in order to jailbreak). Thanks much!
     
  13. intoyourhead macrumors newbie

    Joined:
    Jul 28, 2009
    #13
    Thanks a lot for this! Was having the same problem with my new iPhone 4 after downloading 4.01. Edited the file, rebooted Windows and voila. A night of heartache avoided. Had completely forgotten that I'd been tinkering with code months ago with my old 3G
     
  14. coolpal macrumors member

    Joined:
    Oct 27, 2006
    #14
    Thank you.. that did the trick for me.
     
  15. bagashy macrumors newbie

    Joined:
    Aug 19, 2010
    #15
    You dont need to change the host file when you get that error

    1004 error the software is already loaded in your device what you need to do is to use to kick your iphone out of recovery mode which is only a click of a button
    it takes less than a minute for your iphone to be back to normally with correct firmware

    i hope that help

    recboot For Window


    thank you
     
  16. shazzzam28 macrumors newbie

    Joined:
    Aug 26, 2010
    #16
    Thanks

    Thank you, thank you, thank you!!!! i thought i was going to have to buy a new iphone.... this really helped me! Thanks again!

     
  17. DaLurker macrumors 6502

    Joined:
    Mar 30, 2006
    #17
    Thanks for this post OP. Resolved my issue :)

    Can't believe I forgot about my host file edit...
     
  18. Frado macrumors member

    Joined:
    Sep 13, 2009
    #18
    Did apple blacklist the 4.0.1 update or something?:D . Wanted to restore to 4.0.1( now on same fw), but it says my iphone is not eligible for the requested build..
    Can this be fixed? Was trying to restore once again(facetime doesnt work), but it's not possible anymore?
     
  19. webs1 macrumors member

    Joined:
    Aug 14, 2008
    #19
    Yes, they stopped signing the SHSH blobs some time ago. If you have used Cydia or FWUmbrella to backup you SHSH blobs, you can still restore to 4.0.1.
     
  20. romadu macrumors newbie

    Joined:
    Jan 21, 2010
    #20
    Recboot fixes the problem

    The previous poster who suggested using RecBoot to exit Recovery Mode is correct. This fixed the problem for me.

    I was updating from 4.0.1 jailbreak to 4.1 (to use HDR photos) but kept getting error 1004. After I used RecBoot Exit, the phone started as normal and I was able to restore my data to it.
     
  21. renejakobsen macrumors newbie

    Joined:
    Sep 9, 2010
    #21
    the solution is recboot

    i had the same problem, but used recboot which helped, but my sim card was then sim locked, but then i just called the company and gave them the imei number, then i got my iphone back as before!!
     
  22. ark561 macrumors newbie

    Joined:
    Nov 28, 2009
    Location:
    Columbus, OH
    #22
    Had trouble updating to 4.1, and this worked for me. I totally forgot that I changed the file.
     
  23. Scidd0w macrumors newbie

    Joined:
    Aug 9, 2010
    #23
    I had the same error and fixed it via TinyUmbrella for windows. It has an kick out of recovery command.
    What I noticed was that my iPhone4 is updated to 4.1 but the baseband is not updated. I'm still on baseband (modem firmware) 01.95.00 and not the new 2.10.04.

    Now I have a question about this. I have a factory unlocked iPhone4 and thus don't care about unlocking it via jailbreak. I saved my 4.01 and 4.02 blobs for if I decide to jailbreak it in the future (maybe when I have a wifi ipad).
    Now my question:
    Is there anything else updated in the modemfirmware besides the unlock protection?
     
  24. Jr8oh8 macrumors newbie

    Joined:
    Oct 11, 2010
    #24
    Hey, I just wanted to thank you for this solution! I realized after trying to restore it, that i was doing something wrong. Then I googled the error and came upon these forums. Thankfully I found your solution, because a while back I remembered I tried to downgrade my new iPhone. So I modified iTunes and what not. But I upgraded my software before I edited the text files. So I encountered this problem when I was trying to upgrade my dads' iPhone 4! When I kept getting this error I freaked out, because my father is a business man and he needs his phone consistently. So if it wasn't for you advice I would have been in deep trouble. So I just wanted to thank you personally through this message for your help!
     
  25. nveeel macrumors newbie

    Joined:
    Oct 12, 2010
    #25
    I phone 4 (4.0.1 JB) stuck at rec while updating to 4.1

    Dear all
    I could resolve my problem with the help of Tinyumbrella's Kick out of rec tab.:)
    Wld like to JB with GP.Any suggestions for the choice of JB?:confused:
     

Share This Page