iPhone 4 stuck in recovery mode after installing 4.2 GM HELP!

Discussion in 'iPhone' started by sdm1985, Nov 2, 2010.

  1. sdm1985 macrumors 6502

    Joined:
    Jul 1, 2008
    #1
    Hi,

    I have downloaded the GM 4.2 installed it on my phone and I can't pull the phone out of recovery. I have tried tiny umbrella but it won't work.

    Can somebody help, I have the latest iTunes (I think), an iPhone 4 and I assume the correct GM 4.2 - how can I get out of recovery and I also have the new iTunes logo on the screen
     
  2. Jeff Flowerday macrumors regular

    Joined:
    Aug 23, 2007
    Location:
    Calgary, AB
  3. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
  4. sdm1985 thread starter macrumors 6502

    Joined:
    Jul 1, 2008
    #4
    When i click iTunes...about..it says..

    ..10.1b10 (10)
     
  5. LiquidThunderLT macrumors member

    Joined:
    Jun 21, 2009
    #5
    I'm having the same problem. 10.1 beta in OS X. I've gotten so many 4-code errors I can't even keep track of them, 1004, 1013, 1038, etc. No matter if I try and restore to official 4.1 firmware or 4.2 GM or what, it will NOT go out of DFU mode. pretty ****ing awful. starting to think I'm just not going to have a phone until this comes out officially :(
     
  6. sdm1985 thread starter macrumors 6502

    Joined:
    Jul 1, 2008
    #6
    Are you running the same iTunes as me? iPhone 4? When I chose the file for iTunes it confirmed that the phone would be restored and 4.2 installed.

    I am stuck in recovery mode and have the usb and new itunes logo on the screen. :( :(
     
  7. Jeff Flowerday macrumors regular

    Joined:
    Aug 23, 2007
    Location:
    Calgary, AB
    #7
    Have you guys tried unplugging the phone, rebooting the iPhone and then plugging it back into your computer?
     
  8. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #8
    Are you a legit dev?

    Have you tried re-installing via Xcode?

    Have you tried putting your phone in to DFU mode and restoring to 4.1?
     
  9. LiquidThunderLT, Nov 2, 2010
    Last edited by a moderator: Nov 2, 2010

    LiquidThunderLT macrumors member

    Joined:
    Jun 21, 2009
    #9
    yup same itunes and an iPhone 4 :(

    ---------------------------

    I have tried unplugging my phone and rebooting, rebooting my computer, using a different usb cable, a different usb port, etc.

    i just reinstalled the itunes 10.1 beta from a different .dmg I got from a different torrent and used tinyumbrella to kick my phone out of DFU. I finally got to the point where I can restore my phone from a backup and it's-reactivated now, no more DFU screen, it's currently restoring. the most recent restore I tried while it was stuck on DFU was a 4.1 ipsw so I think that's what it is running, once it's restored I will try and go up to 4.2 again
     
  10. sdm1985, Nov 2, 2010
    Last edited by a moderator: Nov 2, 2010

    sdm1985 thread starter macrumors 6502

    Joined:
    Jul 1, 2008
    #10
    No not a developer and have never had a problem with GM releases before, also other non-developers haven't had a problem.

    I am getting really frustrated now. How can I get this phone out of recovery mode?

    were you still through the process of 4.2 when you used tiny umbrella or had you restored and iTunes installed 4.1?
     
  11. iShorty macrumors regular

    iShorty

    Joined:
    Jun 23, 2010
    Location:
    Nottingham, UK
    #11
    Check list;
    1. Should be a dev
    2. Should have iTunes 10.1b2
    3. If you're on windows, try adding the IPSW to %appdata%/Apple Computer/iTunes/iPhone Software Updates then Shift + Restore to that location
    4. If all fails, give up.
     
  12. lskeys macrumors member

    Joined:
    Apr 27, 2010
    #12
    I had the same problem until I opened the iphone 4 developer profile in Xcode. The itunes was able to verify everything with the apple servers. Install went smooth after that.:D
     
  13. TOOFY macrumors regular

    Joined:
    Jun 24, 2010
    Location:
    Long Awhlandddd, NY
    #13
    How about you tool bags just wait for the damn release. :eek:
     
  14. imac9556 macrumors 6502a

    Joined:
    Jul 12, 2004
    #14
    Yeah, I learned my lesson not to use a "pre-release" as the OS for the device that I use to take my notes with. Today my iPad crashed and froze so I rebooted it, it kept on going to recovery mode....

    Use this app called (google it) "recboot", I used it to get out of recovery mode after several tries. It took the iPad about 5 minutes to "boot" with the apple screen after I clicked "exit recovery..."
     
  15. kepner macrumors 6502

    Joined:
    Sep 7, 2003
    #15
    I'm a developer and had this problem. To fix it, I clicked the "Kick Device out of Recovery Mode" button in TinyUmbrella.
     
  16. cirial macrumors regular

    Joined:
    May 2, 2010
    Location:
    Pompano Beach, FL
    #16
    Same thing happened to me..

    I installed the iTunes 10.1 beta 2 on Windows 7 x64, and all seemed well as it was updating until it got to the part where it wanted to update my iPhone 4's baseband, then it errors out everytime with Error 1013.

    Trying to install 4.1 final downloaded directly from Apple gives me a similar (but not the same) error.

    I find that iTunes 10.1 beta 2 is hugely buggy when syncing Apps as well.

    I now have 4.2 with the 4.1 baseband. I used tinyumbrella to kick my phone out of recovery mode.

    Never jailbroke my device
     
  17. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #17
    I'm a developer and did not have this problem. But when I installed it n my second development device (forgot to register UDID) it did this until the UDID was registered in the provisioning portal.
     
  18. cirial macrumors regular

    Joined:
    May 2, 2010
    Location:
    Pompano Beach, FL
    #18
    Interesting.. I'm not a dev. Were you getting the 1013 error when it got to the baseband portion?
     
  19. Tannerozzy, Nov 4, 2010
    Last edited: Nov 4, 2010

    Tannerozzy macrumors regular

    Tannerozzy

    Joined:
    Feb 2, 2008
    Location:
    Waco, Texas
    #19
    Same problem here. I updated my iPad to 4.2 GM a couple nights ago. Everything is running smoothly, so I decided to update the iPhone 4 as well.

    I keep getting error 1013 or 1004 and the device goes into recovery mode. Frustrating.


    I'm not a dev btw, I just really wanted AirPlay.


    Update: I ended up using TinyUmbrella to get it working again. Guess I'll just wait for the official 4.2 and iTunes releases (hopefully next week).
     
  20. kepner macrumors 6502

    Joined:
    Sep 7, 2003
    #20
    After I used TinyUmbrella to kick my device out of recovery mode, it was running 4.2. Are you sure yours isn't?
     
  21. DribbleCastle macrumors regular

    DribbleCastle

    Joined:
    Apr 17, 2009
    Location:
    Seattle, WA
    #21
    Finally figured it out

    I was a little nervous for a while that I put my phone into a useless state but then I figured it out with a little help from this forum. Thanks! Let me tell you my story and hopefully it will help someone.

    I had the same error 1013 after a botched upgrade to 4.2 running the itunes 10.1 Beta. I tried to use Tiny Umbrella to exit the recovery mode but was unable to successfully do so. It just kept rebooting to the plug into itunes screen.

    I then attempted to revert to iOS 4.1 but was met with another error 1004 on restore. At this point I thought I was screwed. I then used TinyUmbrella again to exit recovery mode which worked. Good news, I was set back to useable 4.1 iPhone.

    For whatever reason I wanted to give it one more try so I upgraded to 4.2 again. Same error 1013 :mad:, however, I this time I was able to use TinyUmbrella to successfully exit recovery mode which allowed me then to restore my backup to the phone.

    I'm happy I stuck with it. The airplay integration in 4.2 is sick! I now can easily use a Airport Express to stream podcast to areas of my apartment like the bathroom etc. with ease. Love it! Airplay for audio works anywhere there is an audio slider. iTunes store streaming, Pandora, Remote App, you name it. Great addition to an already amazing phone. I'm now really interested in the new AppleTV and the upcoming AirPlay equipped third party speakers.
     
  22. xraytech macrumors 68020

    Joined:
    Mar 24, 2010
    #22
    Google "RecBoot"
     
  23. RS232 macrumors regular

    RS232

    Joined:
    Mar 10, 2009
    #23
    Got GM 4.2 on my iPhone 4 finally!

    I had similar problems like you... I nearly gave up and used TinyUmbrella to get it back to 4.1!

    But if you use this solution from Apple Discussion Forum... http://discussions.apple.com/thread.jspa?threadID=2480871&start=0&tstart=30

    (Essentially editing the 'host' file which is easy peasy), it works and now I'm on 4.2!!! :D

    I'm using the beta version of iTunes too. I hope this helps folks out there.
     
  24. entaum macrumors newbie

    Joined:
    Mar 4, 2010
    #24
    Same issue here.

    Solved by editing the HOSTS file and commenting/removing the gs.apple.com line as shown above.

    On Iphone 4 with IOS 4.2GM and Itunes b2.
     
  25. ajarnfalang macrumors regular

    Joined:
    Oct 27, 2010
    #25
    Why can't you guys just wait until stuff officially comes out? :confused:
     

Share This Page