iPhone 5 "no service" problem

steve31

macrumors 6502a
Original poster
Jul 20, 2007
908
30
Edmonton Canada
Is anyone having a problem with the iPhone loosing service? I am on the Bell network and it seems that the iPhone is loosing LTE and not dropping back to 3G proper. I am coming from the Galaxy S3 and have always had stellar LTE service. But the iPhone seems to have a problem. I have read that there are a LOT of people having this problem with AT&T, Bell and Telus networks. I talked to a technician with Bell and he said that there is a major problem with the iPhone 5 and there network and that both Bell and Apple are working on solving this problem. Just curious who else is affected by this.
 

playtillyadrop

macrumors member
Mar 20, 2011
81
8
yea i have noticed this problem as well. I'm on rogers, a reset usually fixes the problem. Hopefully they can get this problem sorted out as its pretty annoying.
 

jmkjmk

macrumors newbie
Sep 26, 2012
1
0
I'm on Bell and I seem to have the same problem. I haven't noticed when it happens, all I know is sometimes I'll take my phone out of my pocket and it will say No Service. Restarting the phone fixes it, but it's very annoying.
 

shawn.

macrumors newbie
Sep 30, 2012
1
0
Exact same problem here. Have to reboot to fix it. Airplane mode doesn't help ... really annoying! May have to get a replacement phone if it keeps happening.
 

Lrdlrd

macrumors newbie
Sep 30, 2012
1
0
I have same problem with bell also battery drains on several hours. Replaced phone. Same problem.
 

A.D.J.

macrumors newbie
Sep 30, 2012
5
0
I'm in the UK on the 3 network and have just the same problem. Changed from iPhone 4 to 5. The signal on the 4 was always weak but it was constant. On the 5, when the signal is there its stronger but its always switching suddenly to No Service and the only thing that brings it back is a reset.
 

PM-Performance

macrumors 6502
Feb 12, 2012
318
47
Mine was doing this at work when I go to a no service zone, it would not kick back to throw data back as avail and sit in Edge.
I had ATT reset my profile once and remove and readd data once.
Its still not great by any means, but seems to be switching back a little easier.

They said it is an Iphone 5 thing that Apple is aware of.
All the 4's and 4S on the same network in here are fine including my other 4's and 4S
 

sidebox

macrumors member
May 4, 2009
42
0
Same issue for me... I'm in Brooklyn, NY on sprint. My phone keeps going between 0 and No Service. Switching to and from airplane mode works. I didn't realize this was more than just a sprint issue, as my service has been a little spotty for a while, though never this. I talked to sprint about it last week and I am expecting a micro-cell in the mail tomorrow... Hopefully that fixes my issue at home... We'll see.
 

scienide09

macrumors 65816
May 5, 2007
1,384
0
Canada
Same issue. Telus network in Alberta, Canada. Powering and then on seems to fix it, thought it shouldn't be happening in the first place.
 

MuGeN PoWeR

macrumors 68030
Jun 29, 2011
2,599
596
I remember 4s had this issue as well. The only solution was swapping the phone. I hope the issue has been fixed as i am going to buy iphone 5 in upcomin days.
 

bursthead

macrumors 6502
Apr 9, 2010
280
3
i've had the same issue with my iPhone.. I can't even stream without the phone dropping to "No service". This is especially apparent since I also came from a S3 in which I never lost signal.
 

CanucksRock

macrumors member
Jul 17, 2010
47
2
I am having this issue to. Seems for the most part to like to do No Service while in my house. I never had problems with Service on my iPhone 4.

I'm on Virgin - which piggy backs on Bell.

I've already replaced my phone once (on the first day - hardware issue, couldn't connect to network at all)
 

mkstewartesq@co

macrumors regular
Jun 30, 2007
171
24
I had my phone replaced at the Apple store yesterday due to scuffing. The first replacement model they gave me started exhibiting this exact problem in the store, though it seemed to get better. However, it had dropped service again before I even got out to my car so I took it back. Rebooting it a few times did not fix the problem. The genius took it in the back to have a tech examine it; they decided nothing could be done and so gave me yet another new phone, which is perfect so far. So obviously it's an issue for which they will issue replacements.

Mike
 

slicktor

macrumors member
Jul 4, 2010
58
73
I am on Bell and I have this problem as well. Service just disappears and I have to turn off the phone and turn it back on to get service back. Just switching to airplane mode doesnt help :(
 

uller67

macrumors newbie
Oct 7, 2012
2
0
I have had the same problem. Took my first 5 back to store and had SIM card changed, then did full reboot of IOS6. Neither worked. Got a new phone and it still drops Bell network. My wife's 5 does the same thing.
I read on another fortum to go to Settimgs > general > cellular > enable LTE and turn off LTE. Did that an hour ago and will see if it helps.

I'm pretty underwhelmed by this fancy new phone thus far as it doesn't reliably function as a phone!
 

Dennis187

macrumors regular
Jun 26, 2010
222
2
below you
Mine was doing this, I tried rebooting by pressing the 2 buttons, didn't help. It was also reporting incorrect battery life %. Then I just powered it off with the power button only and powered it back on, so far so good. Will see if it's fixed, seems like it is for me.
 

jlake02

macrumors 68020
Nov 2, 2008
2,260
1
L.A.
I'm betting this is an ios6 issue or a problem with the new SIMs. Total conjecture but I bet that's the issue.
 

Jane333

macrumors regular
Jul 6, 2012
126
0
Michigan USA
I am in Detroit Metro and have ATT and have this happen several times. I mostly have LTE (although it is only about 7 mbps down) but, in certain locations I have had no service. So, either LTE or no service.
 

bbydon

macrumors 6502a
May 18, 2005
590
87
ATL
I opened the sim tray to look at the sim in my wife's phone for the same problem. It had a spot on it...so i cleaned it and put it back in. She says it's working fine. If i had the time just go get a new sim, other wise you may just take a look at the sim and see if it has anything on it.