Resolved iPhone 7 Plus - AirDrop stuck on "Receiving..."

Discussion in 'iPhone' started by geekonthepc, Oct 20, 2016.

  1. geekonthepc macrumors member

    geekonthepc

    Joined:
    Nov 5, 2013
    #1
    Hi all

    I've got a small (but annoying) problem with my iPhone 7 Plus and wondered if anyone else has seen the same.

    Essentially, if I pull up my Control Centre, the AirDrop button constantly says "AirDrop: Receiving..." even though I know it isn't! I can switch it on or off by clicking on the button, but it always reverts to the above when off. I've tried disabling AirDrop in Restrictions, and sending/receiving AirDrop files to/from my Mac with no avail. Tried a reboot too. This has been happening since I got it and restored it from my iCloud backup.

    Has anyone else seen this and better still got a fix?

    Cheers all.
     

    Attached Files:

  2. lolitsDanny macrumors newbie

    lolitsDanny

    Joined:
    Sep 29, 2016
    #2
    Yes I had this problem when going from my 6+ to an SE and it would actually say sent on the other persons phone, but I would receive nothing. I ended up wiping the phone and starting from scratch and no issues since then. Seems a little extreme but it worked and hope this helps.
     
  3. geekonthepc thread starter macrumors member

    geekonthepc

    Joined:
    Nov 5, 2013
    #3
    Yeah I just can't seem to get it to stop saying "Receiving...". Don't understand it.

    Don't really want to restore it if I can avoid it but I might not have any choice.

    Any other thoughts anyone?

    Cheers
     
  4. itsmefudge macrumors regular

    itsmefudge

    Joined:
    Jun 10, 2009
    Location:
    Middle of the Pacific
    #4
    What does it say when you have BT and wifi turned on- mine says "receiving Off" when those radios are turned off
     
  5. geekonthepc thread starter macrumors member

    geekonthepc

    Joined:
    Nov 5, 2013
    #5
    Still having grief with this sadly. I tried re-restoring from a backup but no luck. Don't really want to do a clean restore as I'll loose all my texts, call logs, app data etc. Might see if iOS 10.1 fixes it - hopefully that's out shortly.

    Also, if I try and update my phone number in Phone settings, it says "Phone number could not be saved". Is this also a known issue?

    Seems buggy as hell at the moment :(
     
  6. Galacticos macrumors 6502a

    Galacticos

    Joined:
    Apr 5, 2016
  7. recklesslife85 macrumors 6502

    recklesslife85

    Joined:
    Sep 17, 2012
    Location:
    Wales, UK
    #7
    It's not receiving it's just short for receiving off, apple need to change the wording. It's off so don't worry about it
     
  8. geekonthepc thread starter macrumors member

    geekonthepc

    Joined:
    Nov 5, 2013
    #8
    Ohh yeah so it is! Thank you for that clarification! Just put my device and landscape and saw. You're a lifesaver, thank you for taking that off my mind!
     
  9. Aadiscifi macrumors newbie

    Joined:
    Dec 9, 2016
    Location:
    New delhi
    #9
    I was Facing Same Issue Then My Mind suddenly Strikes on Turning Off Restrictions
    Go to Setting - general- restrictions
    Then turn of the restriction pf Airdrop
    IMG_0109.PNG
     

Share This Page