iPhone Bugs

Discussion in 'iPhone Tips, Help and Troubleshooting' started by longofest, Jun 30, 2007.

  1. unintelligible macrumors newbie

    Joined:
    Jul 12, 2007
    #101
    One bug I noticed is that if you have multiple albums by different artists, the iPod function gets all confused. For example, I have two albums both called "Greatest Hits," one album is by Boston and the other is The Offspring.

    So I touch iPod, Artists, Boston, Greatest Hits, Shuffle. All works okay, song plays, album art shows up, a-ok. Turn the iPhone into landscape mode and it shows the correct album art as well as the correct artist, song name, and album. Now I return the iPhone to portrait mode and go back to the Artists screen and scroll down to The Offspring. Same thing here, click shuffle and still looks great. Now turn the iPhone into landscape mode and something is wrong. It shows the correct cover art for The Offspring Greatest Hits, but the Artist is displayed as Boston, and the album art is in the wrong order. It's somehow now in the same location as the Boston Greatest Hits album! If I scroll through cover flow to the next album and come back, it now changes the album art to that of Boston Greatest Hits. Returning the iPhone to the portrait mode restores Album Art to the correct image.

    Also occasionally when experiencing this bug the iPhone will not be able to decide which album art is correct, and will display the generic music symbol for the album art.

    It seems that this is a bug in the iPod logic, because everything works fine through Cover Flow on iTunes on my MacBook Pro. Has anyone experienced this problem with their iPhone? I'm curious if anyone else has a library similar to mine and can reproduce the problem on their iPhone.
     
  2. MacJediDude macrumors member

    MacJediDude

    Joined:
    Jul 12, 2007
    #102
    I have seen similar problems with "greatest hits" CDs, but it seems to be more of an iTunes issue than just on the iPhone. Important to note, this problem seems to only occur with tracks imported from CDs not on iTunes purchased music. Specifically if I sort by album name, rather than by artist.
     
  3. mcoyne macrumors member

    Joined:
    Sep 15, 2005
    Location:
    Durham, NC
    #103
    Safari rendering

    Safari does not render the same on iPhone as latest 2.x version on the desktop. For example see:
    http://www.seaturtle.org/

    In desktop Safari "What's New" box has some text in it that fits fine. On iPhone the text in the "What's New" box is larger (relatively speaking) and flows out of the box.
     
  4. ryano144 macrumors newbie

    Joined:
    Jun 5, 2007
    Location:
    Pittsburgh, PA
    #104
    Confirmed

    I had the exact same problem with a distribution list email. The left half displayed, the right half didn't, and the footer was full length. On my powerbook, it displayed the entire email with no problems. There is an image on the left with a link attached, but other than that, there was nothing too special about the email.
     
  5. soxfantownie macrumors newbie

    Joined:
    Jul 12, 2007
    #105
    Problems Sending Email with Yahoo Mail

    I have been having problems sending emails from the iPhone via my @yahoo.com email account.

    I spent 45 minutes with Apple support via telephone yesterday. They said it is a problem with Yahoo after we went through power cycling, resetting (home+sleep/wake), and re-configuring Yahoo email support (which did solve the problem for about 12 hours).

    See below for a snip from the message I sent to Yahoo support. I'll post the response I get from them, if I get one.

    ---

    I am using an iPhone and am having problems sending email. I have tried sending messages from my iPhone using my Yahoo mail account configured through the shortcut on the iPhone.

    Yesterday I lost about 10 sent messages - I typed them and hit send (while I had EDGE service) and the iPhone indicated they had been sent, but the items did not show up in my sent items folder (on neither iPhone sent folder nor Yahoo Mail online sent folder).

    I contacted Apple support and they walked me through power cycling iPhone, resetting iPhone, and finally re-configuring iPhone for Yahoo Mail via the iPhone Yahoo Add Account shortcut (i.e. setting up Yahoo on the iPhone email client again). This resolved the problem until it began to recur today.

    I have sent several emails from my iPhone, all of which have appeared to send without incident but show up in neither iPhone sent mail folder nor online Yahoo sent mail folder. I have used my Gmail account via iPhone without incident or interruption during these same periods of time, so I know it is a problem between the iPhone and Yahoo mail.
     
  6. maxrobertson macrumors 6502a

    Joined:
    Jun 15, 2006
    Location:
    Jakarta
    #106
    I get that all the time in Mail. I thought it was annoying at first, but it actually can be useful, because I can then drag them into my sent items. On the iPhone, though, it's probably useless and annoying.
     
  7. iMagination macrumors newbie

    Joined:
    Jul 12, 2007
    #107
    Photo Bug

    Photo:
    A couple of times I've had the iPhone lock when adding a photo to a previously saved contact. This happens when you resize the photo before saving it to contact

    Maps:
    I've had the application just quit in the middle of using it. I wish there was a way to find directions from one "recent" search point to another "recent" search point

    Phone
    Like many other users i'm having BAD problems with service level. Bars drop form full to nothing and back to full again. Sometimes a phone call will come in, obviously with enough signal strength to make the phone ring, but when i move the slider to answer the call gets dropped. This really sucks and I'm taking the unit back tomorrow beacuse I just can't stand it anymore

    WiFi
    Have probles with getting weak signal at home when my Macbook has full signal

    EDGE
    Also get random messga ethat EDGE Network is not available.

    iPod
    Same problems with music cutting out, though have not noted what other apps i'm running when this happens

    Does anyone expect Apple to respond to all these issues, or do we just have to wait in the dark for a fix?
     
  8. r6girl Administrator/Editor

    r6girl

    Staff Member

    Joined:
    Sep 6, 2003
    Location:
    Massachusetts
    #108
    i also have a jawbone paired with my iphone. i paired it once and have not had to enter the passcode any more beyond that. it connects quickly to the iphone once i turn it on with no problems. not sure why you're experiencing that...
     
  9. iMagination macrumors newbie

    Joined:
    Jul 12, 2007
    #109
    Calling Card

    I use a calling card to call England from USA. I have typed in the commands necessary to make the call without additional entry. This worked well on verizon. But on iphone after dialing the calling card number, all the automatic inut after the first pause is so slow, the numbers also do not go through crisply, that the calling card auto system does not recognize the input.
    So it now becomes an arduous task to call. ie i have to call the calling card number, then "1" for English, then enter my pin, then the number in England.

    Any suggestions relating to this?
     
  10. hanisch macrumors newbie

    Joined:
    Jul 18, 2007
    #110
    head phone sound volume bug

    sound volume becomes much lower through the headphones. to get the bug, do the following:

    1. put the headpones in the headphone jack.

    2. turn the iphone off: hold down the sleep button for several seconds and then, when the red bar appears that says "slide to power off," slide it.

    3. turn the iphone back on: firmly press the sleep button.

    4. when the home screen appears, press the ipod icon.

    5. play a song (preferably one that you can notice when the sound drops).

    6. set the volume to be reasonbly loud (say 75%).

    7. listen for a little bit to get a feel for how loud it is.

    8. pull the headphones out of the headphone jack: you should notice that the volume setting will shift to whatever it is set for incoming call rings.

    9. put the headphones back in the headphone jack: you should notice that the volume setting should revert to what it was set during step 6.

    10. press play.

    if the sound volume coming out of the headphones drops significantly (even though the volume setting has not changed), you have the same bug that i have. when this happens, setting the volume to 100% is not very loud. to get the volume back up, you have to turn the phone back off and on.

    this problem also happens after you receive a call while listening to music. after using the mic button to end the call, the sound volume goes down even though the volume setting is the same.

    after i noticed this problem, i exchanged my phone. the new one i got has the same problem. also, i tested three display phones at the apple store (5th avenue store in new york), and all three had the same problem.

    i bought my initial phone at the soho store in new york on july 5th. i exchanged it for a new one at the 5th avenue store late last night.

    please post a reply if you have the same problem. i hope this can be fixed via a software update.

    william
     
  11. xfusejc macrumors 6502

    Joined:
    Dec 29, 2006
    #111
    I have one that has been talked about before in this thread already. My iPod stops playing music after a minute or two while browsing with Safari. It just stops automatically.
     
  12. chuckd62687 macrumors member

    Joined:
    Mar 15, 2007
    #112
    "Just Sixteen"

    I noticed today that my iPhone said "Just Sixteen" under the time when locked instead of the date. Has anyone seen this? A reset fixed it, but I found it to be very strange behavior.
     
  13. chuckd62687 macrumors member

    Joined:
    Mar 15, 2007
    #113
    Could it be a reference to the iPhone having 16 applications? I am still puzzled how I got into that state.
     
  14. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #114
    It displays the last song played.....
     
  15. chuckd62687 macrumors member

    Joined:
    Mar 15, 2007
    #115
    That's it!!! The last song I listened to was "Just Sixteen" by Velvet Revolver. Is that a feature or a bug? Is there a way to get the date to display without resetting?
     
  16. unity macrumors 6502a

    Joined:
    Sep 30, 2005
    Location:
    Green Bay, WI
    #116
    Not sure, I never had the problem or need to but then again my interfaces into my car anyway. I would think if you just exit the iPhone app on the phone and lock the screen it will not display. I think it displays it when you pull the ear buds out and it pauses. In essence, the displayed song is the currently paused song.
     
  17. jazzbb macrumors newbie

    Joined:
    Jul 22, 2007
    #117
    Iphone Top 25 problem Fixed

    This problem is odd indeed but the best solution is to uncheck "live updating" in the properties of the smart playlist and all your top 25 songs will appear on your iphone as shown in itunes. If you want to update the list in itunes check "live updating" and then uncheck it and sync. These steps will allow you to accomplish your initial problem.
     
  18. askripko macrumors member

    askripko

    Joined:
    May 10, 2007
    #118
    iPhone Reboot

    Today we will examine a problem which has arisen with iPhone after listening music for a very long time when the battery charge has gone to zero. Having connected it to charge device, i have decided to check up it after few hours. I astonished, I have found out its not responding to any pressing. Pressing of the “On/Off” button and “Home” button did not result anything though during that time iTunes respond to phone.

    To begin with I have decided to try reboot as follows: Press and hold button “Home” six seconds. This command forces to clos all applications which can block iPhone’s work. But it has not worked.
    Further - i have tried simultaneous holding of buttons “Home” and “On/Off”. Then after holding throughout 10 seconds on the screen has been appeared an Apple. I was surprised that iPhone has rebooted for only 4 seconds.

    Now you know. If your iPhone has ceased to respond to commands, try Home+On/Off and show some patience.
     
  19. elguercoterco macrumors newbie

    Joined:
    Jul 23, 2007
    #119
    Ditto.

    I think what's happening is when you leave ipod and use safari, the ipod controls are still there, but invisible to you. My music will stop while browsing safari ONLY when I try to scroll up or down by touching the area where the ipod controls would normally be in vertical mode. (I'm not sure if that's exactly what's happening but it's the best I've been able to come up with...)

    For example, when in landscape mode in safari, my ipod will continue to work while browsing if I touch-scroll in the middle of my iphone and not towards the side (bottom) where the ipod controls would normally be.
     
  20. iphonebuglist macrumors newbie

    Joined:
    Jul 23, 2007
    #120
    We have just started a database for iPhone bugs.

    This website allows you to enter iPhone bugs and feature requests to have them all in one trackable location. Features are being added still but the database is fully functional. Check it out:
    http://www.iphonebuglist.com

    :apple:
     
  21. fireant01 macrumors newbie

    Joined:
    Jul 24, 2007
    #121
    My playlists don't seem to work. if I click a song it repeats it constantly.
    If I click shuffle within the list it sticks on the same song and must be manually clicked/forwared in order to go to the next song in the queue.

    As far as setting the defaults for weather you can do that from the weather screen.
     
  22. fireant01 macrumors newbie

    Joined:
    Jul 24, 2007
    #122
    You can buy an adapter for that. That was mentioned at a number of sites before the iPhone went on sale.
     
  23. dannybishop macrumors newbie

    Joined:
    Jul 28, 2007
    #123
    DNS was my only problem

    FIXED: I could connect to my router (Actiontec gt701-wg) or any address if I knew the IP, but any named web addresses would result in "Safari cannot connect..." So I figured I had a DNS issue. I erased the 192.168.0.1 from iPhone's DNS list (it was first) and left my ISP's DNS. Works great. Safari, GMail, maps, stocks, weather, etc. now all better!

    Why wouldn't iPhone skip the DNS that was failing and move onto the 2nd DNS? Why wouldn't the router's DNS function on iPhone? Seems like an issue worthy of Apple's attention.

     
  24. Character Zero macrumors member

    Joined:
    Apr 27, 2005
    #124
    Sound bug with headphones watching movie

    I haven't tested this listening to music but I have been able to reproduce it with movies. Ok so I am watching a movie and using the headphones that were included with the phone (with the clickable mic). So I want to test out the click on the mic, so I press the mic and the movie pauses. I then click again and the movie resumes. But now I want to adjust the volume. The slider under the Play FF REW does not work any more (what comes up when you tap the screen). Ok so I exit out of the iPod and go back in. I start the movie, and the slider works. I adjust the volume. I then pause and resume using the click mic and the slider no longer works.

    The steps:
    1) Plug in the included headphones.
    2) Play a video through the iPod
    3) Use the slider controls (not the side controls) to adjust volume
    4) Pause the movie with the click mic
    5) Resume the movie with the click mic
    6) Try and adjust the volume with the slider control.
     
  25. riotti macrumors newbie

    Joined:
    Jul 31, 2007
    #125
    This did the trick

    Thanks for the advise!!!! This worked
     

Share This Page